LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-02-2013, 01:15 AM   #1
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Rep: Reputation: Disabled
Macbook loud fans after installing Slackware


Hi,
I finally decided to install Slackware on my Macbook 5.2 ( http://www.everymac.com/systems/appl...dia-specs.html ), in dual boot with Mac OS X, using rEFIT and LILO.

However, I find out that when I am running Slackware, the macbook's fans are more and more loud, as I run slapt-get for example. Although I switched to the generic kernel and do not use X, this issue persists. It's like if the memory or the CPU is overused, although the system is not particulary slow.
In Mac OS X, I did not have this problem.

What should I do? It should be better that I solve this issue before running X.
 
Old 07-02-2013, 02:05 PM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
To my knowledge the fan speed is controlled by OS X depending on the CPU loud .
Can Slackware do the same ?
If not it might be that the fans are running nearly full speed
 
Old 07-02-2013, 03:43 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Check if the power-saving methods for your CPU are working correctly. Please provide the output of
Code:
cpufreq-info
 
Old 07-02-2013, 11:36 PM   #4
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
Here is the output (half in French, sorry):
Code:
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  driver : acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  limitation matérielle : 1.60 GHz - 2.13 GHz
  plage de fréquence : 2.13 GHz, 1.86 GHz, 1.60 GHz
  régulateurs disponibles : ondemand, userspace
  current policy: frequency should be within 1.60 GHz and 2.13 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range. 
  current CPU frequency CPU is 1.86 GHz.
Some additional details: I'm using the x86_64 version.
While running Slackware, the macbook heat is increasing and then the fans start running. I never experienced this on my Mac OS X installed in the other partition.

Last edited by lensilvan; 07-03-2013 at 01:46 AM.
 
Old 07-03-2013, 10:00 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
OK, so power-management for the CPU is working correctly, as it seems. Next thing to check would be the video device. The free nouveau driver has issues with setting the correct clockspeed and lacks power management features, so I would recommend to install the latest Nvidia driver next and see if temperatures decrease.
 
Old 07-03-2013, 10:20 PM   #6
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
I know it's annoying but I can't install xf86-video-nouveau-blacklist, necessary for running the nvidia driver. According to slapt-get, xf86-video-nouveau-blacklist is nowhere to be found. Here are the mirrors I use:
Code:
# This can point to any release, ie: 9.0, 10.0, current, etc.
SOURCE=ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/:OFFICIAL
SOURCE=http://slack.isper.sk/pub/slackware64-14.0/
SOURCE=http://repository.slacky.eu/slackware64-14.0/
SOURCE=http://slackware.org.uk/msb/
SOURCE=http://slackware.org.uk/salix/x86_64/14.0/
SOURCE=http://salix.hostingxtreme.com/x86_64/14.0/
The xf86-video-nouveau-blacklist is required according to: http://docs.slackware.com/howtos:har..._configuration
 
Old 07-04-2013, 05:18 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Just do this
Code:
echo "blacklist nouveau" > /etc/modprobe.d/nouveau.blacklist
as root, it has the same effect as installing xf86-video-nouveau-blacklist.
 
Old 07-04-2013, 07:51 AM   #8
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
I followed the instructions on the wiki, then run as root echo "blacklist nouveau" > /etc/modprobe.d/nouveau.blacklist as indicated.
At rebooting very disappointingly, the error no nvidia graphics adapter probed and coud not insert nvidia: No such device, appeared. I've installed all the drivers and blacklisted the driver nouveau, so where is the logic in this situation???

Last edited by lensilvan; 07-04-2013 at 11:16 PM.
 
Old 07-04-2013, 11:18 PM   #9
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
I don't understand at all. I just checked if /etc/modprobe.d/nouveau.blacklist was created and it is the case.

Code:
blacklist nouveau
I then deleted it and rebooted but this absurdity still occurs. Then I removed the nvidia drivers and X was loaded as before. After I blacklisted again nouveau, X was loaded correctly but my mouse stopped working and I had to remove again nouveau.blacklist.

Last edited by lensilvan; 07-04-2013 at 11:39 PM.
 
Old 07-05-2013, 09:28 AM   #10
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Have you made a xorg.conf/xorg.conf.d file?
 
Old 07-05-2013, 04:12 PM   #11
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
I tried to generate it once but it failed.
It seems that blacklisting nouveau don't have any effects at all on the nouveau driver which keeps running as if nothing happened. I removed nvidia and blacklisted nouveau and I booted normally.
 
Old 07-05-2013, 07:42 PM   #12
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
You need an xorg.conf file or an xorg.conf.d file if you want to use the nvidia drivers. This is why it's not working. You're attempting to blacklist nouveau with nothing to replace it.
You said you'd installed the nvidia drivers. (assuming you have done it correctly) As root, do the following.
Code:
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf
This will create a file called /etc/X11/xorg.conf.d/20-nvidia.conf, containing the following.

Code:
Section "Device"
        Identifier "My GPU"
        Driver "nvidia"
EndSection
The part that says 'Driver "nvidia"', is telling xorg to use the nvidia driver instead of nouveau. Restart your computer to see if you have success.
 
Old 07-06-2013, 08:44 AM   #13
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
I applied all this.
Issues keep going and going. After reboot, I get the same and the same error "No nvidia graphics adapter probed." "Error: could not insert 'nvidia': No such device'".
Fatal server error: no screen found.
 
Old 07-06-2013, 08:38 PM   #14
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
You sure you've compiled and installed it?
 
Old 07-06-2013, 10:51 PM   #15
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 103

Original Poster
Rep: Reputation: Disabled
Yes, sure!!!
I guess it's an issue caused by xorg.conf (Once, I tried to generate one using X -configure but it failed since it detected 2 screens.). Maybe I should try to 'correct' xorg.conf but I can't find it.

Well, I don't know the origin of that issue and what to do.

Last edited by lensilvan; 07-06-2013 at 11:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Slackware on a macbook pro quietguy47 Slackware 14 03-15-2012 09:42 AM
Problem installing Slackware on MacBook Pro eyeontheprize Slackware 1 05-07-2009 09:52 AM
hot and loud macbook pro. even with 0% cpu fans on 6000rpm. ragadab Linux - Laptop and Netbook 4 06-28-2008 04:09 AM
loud fans coolb Linux - Hardware 9 04-17-2006 03:23 PM


All times are GMT -5. The time now is 03:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration