LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-05-2003, 01:55 AM   #1
geru59
LQ Newbie
 
Registered: Nov 2003
Location: Romania
Posts: 2

Rep: Reputation: 0
Question M5451 PCI Al-Link Audio Controler / Red Hat 9


Hi,
My computer is Toshiba satellite 1800-204/ Notebook
I installed from Iso CD Red hat 9 in grafic mode all is going OK with one exception: auto detect of sound card fail

redhat-config-soundcard delivers:

/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o failed
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod trident
failed
sox: Can't open output file '/dev/dsp': No such device
-9


The system log shows messages like this:
kernel: Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio,
version 0.14.10h,
kernel: PCI: Found IRQ 11 for device 00:06.0
kernel: trident: ALi Audio Accelerator found at IO 0x1000, IRQ 11
kernel: ALi 5451 did not come out of reset.
kernel: trident_ac97_init: error resetting 5451.
insmod: /lib/modules/2.4.20-9/kernel/drivers/sound/trident.o:
init_module: No such device
insmod: Hint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters. You may find
more information in syslog or the output from dmesg
insmod: /lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod
sound-slot-0 failed
modprobe: modprobe: Can't locate module sound-service-0-3
PLS help
 
Old 11-09-2003, 11:03 AM   #2
zdAntz
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedore 2
Posts: 22

Rep: Reputation: 15
I got redhat 2 days ago on my toshiba satellite
and I'm having exactly the same problem
I've been everywhere for resolutions, but with no luck yet
the gurus out there plz help us noobs
 
Old 12-05-2003, 02:58 PM   #3
mrde50garfield
Member
 
Registered: Dec 2003
Distribution: Mandrake, Red Hat, Gentoo, Fedora, ClusterKnoppix, Scyld Beowulf
Posts: 52

Rep: Reputation: 15
I have a Tos Sat 1800 and had nothing but bad luck with RH9 and the sound card.

What's bizarre, is that RH8 found the sound card perfectly.

I finally gave up after trying EVERY CONCEIVABLE combination of drivers available for it on the net.

Finally, I went to Mandrake 9.1. Don't use 9.2!
 
Old 02-21-2004, 05:50 PM   #4
pcnvtk
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Smile

I have the same problem using original kernel (2.4.20-8) from RH9. But after I update kernel to 2.4.20-30, the sound works!
 
Old 03-17-2004, 04:44 PM   #5
Guciacz
LQ Newbie
 
Registered: Mar 2004
Distribution: SuSE 10.0
Posts: 7

Rep: Reputation: 0
I think the kernel is the way to go. I updated mine and now I'm enjoying my music.
 
Old 07-19-2007, 10:13 AM   #6
sawadeekap2233
LQ Newbie
 
Registered: Nov 2006
Location: Chernokulaikos
Distribution: Fedora3 Colinux win98
Posts: 22

Rep: Reputation: 15
Quote:
Originally Posted by geru59
Hi,
My computer is Toshiba satellite 1800-204/ Note book
I installed from Iso CD Red hat 9 in grafic mode all is going OK with one exception: auto detect of sound card fail

redhat-config-soundcard delivers:

/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o failed
/lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod trident
failed
sox: Can't open output file '/dev/dsp': No such device
-9


The system log shows messages like this:
kernel: Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio,
version 0.14.10h,
kernel: PCI: Found IRQ 11 for device 00:06.0
kernel: trident: ALi Audio Accelerator found at IO 0x1000, IRQ 11
kernel: ALi 5451 did not come out of reset.
kernel: trident_ac97_init: error resetting 5451.
insmod: /lib/modules/2.4.20-9/kernel/drivers/sound/trident.o:
init_module: No such device
insmod: Hint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters. You may find
more information in syslog or the output from dmesg
insmod: /lib/modules/2.4.20-9/kernel/drivers/sound/trident.o: insmod
sound-slot-0 failed
modprobe: modprobe: Can't locate module sound-service-0-3
PLS help
hi, u encountered this problem in 2004, now 3yrs ago.
Did u solve this problem with RH9? or u hv upgraded to some other distro??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALI M5451 PCI AC-Link - Fedora Core Critter Hart Linux - Hardware 1 07-19-2007 10:00 AM
ALi M5451 PCI South Bridge Audio(rev 01) driver for Debian harlemno1 Linux - Hardware 6 11-10-2004 12:18 PM
ADM8211 PCI and Red Hat 9 Fany Linux - Wireless Networking 2 12-31-2003 01:22 AM
D-Link DWL-650 and Red Hat 9 rlindsley Linux - Hardware 1 09-03-2003 08:40 AM
Red Hat 9.0 and DFE-530TX+ (D-Link) bgrimes Linux - Hardware 1 08-22-2003 03:14 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration