LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-27-2004, 05:55 PM   #1
Keenan
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Rep: Reputation: 0
Question Linux freezes on laptop because of apm


Hello,

I've been running a dual boot on my Compaq Armada 110 laptop for about 6 months now. I am running Windows XP and Fedora Core 1 (which I just installed instead of my Red Hat 9). APM works perfectly in XP but, whenever I close the lid to my laptop in linux, my computer freezes. I cannot get into a command prompt via ctrl-alt-f1. I can't even reset with ctrl-alt-delete. I've tried to diabled apm in the kernel by doing a make xconfig, disabling apm, saving, then doing a make dep. Is there a step there that I am missing?

On the other hand Ive noticed that my computer will freeze when I close the lid during the boot loader too. (GRUB now, but it used to be LILO when I had Red Hat 9) I figured that my Linux kernel isn't even loaded at that point, so I tried disabling apm in GRUB by adding a apm=off line. However, it did not have any effect. I tried the same thing with LILO when I had it, no effect then either.

I've been doing web searches on this topic for months and I've noticed a lot of people saying to disable apm in the BIOS, but my BIOS has no option for it. You would think though that if it works fine in Windows XP then there should be a way to make it work Linux.

Any help would be greatly appreciated. I leave my laptop on all the time and I'de hate for the screen to burn out. Also, sorry for any poor grammar, I'm writing this quickly before work.

Thanks again,
Keenan
 
Old 01-27-2004, 06:06 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
try something other than Fedora first. Even Redhat 9 is better. For the kernel you need to make the new kernel also.

Example
make xconfig
make dep
make clean
make bzImage
make modules
make modules_install
copy /usr/src/linux/arch/i386/boot/bzImage to /boot.
add it to your /boot/grub/grub.conf
don't remove any older kernel images just incase you have a problem.

I would use a newer kernel relaese to build this from
 
Old 01-28-2004, 09:45 PM   #3
epoo
Member
 
Registered: Aug 2003
Distribution: slackware 11, ubuntu 7.04
Posts: 165

Rep: Reputation: 30
you could also try disabling apm and using acpi, from what ive read it seems to work much better.
 
Old 01-29-2004, 01:03 AM   #4
Keenan
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the suggestions. I just changed my linux from Red Hat 9 to Fedora, so I know i have the same prob in rh9. However, I'm willing to give a little more effort before I try other distros. I tried compiling the kernel after disable all power management. It took me a day or so to do it because Im still learning linux. I didn't seem to have any affect. I will try enabling ACPI only now. Looking at the kernel options in make xconfig, it seems that I want to enable Power Management, disable Advanced Power Management, and enable ACPI. Is this correct? I'll give it a get go.

Thanks again,
Keenan
 
Old 08-03-2005, 02:48 PM   #5
Keenan
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Talking SOLVED -- sorta

Hey I'd just like to say that for the record, I finally got a linux distrubution to not freeze whenever I close my lid on the Compaq Armada 110. I installed gentoo using a stage 1 install. In my USE variable i made sure to include "-apm -acpi" this will ensure that everything on the system will be compiled without apm or acpi support, this also includes grub. I wonder now if maybe i could have gotten away with "-apm acpi" and try to get acpi to work. But that is a task for another day. It just feels good to close the lid since i keep that computer on all the time.

Keenan
 
Old 08-04-2005, 05:07 PM   #6
digitalboy74
Member
 
Registered: Aug 2004
Location: Matrix
Distribution: slack currrent
Posts: 61

Rep: Reputation: 16
you can also boot with noacpi as a kernel paramter to temporarily disable it. similar with apm.

on a laptop you will more than likely want acpi enabled. These days acpi will also allow some mild power savings if you are ever unplugged...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
APM on laptop ALMOST working... jdrietz Linux - Laptop and Netbook 0 10-06-2005 07:21 PM
Disabling APM on older laptop litlmary Linux - Laptop and Netbook 2 06-08-2005 09:18 PM
Acer Ferrari freezes (apm and/or acpi problems?) nfisk Linux - Laptop and Netbook 2 03-23-2005 08:05 AM
X server freezes probably due to APM/ACPI XStorm Linux - Hardware 2 01-14-2004 06:47 PM
APM laptop help please Dumpsterm0uth Linux - General 2 02-12-2003 10:29 PM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration