LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-17-2007, 07:14 PM   #1
CalcAndCoffee
LQ Newbie
 
Registered: Aug 2007
Distribution: Slackware 12.0
Posts: 4

Rep: Reputation: 0
Linux 2.6.21.5 to 2.6.22.3: /dev/sda becomes /dev/hda


My system:
Toshiba Satellite A135-S4527
Slackware Linux 12.0

I'm currently using a custom build of kernel 2.6.21.5, under which my hard drive (correctly) appears as /dev/sda and my partitions appear as /dev/sda[1-6].

When I build a 2.6.22.3 kernel (using a slightly updated configuration), however, my hard drive becomes /dev/hda. When I manage to actually boot the system, reiserfsck warns that DMA is off on the hard drive. The system also suffers a severe slow-down.

What seems like the relevant section of the boot messages for the working kernel:
Code:
ata: 0x170 IDE port busy
ata: conflict with ide1
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x000118b0 irq 14
ata2: DUMMY
scsi2 : ata_piix
ata1.00: ATA-7: Hitachi HTS541612J9SA00, SBDOC7DP, max UDMA/100
ata1.00: 234441648 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata1.00: configured for UDMA/100
scsi3 : ata_piix
scsi 2:0:0:0: Direct-Access     ATA      Hitachi HTS54161 SBDO PQ: 0 ANSI: 5
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3 < sda5 sda6 > sda4
sd 2:0:0:0: Attached scsi disk sda
/proc/scsi/scsi (again, under working kernel):
Code:
Attached devices:
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: Hitachi HTS54161 Rev: SBDO
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Output from hal-device:
Code:
17: udi = '/org/freedesktop/Hal/devices/storage_serial_SATA_Hitachi_HTS5416_SB2D01E4J6MJMB'
  storage.media_check_enabled = false  (bool)
  storage.firmware_version = 'SBDO'  (string)
  storage.removable.media_available = true  (bool)
  storage.size = 120034123776  (0x1bf2976000)  (uint64)
  storage.hotpluggable = false  (bool)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_serial_SATA_Hitachi_HTS5416_SB2D01E4J6MJMB'  (string)
  storage.bus = 'scsi'  (string)
  block.major = 8  (0x8)  (int)
  block.is_volume = false  (bool)
  storage.drive_type = 'disk'  (string)
  info.capabilities = { 'storage', 'block' } (string list)
  storage.removable.media_size = 120034123776  (0x1bf2976000)  (uint64)
  info.udi = '/org/freedesktop/Hal/devices/storage_serial_SATA_Hitachi_HTS5416_SB2D01E4J6MJMB'  (string)
  storage.lun = 0  (0x0)  (int)
  storage.no_partitions_hint = false  (bool)
  info.vendor = 'ATA'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  storage.model = 'Hitachi HTS54161'  (string)
  storage.serial = 'SATA_Hitachi_HTS5416_SB2D01E4J6MJMB'  (string)
  storage.originating_device = '/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host_scsi_device_lun0'  (string)
  info.product = 'Hitachi HTS54161'  (string)
  storage.requires_eject = false  (bool)
  linux.sysfs_path = '/sys/block/sda'  (string)
  storage.physical_device = '/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host_scsi_device_lun0'  (string)
  info.category = 'storage'  (string)
  storage.automount_enabled_hint = true  (bool)
  storage.removable = false  (bool)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host_scsi_device_lun0'  (string)
  block.device = '/dev/sda'  (string)
  block.minor = 0  (0x0)  (int)
  storage.vendor = 'ATA'  (string)
  storage.partitioning_scheme = 'mbr'  (string)
Is there some relevant configuration option that differs between the two kernel versions that could be responsible for this? I've revisited the configuration several times and tried rebuilding the kernel, but nothing seems to help. (I will gladly post any other information that may be helpful.)
 
Old 08-18-2007, 04:26 AM   #2
perry
Member
 
Registered: Sep 2003
Location: USA & Canada
Distribution: Slackware 12.0
Posts: 978

Rep: Reputation: 30
Here's something I can spot a mile away?

Is there something wrong with 2.6.21.5 ?

What's this obsession with having the latest and greatest all the time?

When are you going to be a little bit settled with just a simple milestone?

Why not give 2.6.21.5 a chance to get it's bugs worked out before jumping onto the bandwagon of the Jone's Operating System + 1 ?

Don't you think it's bit of an obsession ?

Nobody can answer your question because that version of the kernel still has the paint drying on it.

2.6.21.5 was a major milestone, Slackware testifies to this.

Give it a break!

- perry
 
Old 08-18-2007, 03:50 PM   #3
Fluxx
Member
 
Registered: Aug 2005
Location: Bavaria, Germany
Distribution: Slackware (Current)
Posts: 225

Rep: Reputation: 30
No problem here with kernel

Code:
slack@medino: ~ $ uname -r
2.6.22.3-centr
slack@medino: ~ $
My harddisk is plugged to a SATA-controller in a Medion Notebook. It is /dev/sda.

Here the output of dmesg:

Code:
ata1: SATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x00011100 irq 14
ata2: PATA max UDMA/100 cmd 0x00010170 ctl 0x00010376 bmdma 0x00011108 irq 15
ata1.00: ATA-7: FUJITSU MHV2060AH, 000000A0, max UDMA/100
ata1.00: 117210240 sectors, multi 16: LBA 
ata1.00: applying bridge limits
ata1.00: configured for UDMA/100
ata2.00: ATAPI: HL-DT-ST DVDRAM GMA-4082N, HA01, max UDMA/33
ata2.00: configured for UDMA/33
Device driver target2:0:0 lacks bus and class support for being resumed.
scsi 2:0:0:0: Direct-Access     ATA      FUJITSU MHV2060A 0000 PQ: 0 ANSI: 5
sd 2:0:0:0: [sda] 117210240 512-byte hardware sectors (60012 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
 or FUA
sd 2:0:0:0: [sda] 117210240 512-byte hardware sectors (60012 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
 or FUA
 sda: sda1 sda2 sda4 < sda5 sda6 >
sd 2:0:0:0: [sda] Attached SCSI disk
And here the output of:

Code:
slack@medino: ~ $ cat /proc/scsi/scsi 
Attached devices:
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: FUJITSU MHV2060A Rev: 0000
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: HL-DT-ST Model: DVDRAM GMA-4082N Rev: HA01
  Type:   CD-ROM                           ANSI  SCSI revision: 05
slack@medino: ~ $
Fluxx.

P. S.: I can send you my /usr/src/linux/.config to check where the differences are.
 
Old 08-19-2007, 01:11 AM   #4
CalcAndCoffee
LQ Newbie
 
Registered: Aug 2007
Distribution: Slackware 12.0
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Fluxx View Post
P. S.: I can send you my /usr/src/linux/.config to check where the differences are.
That would be excellent!
It seems like that would be of immense help.
 
Old 08-19-2007, 05:28 AM   #5
Fluxx
Member
 
Registered: Aug 2005
Location: Bavaria, Germany
Distribution: Slackware (Current)
Posts: 225

Rep: Reputation: 30
Your e-mail?

Fluxx.
 
Old 08-21-2007, 12:04 AM   #6
CalcAndCoffee
LQ Newbie
 
Registered: Aug 2007
Distribution: Slackware 12.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks, Fluxx!

Last edited by CalcAndCoffee; 08-22-2007 at 06:02 PM.
 
Old 08-21-2007, 05:41 AM   #7
WKali
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
I have this problem too.

I apologize too, ;-)

WKali

Last edited by WKali; 08-23-2007 at 12:02 PM.
 
Old 08-22-2007, 10:55 AM   #8
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
I would have sworn there is a rule against taking a discussion out the forum areas,
where they are public & can help everybody, into e-mail, where they aren't & don't.

Please do not use e-mail this way. If you think the files are too long or wide,
consider using a pastebin & posting the link here.
 
Old 08-22-2007, 05:59 PM   #9
CalcAndCoffee
LQ Newbie
 
Registered: Aug 2007
Distribution: Slackware 12.0
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by archtoad6 View Post
I would have sworn there is a rule against taking a discussion out the forum areas,
where they are public & can help everybody, into e-mail, where they aren't & don't.

Please do not use e-mail this way. If you think the files are too long or wide,
consider using a pastebin & posting the link here.
I apologize.
The main idea is that IDE must be entirely disabled. Disabling IDE caused my hard drive to function properly (and appear as sda) and my CD/DVD drive to function properly (I hadn't realized that this was misrepresented, too).
 
Old 08-23-2007, 11:17 AM   #10
Fluxx
Member
 
Registered: Aug 2005
Location: Bavaria, Germany
Distribution: Slackware (Current)
Posts: 225

Rep: Reputation: 30
It is also a problem of Slackware's default kernel. I have two notebooks with SATA-controllers and DVD-burner.

Slackware's default kernels (2.6.21.5) use the harddisk as /dev/sda, what is correct and the DVD-burner as /dev/hdc, what causes immense problems. The DVD-drive is slow, dma cannot be enabled, burning is slow and needs 100 % CPU. During burning process there is no go for mouse or other usage of the system. This behaviour cannot be solved with the default kernel. Watching a DVD/VCD is horrible, there is a CPU-usage of 100 % (1,6 GHz Centrino, 1024 MB RAM) and the message, that the system is to slow to play DVDs!!! There are only some single pictures in a FPS of may be 10-12.

Only a recompiled kernel is able to use the DVD-burner in a correct way. To make this work I had to disable in /usr/src/linux/.config in section "Device Drivers" the subsection "ATA" completely.

Then the harddisk is /dev/sda (what is correct as before) and the DVD-burner is /dev/sr0 (what is correct then). No problems to use the DVD-burner, to watch DVD/VCD. The CPU usage is then 17 % with 600 MHz while watching a VideoDVD with mplayer.

I do not know the problem, but kernels of e. g. PCLinuxOS can handle the hardware of the notebook out of the box (/dev/sda and /dev/sr0).

Fluxx.

P. S.: Sorry, I couldn't post the .config here, because 25000 signs are allowed and it had about 76000.

Last edited by Fluxx; 08-23-2007 at 11:23 AM.
 
Old 08-26-2007, 10:08 AM   #11
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
As I said, use a pastebin:
http://pastebin.com/
http://pastebin.ca/
http://pastebin.ca/others.php
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive... /dev/sda1 doesn't show unless I try mounting /dev/sda as vfat finite Linux - Hardware 8 03-10-2009 12:52 AM
Install lilo on external drive (/dev/sda), then boot as INTERNAL (/dev/hda)? slackware-elf Slackware 3 08-18-2007 04:51 PM
Where is my HD? - not /dev/hda or /dev/sda ?? BrianK Linux - Hardware 11 04-24-2007 05:35 PM
[SOLVED] system disk moves from /dev/sda to /dev/sdm gdevaucorbeil Linux - Hardware 4 03-10-2007 09:30 AM
Sandisk USB card Reader not linking /dev/sg0 to /dev/sda acidraven Linux - Hardware 1 06-19-2004 03:56 PM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration