LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 07-29-2005, 03:24 PM   #1
darkarcon2015
Member
 
Registered: Jun 2004
Location: Potsdam, NY
Distribution: Fedora Core 6
Posts: 201

Rep: Reputation: 30
LILO BIOS Check


I have Slackware 10.1 (kernel 2.6.12.2) running on my IBM Thinkpad T42 and for some reason the LILO BIOS Data Check takes forever to complete. On my desktop computer, it takes about 1 second to complete. My Thinkpad takes at least 15 seconds to complete. Can I disable this check or is there anything that I can do to speed this up a bit? Thanks for any help.
 
Old 07-29-2005, 04:15 PM   #2
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
hmmmm what you mean by "LILO BIOS data check" ? As far as I know, LILO doesn't care about the BIOS, unless it does some check that I am not aware of...
Can you give some more details?
 
Old 07-29-2005, 08:40 PM   #3
darkarcon2015
Member
 
Registered: Jun 2004
Location: Potsdam, NY
Distribution: Fedora Core 6
Posts: 201

Original Poster
Rep: Reputation: 30
Right when you pick a distribution other than Windows, it says at the bottom of the screen "Bios Data Check." When it;s done it says Complete and then starts to load the kernel.
 
Old 07-30-2005, 03:04 PM   #4
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Oh, sorry for the confusion... Still this check isn't done by Lilo atmo, as the kernel is already loaded in memory at this point (I think?)

Hmmm I never had problem with this. In newer kernel, there is some options that make some "check" to the BIOS, like, in "Processor in feature" the "Firmware drivers/BIOS enhanced drive call..." or in "Plug and Play" the option "Plug and Play BIOS support".
My guess would be to turn off these 2 options, but I don't really know if these have something to do with the "BIOS check".
 
Old 07-31-2005, 02:54 PM   #5
darkarcon2015
Member
 
Registered: Jun 2004
Location: Potsdam, NY
Distribution: Fedora Core 6
Posts: 201

Original Poster
Rep: Reputation: 30
Sorry, I got the process wrong, it goes like this:
Code:
*LILO Bootloader*
boot: Linux
Loading Linux.....*series of dots until the next line appears*
BIOS data check successful
*Screen clears and the kernel starts to load*
I checked on my desktop and those two lines are diabled as well as on my laptop. Also, my desktop doesn't produce as many dots during the Loading process.

Last edited by darkarcon2015; 07-31-2005 at 02:55 PM.
 
Old 08-01-2005, 12:57 AM   #6
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
the "dots" are the kernel that is tranfered in high memory (RAM). Sometime it can take more time, as example if you are booting from a floppy, as floppy are REALLY slow...

If you see more dots, this only mean your system transfer rate from harddrive to memory is really slow, maybe a dying hdd or just a very old IDE bus that transfert really slowly... What kind of laptop is this?
 
Old 08-02-2005, 08:57 AM   #7
darkarcon2015
Member
 
Registered: Jun 2004
Location: Potsdam, NY
Distribution: Fedora Core 6
Posts: 201

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by darkarcon2015
I have Slackware 10.1 (kernel 2.6.12.2) running on my IBM Thinkpad T42...
1.7 GHz Pentium M Dothan
512 MB RAM

I am booting from the hard disk which has an RPM of 7200.

Last edited by darkarcon2015; 08-02-2005 at 08:58 AM.
 
Old 08-26-2005, 06:54 PM   #8
octinum
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 35

Rep: Reputation: 15
I have the same problem here!
I have an HP-Compaq nx9005 notebook, and it is lilo! I always install grub because of this problem.

I think that happens when the kernel is uncompressing to memory. Here are my observations:

1) Lilo passes this step almost instantly on desktop machines. I installed Slackware on 2 notebook machines, both booted so slow. 4 desktops have no problems.
2) Grub handles this. I don't know how, but Grub never waits.

Why do I not switch to Grub this time? Because I want to solve this!
 
Old 08-27-2005, 10:28 AM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,175

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
I quick google found this:
Lilo has a option to skip this test.
By entering nobd as a boot-argument, or by setting the global flag 'suppress-boot-time-BIOS-data' in
lilo.conf

http://www.wlug.org.nz/lilo(8)
 
Old 08-27-2005, 03:50 PM   #10
octinum
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 35

Rep: Reputation: 15
Solved!

I'm sorry for posting this too late, but I solved the problem just an hour later than my previous reply.
I read lilo.conf manual more carefully(i.e. using my brain instead of another part of my body ) and found the answer there.
Just add the following in /etc/lilo.conf, under Global section:

Code:
compact
Like this:
Code:
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
compact
The file goes on of course, this is just the portion you need.
Note: Maybe you will need to do
Code:
lilo
as root. I did it anyway, because I recompiled my kernel at the same time.
 
Old 02-18-2010, 01:28 PM   #11
shaiss
LQ Newbie
 
Registered: Aug 2009
Posts: 8

Rep: Reputation: 0
Im on ubuntu 10.04 alpha 2 and adding compact worked for me. Lilo was showing the dots and taking 10 seconds even though I'm running of a 15k rpm drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO and BIOS Data Check jrdioko Linux - Software 1 05-03-2009 06:28 PM
lilo bios check takes forever... edong23 Linux - Laptop and Netbook 1 07-17-2005 12:55 PM
lockup after bios check fincher69 Linux - General 2 02-11-2005 04:31 AM
Can't get past bios check NonSumPisces Linux - General 1 06-18-2004 05:35 AM
lilo's bios check too slow ferenkileen Slackware 0 05-06-2004 12:11 PM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration