LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Laptop won't turn off after a new installation (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/laptop-wont-turn-off-after-a-new-installation-521829/)

JAKK 01-22-2007 04:42 PM

Laptop won't turn off after a new installation
 
Hi.I have an IBM Thinkpad 390e, and I had to reinstall slackware due to a stupid error on my part. When it came time for me to recompile my kernel(I use a custom one),I did so without a problem. The kernel works fine,but the laptop won't shut down. It hangs after saying 'system halted'. I tried using 2.6.19.1 instead of the newest kernel,but that didn't help any. APM support was compiled in. The odd thing is that everything worked just fine when I had my old installation of slack. I debated which forum I should put this in, I ended up putting it here because I don't think it's a problem with slack. Thanks.

Matir 01-22-2007 05:28 PM

Did you also add ACPI support? Some machines require that for shutdown.

JAKK 01-22-2007 05:37 PM

I will try adding acpi support,but my old install didn't have it. Thanks
Ok,ACPI compilied in fixed it for some reason,I never had to do that with my last install. Thanks for

EDIT: Ok,something is wrong. If I have acpi,my usb devices aren't detected. If I turn acpi off,then they are detected,but the laptop won't shut down. I'm not sure what is going on,like I said before,I never needed acpi with my old install.

jim-j 01-27-2007 09:34 PM

"apm=power-off" saved me
 
I had a similar problem with my Shuttle ak31 v2 motherboard. First off, this motherboard must not handle ACPI correctly. Ever since FC2 I've had to use "acpi=off" in the grub.conf which disables ACPI in Linux, but everything worked fine (it uses APM instead) in FC2, FC3, FC4 and FC5. Once I upgraded to FC6, however, Fedora would no longer turn off the power on my PC when I shut it down. It would just stop, with the last message on the screen being "System halted.". After much googling I found this page, http://mandrivausers.org/index.php?showtopic=38210
which recommended adding "acpi=off apm=on apm=power-off" to the grub.conf. Since my acpi was already off, and I new my APM was already on I simply had to add "apm=power-off" to my grub.conf and now Linux will shut the power off on my PC after it shuts down!

My relevant grub.conf entry now looks like this:

title Fedora Core (2.6.19-1.2895.fc6)
root (hd0,1)
kernel /boot/vmlinuz-2.6.19-1.2895.fc6 ro root=/dev/hda2 selinux=0 vga=791 acpi=off apm=power-off elevator=anticipatory
initrd /boot/initrd-2.6.19-1.2895.fc6.img
savedefault

Hope this info helps.

SqdnGuns 01-30-2007 04:36 AM

Quote:

Originally Posted by JAKK
EDIT: Ok,something is wrong. If I have acpi,my usb devices aren't detected. If I turn acpi off,then they are detected,but the laptop won't shut down. I'm not sure what is going on,like I said before,I never needed acpi with my old install.

Have you tried the huge26.s kernel on CD 2 in the extra directory? Give that a shot and don't forget to install the kernel modules to from the same directory.


All times are GMT -5. The time now is 07:53 AM.