LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-30-2007, 06:23 PM   #1
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Rep: Reputation: 18
laptop will not shut down completely under Ubuntu 7.04


Hi

I dusted of my older laptop and installed Ubuntu 7.04 on it.
It is an Ibm 600x. P3 500mhz. When I click the shut down
button it starts to shut down by hangs at the the Ubuntu screen
with and empty progress bar. I can flick the power switch and
it will shut down then. the install went correctly otherwise.

Ive seen this problem listed in the threads before but could not
find it again. I recall the fix involved adding a line of code
to a script somewhere.

Thanks in advance for your help
Vanessa
 
Old 11-30-2007, 11:53 PM   #2
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
does entering the command "poweroff" at the command line help? You may need to do via sudo
 
Old 12-02-2007, 03:40 PM   #3
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Original Poster
Rep: Reputation: 18
hi

I tried the sudo poweroff as you suggested, but it goes to the same screen.
the laptop is halted, but will not power off. I read a simular post in the
forum so apparently this is not a unique problem.

Im thinking of doing a reinstall and seeing what happens.

thanks again.

Vanessa
 
Old 12-10-2007, 01:59 AM   #4
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mepis, AntiX, Mint
Posts: 172

Rep: Reputation: 21
Have you tried
shutdown -P

Also do you have any acpi boot option specified in lilo/grub?
 
Old 12-10-2007, 11:02 PM   #5
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Original Poster
Rep: Reputation: 18
Hi

I tried the shutdown -P command, it didnt work either.
the screen in terminal says

sudo shutdown -P
password lllllll

shutdown: time expected
try "shutdown --help" for more information

I also tried it without the sudo option, it errored and said
try "shutdown --help" again.

I did a reinstall before trying any of this, and downloaded all
the updates.

Im not sure what to try next.

You asked

"Also do you have any acpi boot option specified in lilo/grub?"

I dont know where to look for this boot option?
can you tell me where to look?

Thanks again
Vanessa
 
Old 12-13-2007, 03:13 PM   #6
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
Can't help with the automatic shut down, but this:

shutdown: time expected
try "shutdown --help" for more information

is looking for WHEN you want to shutdown. Try:

shutdown -p now

The "now" can also be a time in seconds. Read the man page for more.

Good luck.

C
 
Old 12-13-2007, 10:25 PM   #7
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mepis, AntiX, Mint
Posts: 172

Rep: Reputation: 21
I believe that if you do:
dmesg | less
and then look for command line, you should see what your Linux boot options are.
In fact post the line here.
 
Old 12-15-2007, 11:46 PM   #8
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Original Poster
Rep: Reputation: 18
Hi everyone again

first thanks for all the support in figuring this one out!!

I tried the shutdown -P now and got the same results as before, the computer basically halts and does not shut down.

next I did the dmesg | less and got the following output

0.000000] Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Sun Sep 23
19:50:39 UTC 2007 (Ubuntu 2.6.20-16.32-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] sanitize start
[ 0.000000] sanitize end
[ 0.000000] copy_e820_map() start: 0000000000000000 size: 000000000009fc00 end: 000000000009fc00 type: 1
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 000000000009fc00 size: 0000000000000400 end: 00000000000a0000 type: 2
[ 0.000000] copy_e820_map() start: 00000000000f0000 size: 0000000000010000 end: 0000000000100000 type: 2
[ 0.000000] copy_e820_map() start: 0000000000100000 size: 0000000023ed0000 end: 0000000023fd0000 type: 1
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 0000000023fd0000 size: 000000000000f000 end: 0000000023fdf000 type: 3
[ 0.000000] copy_e820_map() start: 0000000023fdf000 size: 0000000000001000 end: 0000000023fe0000 type: 4
[ 0.000000] copy_e820_map() start: 0000000023fe0000 size: 0000000000020000 end: 0000000024000000 type: 2
[ 0.000000] copy_e820_map() start: 00000000fffe0000 size: 0000000000020000 end: 0000000100000000 type: 2
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 0000000023fd0000 (usable)
[ 0.000000] BIOS-e820: 0000000023fd0000 - 0000000023fdf000 (ACPI data)
[ 0.000000] BIOS-e820: 0000000023fdf000 - 0000000023fe0000 (ACPI NVS)
[ 0.000000] BIOS-e820: 0000000023fe0000 - 0000000024000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
[ 0.000000] 0MB HIGHMEM available.
[ 0.000000] 575MB LOWMEM available.
[ 0.000000] Entering add_active_range(0, 0, 147408) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 147408
[ 0.000000] HighMem 147408 -> 147408
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 147408
[ 0.000000] On node 0 totalpages: 147408
[ 0.000000] DMA zone: 32 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 4064 pages, LIFO batch:0
[ 0.000000] Normal zone: 1119 pages used for memmap
[ 0.000000] Normal zone: 142193 pages, LIFO batch:31
:

I didnt see the command line listed
I hope this gives you some more clues.

the other thing I noticed when I boot the system I get a message about the bios age being
too old. 1999. acpi = forced what ever that means.

I will try to update the bios this week and report what happens.

thanks again for all the help and attention

Vanessa
 
Old 12-16-2007, 03:17 AM   #9
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mepis, AntiX, Mint
Posts: 172

Rep: Reputation: 21
Ok for boot options, if you are using Grub look in /boot/grub/menu.lst. There you will see your choices for booting, and your boot options should be on the line for kernel.
For lilo, see /etc/lilo.conf.

Also for your bios, I doubt there are updates for it around (too old).
You may have to specify acpi=off if your bios' implementation of acpi is flakey.
Not sure how to specify apm instead of acpi, might be automatic if acpi is turned off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error partioning hard drive "Windows did not shut down completely" emissary Linux - Laptop and Netbook 3 12-25-2005 01:43 PM
suspend when I shut my laptop down PinRojas Linux - Laptop and Netbook 6 07-08-2005 08:08 AM
CentOS wont shut down completely! twysm Linux - Newbie 3 06-12-2005 08:23 AM
CentOS wont shut down completely! twysm cAos 2 06-12-2005 02:35 AM
How to get laptop LCD to shut off deviant03 Linux - Hardware 0 01-25-2005 06:39 AM


All times are GMT -5. The time now is 02:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration