LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 11-02-2004, 11:35 PM   #1
blizunt7
Member
 
Registered: Mar 2004
Distribution: Fedora Core 1,2,3, RHEL3,4,5 Ubuntu
Posts: 272

Rep: Reputation: 30
Laptop Fan + overheating


Hey all, I am running FC1 on a HP pavilion zt1185. My laptop overheats excessively. Is this an issue with the linux coding for controling fan speeds??? Sometimes my computer will shutdown unexpectedly, and when i feel the bottom, i can hardly keep my hand on it, it is so damm hot. HOwever if i run a small fan over the lapton blowing downward towards the keyboard, my machine will run fine for days upon days.

Anyone might have any suggestions how to keep my notebook cool all the time??

thanks
 
Old 11-03-2004, 01:02 AM   #2
Xolo
Member
 
Registered: Jul 2004
Location: The Netherlands
Distribution: Mandrake, Knoppix, Coyote Linux, RedHat
Posts: 354
Blog Entries: 3

Rep: Reputation: 30
Sounds like it's running completely without any APM support. there's been another post on that same subject here but I can't find it now. i'll try locating it when I get back from work.
 
Old 11-03-2004, 01:23 AM   #3
blizunt7
Member
 
Registered: Mar 2004
Distribution: Fedora Core 1,2,3, RHEL3,4,5 Ubuntu
Posts: 272

Original Poster
Rep: Reputation: 30
thatd be great thanks...

what is the difference between APM and acpi???? if any...


Josh
 
Old 11-03-2004, 03:14 AM   #4
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
acpi is kind of a newer power-management function with more options/features than apm.
acpi allows the os to take over more controll about the various aspects of pm in linux like fan, button and sleep (but also irq-routing,...). it depends on your system what would work better, acpi or apm. older boxes usually just have apm support, while a acpi implention will give you additional control over some aspects of powersaving or cooling. use the one that better fits your needs if you have both avail.

you should get information about supported features of your laptop by viewing the "dmesg" output and logfiles messages.
there has to be daemon (apmd/acpid) running on your sys taking care of pm-events also. it's likely configureable via files in /etc/acpi, /etc/apm or ... (read docs).
there is a laptop-howto and "linux on mobiles" documentation somewhere. google for further info.

sl mritch.
 
Old 11-04-2004, 11:29 AM   #5
darkseed2g3
Member
 
Registered: Sep 2003
Location: Philadelphia ,Pa
Distribution: Fedora Core 1 BABY !!! YEA
Posts: 67

Rep: Reputation: 19
check out i8k , with in i8k there is a program called i8kfan that you can use with gkrellm , or on the console . It will help you control the temps that the fans kick on and at what speeds.
 
Old 11-05-2004, 10:25 PM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Your laptop should be acpi. I think there is a physical problem with some of the fans used in the laptops. Mine does not overheat as long as there is airflow under it but one of the fans is bad and only comes on when it feels like it. Makes noise when it does come on. Make sure they are all spinning when it's hot. Also be sure the bottom is on a flat surface not blocking the vents. Some of the fans might be running all of the time and some only come on when the temperature goes up. When it shuts off again turn it on and check the fans. Then enter the BIOS and check the temp.


You might want to check this too... (the names may differ, check in /proc)


cat /proc/acpi/thermal_zone/THRM/temperature
temperature: 57 C

david@zeus:~> units
1948 units, 71 prefixes, 28 functions

You have: tempC (57)
You want: tempF
134.6

You can also check the shutoff temp in proc/acpi

david@zeus:~> cat /proc/acpi/thermal_zone/THRM/trip_points
critical (S5): 72 C
passive: 70 C: tc1=4 tc2=3 tsp=40 devices=0xcdfa5880



My guess is if it's shutting down acpi is working and you have a problem.
 
Old 11-15-2004, 06:17 AM   #7
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
Quote:
My guess is if it's shutting down acpi is working and you have a problem.
Not necessarily. If the processor is overheating, it will shut down causing the computer to shutdown or reboot. I had that problem with a desktop. I couldn't figure out why it would reboot spontaneously or occassionally shut down for no apparent reason. When I opened the case I saw a cable had blocked the fan from turning and caused the processor to overheat. I secured the cable, but the performance was shot after all the overheating. I ended up upgrading the whole motherboard, so not entirely a bad thing, but not so easily done with a laptop.

You may need to recompile your kernel to support acpi.
 
Old 11-15-2004, 06:48 AM   #8
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
If it just powers off then I would tend to agree somewhat.

However I would consider shutting down to mean Linux shuts down. Which means ACPI isworking like it should be or it would not shutdown. It would burn up.

So once again my guess is you have a problem with one or more of the fans.
 
Old 01-19-2005, 06:39 PM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Don't forget the obvious, airflow blockage. Vacuum the dust off the fan screen periodically.
 
Old 07-04-2005, 10:57 PM   #10
windowsrefugeeX
Member
 
Registered: Apr 2004
Posts: 272

Rep: Reputation: 30
What up linux world

Well I am having the same problem! my laptop overheats.

I was trying to install gentoo on my laptop (Pentium4 2.5Ghz, 512 DDR 2100, 40gig Fujitsu, SiS650, and a Cd burner 40X) but the darn thing shuts off while compiling. So i checked the Hard drive with Fujitsu software and guess what! the laptop shuts off. So i put a fan under neath, open the ram lid and the Fujitsu software to check the hard drive worked fine.

So once again I tried to install gentoo with the fan at the bottom but no luck it shuts down while compiling, I guess when the cpu is running @ 100% for a while ( like 2mins) it shutdown!

I read this forum yes i will check my fans they seem to be a bit dusty, how do i know that? will I open up my laptop and she is not looking pretty fellas hehehehehe. Anyhow i have one question I know there's a gel that goes on top of CPU chip and in between the heat sink for desktops and or towers, does the same apply for a laptop?? I am guessing yes therefore as soon as the shops open I am going to buy some gel and yes of course a little vacuum for my computers hehehe

Any suggestions?

PS my laptop also runs windows xp, now it runs fine under windoze xp however I never compile under windoze, and yes it did shutdown on me under windoze while i was watching a dvd (once again cpu eh). Actually that was the first time it did that (shutdown)

I forgot it shuts off under windoze if i play 3d games if i play something like ut2k4 it plays for about 5mins then it shuts off darn thing eh

Last edited by windowsrefugeeX; 07-04-2005 at 10:59 PM.
 
Old 07-05-2005, 08:11 PM   #11
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
It seems that lately the laptops are using 1.3 - 1.6 GHz processors. A hot processor is hard to deal with in a laptop.


If I do not ventilate my laptop it will get hot. In Windows my machine will overheat to the point of lockup. In linux it just shuts down properly. I guess I need to configure something in windows.


One of these days I'm gonna change the fans.


I have it sitting on a platform I got at Best Buy with two fans powered by usb. It helps.



If your going to clean it with air avoid spinning the fans with the compressed air. They will spin beyond the rated speed and could be damaged.

Last edited by DavidPhillips; 07-05-2005 at 08:14 PM.
 
Old 07-06-2005, 03:21 AM   #12
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 304

Rep: Reputation: 30
This is a problem that I had with my laptop for awhile. If your computer can't even last long enough to get through compiling the kernel (understandable), then this may help. If it works it will slow down your CPU so that hopefully it lasts longer before overheating.

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

If this returns performance, then your CPU is running full speed all the time. With a P4 2.5, it probably isn't supposed to be doing that. If it returns userspace, it may also be set to run full speed.

next:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

If this ONLY returns performance, then this isn't going to work for you. However, if there are other options, this might help. My computer only has performance and userspace, so I'll give you directions based on what I do. I'm not completely sure what the other choices may be, but I believe there is something like powersave, which would run you at the lowest possible frequency, and ondemand, which would ratchet up the cpu speed as it is needed. (I think ondemand is just for AMD processors, but there must be something similar for newer pentiums.) Anyway, here are the directions...

If userspace showed up in the last space, this may work.

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
this will show you the frequencies your cpu can run at in kilohertz

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
this will show you the speed your cpu is running at now

you need root priveledges for the next steps so:

su
enter your root password

echo -n "userspace" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

that replaces performance with userspace which basically is a manual mode of control

in the next line, replace somefrequency with one of the frequencies that you got when you looked at scaling_available_frequencies, it should be one that is lower than your current frequency, this will make your processor much less likely to overheat for awhile, it'll also use less power

echo -n "somefrequency" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

If this DOES work for you, I made my computer boot up to a lower speed by basically adding some of these lines to the end of the file:

/etc/rc.d/rc.local

Then I added in some alias commands so now I can easily change my speed manually by going into a terminal and typing freq2 or something like that. Anyway, hope that helps.
 
Old 07-06-2005, 04:01 AM   #13
mcgrew
Member
 
Registered: May 2005
Location: West Virginia, US
Distribution: Gentoo
Posts: 56

Rep: Reputation: 15
The laptop should never overheat unless something is physically wrong with the fan, or perhaps the acpi is not turning on the fan. At least that's my thought. Mine get's a little hot when compiling, but never hot enough to shut down, even after compiling at full speed for hours (granted mine's max temp is 100C, but any laptop with a lower max should have adequate cooling to keep it below the max.)

Some acpi's are not fully compatible with linux, so some things work, others don't. Some just require extra modules (like mine).

Try booting the kernel with acpi=off as a kernel argument. this will turn off acpi, and apm (hardware control) should take over. If this helps, your problem is probably with acpi. If not, you probably have something wrong with your fan.

If you dual-boot, do you have this problem in windows? If not, it's almost certainly an acpi issue.

Have you had this problem since you installed linux, or just recently? Yet another clue. Recently = hardware, Always = acpi(software)

I don't know much about normal operating temperatures really, so maybe I'm way off base here, but maybe some of this will help.
 
Old 07-06-2005, 06:23 AM   #14
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 304

Rep: Reputation: 30
I don't have a whole lot of faith in hardware vendors. I know more than one person with new laptops that routinely overheat when running high performance games for an hour or more. The worst case is someone who has a special cooling unit that he sets his laptop on and the laptop STILL overheats on occasion. I think the problem is manufacturers trying to put ever higher "numbers" into lighter weight machines. If they are that close to the edge on an operating system that they are supposedly made for, then even minor issues with ACPI not functioning as well as it should could make for an unstable machine I think.
 
Old 07-06-2005, 02:32 PM   #15
windowsrefugeeX
Member
 
Registered: Apr 2004
Posts: 272

Rep: Reputation: 30
Thanks folks!


springshades
Tha's a nice little trick and I'll give it a try but i (currently) do not have a fully install system on my laptop. I am stuck in stage2 gentoo it seems texinfo does not want to compile that's another thread hehehe.

mcgrew
Good point when I first bought this laptop something like 3yrs ago. It worked fine! I could play 3d games like utk4 no problems for hours, watch dvds no problem under windoze. However at the time there was no 3d accelation for my video card (SiS650) for linux I was ran SuSE 9.0 and then MDK9.2 with no problem. later getting close to three years that's when problems began, the first time my laptop shutdown was while watch a dvd under windoze. log story short , the laptop will run fine under windows as long as the cpu is not running @ 100% for more than 2mins, for linux will since my dvd-cdr drive broke I try to install gentoo but it shuts down due to overheating.

So now cleaned the heat sink it's an aluminum, put some thermal compound. and well it worked fine for a couple of hours but then it shutdown. So i am sort of stuck, do i go and buy a new copper heatsink for my laptop see if that works? or is it my mobo?
ps the ram also gets hot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop Overheating maelstrom209 Suse/Novell 12 10-07-2006 05:37 AM
linux laptop overheating causes shutdown jtan325 Linux - Hardware 6 02-23-2005 09:29 AM
Laptop overheating with SuSe9.2 DesKelly Suse/Novell 0 11-22-2004 02:45 PM
Laptop fan karan101 Linux - Laptop and Netbook 3 10-26-2004 04:41 PM
Fedora overheating my Compaq Presario 2500 laptop rahuldabane Fedora 1 03-19-2004 07:46 AM


All times are GMT -5. The time now is 03:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration