LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 05-23-2006, 05:15 AM   #1
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Rep: Reputation: 15
keymap gone bad FC5


Hi all, fairly new to Linux and this has me stumped, I have searched the forums also. Problem: installed FC5 (in gnome)on my acer travelmate (I have this on my desktop also and love it). Whilst following the Stanton Finley install guide I came to the point of, install flash. At this point it requires the Selinux policy to be changed to ""Allow the use of shared libraries with Text Relocation" then reboot. After reboot the keymap was wrong in that most of the letters were replaced by numbers. I had this problem before but I couldn't say if it happened at the same point in the installation. Rebooting in failsafe cures the problem so I assume it's some script that's been altered. I have tried resetting the policy but had no luck. Maybe I should disable Selinux? On a top note I haven't used windoze in 3 months, result! next job pcmcia wireless card. thanks for any help.
 
Old 05-24-2006, 02:50 AM   #2
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
You said that
Quote:
Rebooting in failsafe cures the problem
That means the kernel parameters of the failsafe option is working.
I think that you are using lilo, so you can check the /etc/lilo.conf file (if you are using grub then /boot/grub/menu.lst) to determine kernel parameters.
You have to check out the following man pages.
man reset
man bootparam
check the TERM environment variable.
you might just be set.
If you still have problems ,tell me.

Last edited by rch; 05-24-2006 at 02:53 AM.
 
Old 05-25-2006, 02:50 AM   #3
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks for quick the reply rch, I'm reading the docs but to be honest since my knowledge is minimal I'm struggling. I'm booting with grub and I compared the "menu.lst" on the laptop with my desktop. the only difference seems to be the absence of references to rootnoverify and chainloader. When I've finished my chores I can do some more reading

 
Old 05-25-2006, 03:04 AM   #4
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
At first I thought that you had the problem of vidmode(check man rdev) ,but now I think that vidmode is not the problem.
Could you elaborate a bit about what you said
Quote:
After reboot the keymap was wrong in that most of the letters were replaced by numbers.
 
Old 05-25-2006, 06:47 AM   #5
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
When I log in as either root or user most of the keys on my laptop are returning numbers. for example pressing L gives a 3. This has now happened twice following SF's guide. It may not have anything to do with modifying the Selinux policy, I can't be sure. I'd rather cure the problem than try a third install. As before there is no problem when I use Gnome Failsafe mode. maybe something is pointing at another script in the startup procedure.
 
Old 05-26-2006, 02:53 AM   #6
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
You can try
loadkeys -d (for loading default keymaps) which is the file defkeymap.gz
The keymaps are in
/lib/kbd/i386/qwerty/
(in your case you can choose uk.map.gz)
load your keymap through loadkeys
(read the man pages)
Also read manpage of
dumpkeys,
 
Old 06-01-2006, 04:17 PM   #7
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
Sorry it's taken a while to get back, been busy with some other things. I have found that by keeping the function key pressed whilst typing the keys work correctly. So now maybe the keyboard selection is causing a problem. at the moment the xorg.config file shows "pc105"
thanks for your help so far.
 
Old 06-01-2006, 05:51 PM   #8
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
Hi rch I'm back,
Found that the problem can be cured by pressing the function key and the numlk at the same time but on reboot into user the keys misbehave again until I repeat the above. I tried this while browsing and I came across numlockx.sh in /etc/X11/xinit/xinitrc.d.

any ideas?
 
Old 06-02-2006, 11:45 PM   #9
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Hi
Well through the method I described ,you could fix the messed up keymaps in shells(terminals).I think that your runlevel is 5(that is you directly move into the graphical display (could be checked from /etc/inittab)), which means the xorg.conf plays a big role in the keymap. What you could do is change the XKbLayout field in xorg.conf to "uk" or "us". I think that it will help.
As for the xinitrc, the xkb(/usr/X11R6/lib/X11/xkb) is the way keyboard is handled by X server. (Though the configurations are written in xorg.conf). So , read the README.config file in the aforementioned directory. Maybe the problem is with XkbModel or XkbLayout.
Hope it helps.
Robin
 
Old 06-15-2006, 05:45 PM   #10
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
hi rch,
Yes I'm in runlevel 5, tried the commands and making the changes to XKb to no effect.
 
Old 06-15-2006, 10:19 PM   #11
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
I could not understand , maybe you should try to rewrite the xorg.conf.
First of all change the runlevel to 3(from /etc/inittab)
Then when you log into a tty(terminal) ,type setup and choose X configuration.
It will rewrite xorg.conf.Maybe that will help!
 
Old 08-21-2006, 06:47 AM   #12
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
have you resolved your issue?
 
Old 08-23-2006, 05:15 PM   #13
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
sorry, not yet, have been away a while and since I got back only used fc5 on my desktop. Iĺl start again but as a note, it doesn occur until after the initail login. then the keys go pear shaped.
Oh by the way, apologies rch...
 
Old 08-24-2006, 01:07 AM   #14
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
you say the problem disappears when you hit the FN + NUM key
that sounds like your system (after the install) seems to have the num lock activated by default. apparently the following command should help
#numlockx off
this will turn off the numlock for x windows
you might have to install this command
#yum install numlockx
read the following - it is quite short
http://www.fedorafaq.org/#numlock
 
Old 11-07-2006, 02:10 AM   #15
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks Nathaneal, bit late I know (coming back) I had some probs with the fdd, mechanical so had to delve (it's an old laptop). Unfortunately half the keys now don't work. oops! I'm sure your advice will help some one else but thanks again.
 
  


Reply

Tags
keymapping


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad PBR sig when trying to boot FC5 install DVD Eccentric Linux - Newbie 6 11-29-2006 10:38 AM
Boot failure after upgrading FC5 TR3 to FC5 Official Release fsb1284 Fedora 3 03-25-2006 09:12 AM
FC5-test3 --> FC5-release - Anyone tried it? GL1800 Fedora 5 03-22-2006 04:16 PM
Changing the keymap Per M. Linux - Newbie 2 11-01-2005 10:54 AM
Keymap with ,, ulfob Slackware 1 02-04-2004 11:40 AM


All times are GMT -5. The time now is 08:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration