LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 03-10-2009, 06:04 PM   #1
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Rep: Reputation: 0
Keyboard-layout keeps resetting itself to "USA" on reboot.


Hi

I have a new Acer Extensa 5230E, that came preinstalled with Linpus Linux.

When i change the keyboard-layout, i right-click where it says "USA" on the top-panel, then select Keyboardsettings > Layout > Add > and then selects Denmark in the drop-down box. This works fine, i can then switch between "USA" and "DnK" (Denmark).

But, everytime i turn my laptop off and on, i need to do this procedure again, as it allways boots up with "USA" layout selected.
How do i change this, so it will boot up with Danish (DnK) layout selected?

Here are two screenshots of what im talking about:
www.donati.dk/pic1.jpg Look where it says "DnK".
www.donati.dk/pic2.jpg

This is my first experience with Linux, so everything is new to me, and i may have overlooked something obvious

Brgds

Finn Donati

Last edited by Donati; 03-10-2009 at 06:07 PM.
 
Old 03-13-2009, 03:09 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
Welcome to LQ.

The keyboard change, you can do with Keyboardsettings > Layout > Add
will only be temporary, as you already found out.

Linux Linpus is based on Fedora, and usually you would do these
commands for a change :
1) su
2) system-config-keyboard .... and select DK in the GUI window.

If the tool is missing, please do the change in the file
/etc/sysconfig/keyboard

My file in Fedora 10 :
Code:
KEYBOARDTYPE="pc"
KEYTABLE="dk-latin1"
LAYOUT="dk"
MODEL="pc105"
OPTIONS=""
VARIANT=""
.....
And have a look in /etc/X11/xorg.conf .
If you have a line like this :
Option "XkbLayout" "dk"
it should of course be edited to "dk"
if the text is "us".
( Not all 'xorg.conf' have this line, and today
certain X's will even work without an 'xorg.conf'
present.)
.....

Last edited by knudfl; 03-14-2009 at 06:05 AM.
 
Old 03-15-2009, 03:00 AM   #3
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks, that worked out perfect
 
Old 03-18-2009, 09:52 PM   #4
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
There is still one small problem with my keyboardsettings.
Now, on every reboot, i get this message:

>X-systems keyboardsettings is different from your current Gnome keyboardsettings.

>Expected settings model "pc105", layout "us" and no options, but found
>the following: model "pc105", layout "dk" and no options.

>What settings do you want to use?

>And i have the option to click "Use settings for X" or "Use Gnome setup".

Note: Actual message is in Danish language, so its not an exact quote..

How can i get rid of this message?
 
Old 03-19-2009, 09:31 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
I tried this : grep -i dk .config/*

And got : .config/user-dirs.locale : da_DK

.config/ is a hidden folder and 'user-dirs.locale'
is a textfile, please change the text ( us ? ) to da_DK

May be it's then OK ?
......

Last edited by knudfl; 03-20-2009 at 10:13 AM.
 
Old 03-19-2009, 07:08 PM   #6
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
grep -i dk .config does'nt give any output on my system?

Code:
[root@localhost Donati]# grep -i dk .config
[root@localhost Donati]#
I found the user-dirs.locale file in /Home/Donati/.config/user-dirs.locale, and changed the text to da_DK, but that did'nt kill
the message i get on reboot.

Any tips appreciated
 
Old 03-20-2009, 12:42 PM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
@fulbar
Please don't just write [SOLVED] without saying [HOW] ! Explain what you did, or give us the link you followed.
But otherwise, "Welcome to LQ".
 
Old 03-21-2009, 05:36 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
@ tredegar : Post # 7 was never edited to [SOLVED], but seems
to be a container for the "advertising links"
Post # 7 was reported.

____________________________________________________________________

@ Donati

You could try this
' grep -i us .config/* '
' grep -i us .gnome2/* '

.......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Simple, easy - I need a USA keyboard layout WebDesignHero Debian 4 03-16-2008 02:05 PM
Disabling hardware detection of "reboot" and "power" buttons Sabinou Linux - General 3 08-21-2006 08:03 PM
Tiny Sofa 2.0 - I thought "halt", "reboot" were only root command ?? sorcerer Linux - Distributions 1 08-21-2004 04:28 PM
"<" ">" Keyboard keys on Toshiba Satellite 1005-s157 dont work RodCas Linux - Laptop and Netbook 1 05-08-2004 05:22 PM
Removing "shutdown" and "reboot" in logout window nearfar Red Hat 1 10-07-2003 12:33 PM


All times are GMT -5. The time now is 03:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration