LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 01-15-2006, 06:16 PM   #1
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Rep: Reputation: 0
keyboard and touchpad stop responding randomly


Hi I have very weird problem with hanging touchpad.
It happens randomly.
It happens almost every day. Some times two times a day (rarely even more). Some times it works without problems.
It happens only then touchpad is in use (finger is in movement).
Then touchpad "hangs" keyboard also stops responding.
I looked into /var/log/Xorg.0.log after last crash (I have to power off: unplug AC and battery) using knoppix but there was nothing useful. So I looked into /var/log/kdm.log and found this:

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux kohvi 2.6.13-15.7-default #1 Tue Nov 29 14:32:29 UTC 2005 i686
Build Date: 07 October 2005
Before reporting problems, check WHEREISURLICANTPOSTBECAUSEOF5POSTS
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 15 21:36:32 2006
(==) Using config file: "/etc/X11/xorg.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called
SynapticsCtrl called.
SetClientVersion: 0 8
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.
SynapticsCtrl called.

I don't know anything about kernel or drivers. Any ideas ? Some boot options to try ?
 
Old 01-17-2006, 11:07 AM   #2
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
what laptop do you have? and which version of suse?
 
Old 01-17-2006, 04:14 PM   #3
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Mitac 8050QDA
Suse 10
 
Old 01-21-2006, 07:36 AM   #4
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Hmm.
It was on about one hour and then around 13.00 keyboard and touchpad suddenly stopped working.
I had bittorrent running (windows minimized) and just started firefox and then it happened (before I could type something in address bar) !
So I left it like that (keyboard/touchpad not responding) for 1 hour (Fn keys not working/CtrlAltDel not working/power button not working) and it still was in the same state (keyboard/toucpad not working) except
monitor has switched off (kde power control settings).
Some more facts about hangs:
lcd does not turn itself anymore off if I close the lid;
if I then unplug AC adapter the led that indicates if AC is plugged in doesn't turn off;
X (or whatever it is called) is still happily running;
sound will play to the end of playlist.

Feels to me like something wrong with acpi...

Last edited by damnsynaptic; 01-21-2006 at 08:02 AM.
 
Old 01-21-2006, 02:44 PM   #5
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
Quote:
Feels to me like something wrong with acpi...
same here..have you tried booting with acpi=off
 
Old 02-01-2006, 09:31 AM   #6
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
I think this is important:

I got hang (again touchpad movement) during suse installation. It hanged on the screen there you make software changes, choose keyboard layout, configure bootloader, partitioning ...
19.01.2006 01.30

what should it tell me ?
can I exclude synaptics driver from the list of possible causes ?
is it hardware ?

or statical electricity ?
 
Old 02-01-2006, 06:02 PM   #7
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
ahh this is so frustrating
I couldn't imagine that using touchpad could be living hell (latest hang 02.02.2006 ~ 00:50 browsing Kmenu).

Only choice left is to disable touchpad and use USB mouse unless someone here knows other workaround I haven't tried yet.

I have one more question :
I use reiserfs for my / and /home partition
Is it reliable filesystem with so many hangs ?


And I have my own theory why this is happening:
I'm beginning to think that I have to be grounded (keep my feet on the ground) to avoid hangs...(ofcourse I have to delay now switching back to USB mouse and keep my feet on the ground to test my theory)

my crashes...

13.01.2006 14.30
14.01.2006 22.45
15.01.2006 13.40
16.01.2006 00.30
16.01.2006 22.30
19.01.2006 01.30
21.01.2006 13.10
21.01.2006 18.20
21.01.2006 19.30
21.01.2006 23.45
21.01.2006 23.50
22.01.2006 22.00
24.01.2006 21.01
27.01.2006 20.57
30.01.2006 16.40
31.01.2006 14.15
02.02.2006 00.50
 
Old 02-01-2006, 06:46 PM   #8
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Update!
I just had another hang 02.02.2006 ~ 01.35
this time I tested diablo2 demo with wine (impressive software)

Now I can say that my theory about "grounded feet" was wrong.

Let's see now remaining causes:
acpi [does it matter now if I got hang during installation? (see my previous reply)]
hardware [heat ? bios ? (it can't be memory - 4 tests with memtest without errors)]
 
Old 02-02-2006, 11:36 AM   #9
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
connection between touchpad and acpi ?

I think I'm getting closer to somewhere (hell?)

I have done bios update.
I removed intel pro wireless mini pci card and modem card.
I did complete reinstall of suse10 today with gnome selection this time.

surprise ! hang still occured (on fully updated system)
02.02.2006 ~ 18.00 (again during movement on touchpad)

This time I noticed something else:
http://img526.imageshack.us/img526/5...alerror3zr.png
as you can see it is green... but it was immediately grey after hang !

Enough for me. It's time to give up and connect usb mouse.
 
Old 02-02-2006, 11:40 AM   #10
damnsynaptic
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
connection between touchpad and acpi ?

I think I'm getting closer to somewhere (hell?)

I have done bios update.
I removed intel pro wireless mini pci card and modem card.
I did complete reinstall of suse10 today with gnome selection this time.

surprise ! hang still occured (on fully updated system)
02.02.2006 ~ 18.00 (again during movement on touchpad)

This time I noticed something else:
http://img526.imageshack.us/img526/5...alerror3zr.png
as you can see it is green... but it was immediately grey after hang !

Enough for me. It's time to give up and connect usb mouse.
 
Old 06-05-2006, 06:40 PM   #11
chevyou
LQ Newbie
 
Registered: Jun 2005
Posts: 8

Rep: Reputation: 0
Me too

This is also happening to me on an HP dv5000 running 10.1
Any ideas? You ever fix this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard and Mouse randomly stop working link470 Linux - Hardware 3 08-03-2005 08:12 PM
keyboard and mouse stop responding coffeedemon Linux - Software 8 11-09-2004 04:53 PM
Downloads Stop Randomly xbaez Red Hat 1 10-09-2004 11:42 PM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 03:19 PM
Keyboard and Mouse Buttons stop responding h2gofast Linux - General 2 02-26-2004 01:32 PM


All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration