LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-11-2003, 05:42 AM   #1
jweasley
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Rep: Reputation: 0
Kernel Panic : VFS Unable to mount root fs on 09:02


Hello,

I just used up2date to get the most recent kernel for redhat 8. When I reboot the computer the boot halts and I'm unable to run even a command line. Here are the last three messages:

*****************************************
EXT2-fs: unable to read superblock

isofs_read_super : bread failed, dev = 09:02, iso_blknum=16, block=32

Kernel Panic : VFS : Unable to mount root fs on 09:02

*****************************************

I'm using a Dell Inspiron 4000 800Mhz, 40GB, 256Meg, BIOS A20.
The machine dual boots w/ Win2K using Paragon bootmanager.

Is there a way to back down to the old kernel? Is there any type of emergency boot mode?

I'm a newbie and really stuck! Any help is greatly appreciated.

Thanks,
Joe
 
Old 10-11-2003, 05:43 AM   #2
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
This is a common problem and it has only a few causes. First, check the device XX:YY against the list of device codes; is it the correct root device? If not, you probably didn't do an rdev -R, or you did it on the wrong image. If the device code is correct, then check carefully the device drivers compiled into your kernel. Make sure it has floppy disk, ramdisk and ext2 filesystem support built-in.
copied from http://www.csse.uwa.edu.au/programmi...k-HOWTO-7.html

Last edited by arunshivanandan; 10-11-2003 at 05:44 AM.
 
Old 10-12-2003, 03:33 PM   #3
jweasley
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Pretty damn lucky!

I've found a temporary solution to this. If I understand correctly, it looks like the boot loader thought the root partion was on a raid device (09:02). Weird. I'm able to boot the new kernel by pressing F2 when booting and manually entering the root parameter:

root=/dev/hda3

Now I just need to figure out where to put this so that I don't have to manually enter it each time. I thought it might be grub.conf, but that doesn't seem to do it and I can't find etc/lilo.conf. Does anyone know how do to this? Am I headed in the right direction?

Also, how can I determine which bootloader the OS is actually using?

Thanks again,
Joe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic: VFS: Unable to mount root fs in 08:02 sebas_turu Debian 10 01-21-2008 01:04 AM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - Hardware 8 02-24-2004 06:11 PM
Kernel panic: VFS: Unable to mount root cmlo Linux - Software 4 05-20-2003 02:25 AM
Kernel panic: VFS: Unable to mount root cmlo Linux - Newbie 3 05-17-2003 07:55 PM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - General 6 05-26-2002 02:30 PM


All times are GMT -5. The time now is 08:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration