LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   kernel 3.1 and newer blanks my screen (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/kernel-3-1-and-newer-blanks-my-screen-916387/)

Shark82 11-30-2011 10:12 AM

kernel 3.1 and newer blanks my screen
 
Hi

I have ArchLinux, XFCE. From the kernel 3.1 onwards when my power-manager blank the screen i cannot recall my screen back to normal, switching consoles doesn't help - it remains black. I have to suspend and then wake a computer to go back to normal. I know it is the kernel because if i downgrade it the problem disappears. My logs are in this forum thread:https://bbs.archlinux.org/viewtopic.php?id=130052
I posted it here too because for some time now nothing happened regarding the issue.

Thanks for all help

corp769 11-30-2011 12:24 PM

Are you using ACPI or APM power management on your computer? I am thinking it may be a combination kernel/hardware issue; If you use ACPI, try disabling it before you boot into your 3.1 kernel via kernel options in grub, and let me know if it does anything.

Shark82 11-30-2011 02:44 PM

Actually, problem is solved. Look at my upper link. The problem was some acpi lines in my kerneline: acpi_osi=Linux acpi_backlight=vendor.
Now the problem is gone away tough i have to tackle with my volume buttons now. Volume down and mute stopped working. Oh well, at lest black screen has gone :)

Thanks for help.

corp769 11-30-2011 03:08 PM

Yup, that will do it :p
I had a similar problem in the past on my old acer.... I had to spend some time tweaking the ACPI settings to get everything just right.

griffinwebnet 11-30-2011 09:34 PM

OK how exactly did you fix this? I have a feeling, that the problem i am having may be solved the same way...

Shark82 12-01-2011 06:20 AM

Quote:

Originally Posted by griffinwebnet (Post 4538803)
OK how exactly did you fix this? I have a feeling, that the problem i am having may be solved the same way...

In my kernel line (in grub menu) i had this "acpi_osi=Linux acpi_backlight=vendor". When i removed it everything was fine.

griffinwebnet 12-01-2011 01:01 PM

wow im an idiot if i had simply looked at your link i would have seen that :P Anyways thanks and ill see if that works for me :)

-JL


All times are GMT -5. The time now is 09:05 PM.