LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 03-10-2011, 07:22 PM   #1
FatalKeystroke
LQ Newbie
 
Registered: Oct 2010
Distribution: Debian Squeeze x86_64, #!crunchbang 9.04
Posts: 26

Rep: Reputation: 1
"Keep laptop running on lid close?" + "ssh via crossover cable?"


I have a Dell Latitude C800, "Delphi", and a Dell Inspiron 1545, "Hermes."
I currently have Debian Squeeze installed on Hermes and wish to install the same on Delphi.
Before I proceed with this, I want to make sure that I can have Delphi running even when the lid is closed. Can I do this and if so how?
I also want to be able to connect a crossover cable between the two and ssh from Hermes into Delphi. Also can I do this and how?

Any help greatly appreciated, thank you.
 
Old 03-10-2011, 09:31 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,243

Rep: Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557
I can't help with the Latitude. Have you done any testing?

This is normally a hardware call--the software has no way of knowing the lid is closed unless the hardware tells it.

I would feel around for a hardware shutdown switch (read "little tiny button" that's activated when the lid is closed, like a refrigerator light button). If it does have such a switch and if the switch works in Linux (the software has to understand the hardware call), perhaps it can be disabled in BIOS.

I have in Inspiron 1545n. I just closed it four five minutes and reopened it. It did not shut down, but it did lock the screen. Xscreensaver wanted a password when I re-opened it.

As near as I can tell, it has no hardware shutdown switch.

Edit:

The crossover cable is a hardware thing. It should work as long networking is set up properly. It's been a long time since I used a crossover cable--it was in the NT4 days.

You might need to set static ip addresses, since there would be no DHCP server to assign a DHCP address. That's something to investigate.

Last edited by frankbell; 03-10-2011 at 09:34 PM.
 
Old 03-10-2011, 11:11 PM   #3
FatalKeystroke
LQ Newbie
 
Registered: Oct 2010
Distribution: Debian Squeeze x86_64, #!crunchbang 9.04
Posts: 26

Original Poster
Rep: Reputation: 1
I still want the Inspiron to behave normally when closed (it will be used as my main laptop).
With your Inspiron, it's likely that you simply have the settings configured to simply sleep when closed and resume (bringing up the screensaver password prompt) when reopened. This was my default configuration for both Ubuntu and Debian on mine.
As to testing, I have only been able to do so much as turn off the screen on the Latitude by using "vbetool dpms off" this turns off the screen but the lid must still remain open. In the BIOS I didn't find anything that had the effect I want.
I don't mind setting a static IP for the Latitude, I would actually prefer one, but the Inspiron I would like DHCP since it's required for my home wifi.
 
Old 03-10-2011, 11:19 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,231

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
In power management on my laptop the options are:
Blank Screen
Hibernate
Suspend
Shutdown

I haven't tested Blank Screen function, maybe that might leave os running & only blank Screen.
 
Old 03-10-2011, 11:24 PM   #5
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,231

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
I checked it & when I opened lid it prompt for password.
 
Old 03-10-2011, 11:25 PM   #6
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,243

Rep: Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557
When I re-opened the lid, everything was as I had left it.

The only power management I have configured is the screen power management in xscreesaver.

I don't normally mess with hibernate or sleep because, frankly, I think they are mostly silly and unnecessary.

Regarding the ip address, if I understand, you are wanting the crossover cable to work on the ethernet port while that box is also connected to the internet via the wireless. I've never needed to do that, but you will have to make sure the ethernet and the wireless settings are such that they can deal with that. Never done it, can't make suggestions, but I'm sure you can find data about how to manage two different eth connections on the web.

I am going to post this, close LQ, then close the lid of my computer. I'll let you know what I find in the morning!
 
Old 03-11-2011, 07:24 AM   #7
FatalKeystroke
LQ Newbie
 
Registered: Oct 2010
Distribution: Debian Squeeze x86_64, #!crunchbang 9.04
Posts: 26

Original Poster
Rep: Reputation: 1
Preferably I would like to keep the Inspiron connected to the wifi this entire time. The Latitude however I would like to remain disconnected from the web.

So:
Code:
Internet 
    | 
  wifi
    | 
    V 
Inspiron --crossover--> Latitude (no internet)
 
Old 03-11-2011, 08:53 AM   #8
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,243

Rep: Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557
I opened the lid of my Dell 1545n this morning, entered a pword into xscreenlock, and everything was as I left it. All programs left running were still running and responsive to the keyboard and mouse, new programs started without incident, and the 4:00 a. m. podracer cron job ran successfully. I am currently copying the downloaded podcasts to my podplayer.

Conclusion: The computer did not sleep or hibernate.

Edit: Also, last night about an hour after I closed the lid, I connected to it over my network from my file server and was able to see the contents of the shared directory without incident.

Last edited by frankbell; 03-11-2011 at 09:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese laptop "Founder"," unichrome Pro" graph card drivers? Sirr Linux - Laptop and Netbook 3 07-14-2007 02:31 AM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM
"NIM thread blocked" & "Deadman Switch (DMS) close to trigger" errors sosborne Linux - Networking 1 06-28-2006 03:07 PM
could "no route to host" be caused by non-crossover cable? brandonweinberg Linux - Networking 13 01-31-2004 10:47 AM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration