LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Jockey doesn't detect Nvidia proprietary driver Kubuntu 12.04 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/jockey-doesnt-detect-nvidia-proprietary-driver-kubuntu-12-04-a-4175421122/)

matrix13 08-08-2012 09:53 PM

Jockey doesn't detect Nvidia proprietary driver Kubuntu 12.04
 
I installed kubuntu 12.04 on my laptop Dell XPS15 and I noticed that my battery is draining out too fast. I decided to install Nvidia proprietary driver for my Nvidia GeForce GT 525M card. I installed the following packages through konsole (I was following a page I found through google)..
Code:

apt-get install nvidia-current
apt-get install nvidia-current-updates

After rebooting I did,
Code:

jockey-text --list
and I received the error message.
Quote:

ERROR:root:Could not find any typelib for AppIndicator3
Jockey didn't find my Nvidia card. And all my desktop effects and konsole transparency disappeared.
nvidia-settings asked me to create a xorg.conf file and I did
Code:

nvidia-xconfig
After reboot my display resolution is 800x640.
I am stuck here. Uninstalling the Nvidia drivers did not give me a better display.

Any help will be greatly appreciated.

EDDY1 08-08-2012 11:51 PM

Install "nvidia-settings"
The spelling may not be correct but it's GUI tool.
Just checked the spelling is correct atleast for Debian.

matrix13 08-09-2012 02:43 AM

Thank you EDDY1. I did try nvidia-settings. It gave me the following message.
Quote:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.
I did as it asked me to do. I created the xorg.conf file using nvidia-xconfig. When I restarted the machine, the display resolution became 640x800. My xorg.conf file said that the monitor is 'unknown'.

Then I have uninstalled all the nvidia proprietary drivers and installed nouveau. Restart did not change the resolution. I deleted xorg.conf file and after reboot everything started working fine (desktop effects, screen resolution etc.).

But still my battery drains very very fast.

Can you please guide me in how to install Nvidia proprietary drivers in my machine?

EDDY1 08-09-2012 02:50 AM

Quote:

I did as it asked me to do. I created the xorg.conf file using nvidia-xconfig. When I restarted the machine, the display resolution became 640x800. My xorg.conf file said that the monitor is 'unknown'.
I think you confused retart x server with rebooting.
Read section #3
http://www.howtoforge.com/enabling-c...a-geforce-8200
The stop restart command depends on which desktop environment you have, this 1 is gnome or gdm

matrix13 08-10-2012 09:41 AM

I am using KDE and I tried to restart KDM. That also did not solve the problem. Nvidia-settings still says I am not using the Nvidia driver. Also I found in google that a lot of people are unable to configure the Nvidia card especially when it has Nvidia Optimus in it. Mine is a similar case. So I installed bumblebee. Now it seems the battery is draining a little slow. I feel it is better than the previous configuration. I will go with this until I get a solution to the original problem.
Thank you for your help EDDY1.

Vikt3r 08-10-2012 07:28 PM

Jocke made all right because your laptop use nvidia optimus technology.
Install bumblebee
Code:

su
apt-get add-repository ppa:bumblebee/stable
apt-get update
apt-get install bumblebee
reboot

after for starting games and other with nvidia video card
Code:

optirun NameOfTheApplicationOrGame
if your resolution is not a max
Code:

su
apt-get install mesa mesa-utils
reboot
su
cvt X(X of the screen) (space) Y(Y of the screen) 60 = cvt 1280 768 60

{# cvt 1366 768 60
1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"  85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync}

after copy 2nd string and write:
xrandr --newmode <2nd string> = xrandr --newmode "1368x768_60.00"  85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
next step is writing
xrandr --addmode default "name of the mode my modes' name is "1368x768_60.00"" = xrandr --addmode default "1368x768_60.00"
xrandr --output default --mode "name of the mode my modes' name is "1368x768_60.00"" = xrandr --output default --mode "1368x768_60.00"

Sorry for mistakes, i'm Russian

matrix13 08-13-2012 07:28 AM

Thank you Vikt3r, and welcome to LQ.
I have installed bumblebee. But, it seems like it is not able to access the Nvidia card when I run an application using optirun. I get these error messages.
Quote:

$optirun glxspheres
[ 234.567355] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 234.567453] [ERROR]Aborting because fallback start is disabled.
Any idea?

Vikt3r 08-14-2012 04:34 AM

Quote:

Originally Posted by matrix13 (Post 4753063)
Thank you Vikt3r, and welcome to LQ.
I have installed bumblebee. But, it seems like it is not able to access the Nvidia card when I run an application using optirun. I get these error messages.

Any idea?

remove nvidia-current and other nvidia packages, after install proprietary driver from nvidia.ru and reinstall bumblebee.(If you have nvidia packages or install it.)

Write me your kernel version. I think your kernel compiled without acpi changing support.
I had dell n5110 and Intel HD GF 3000 + nvidia geforce 525m and Debian Wheezy, all work all right! Kernel 3.2.4-686-i386-pae and ubuntu 10.04 with kernel 3.4.2-rc2-686-i386-generic-pae

khm... kubuntu 12.04 must suppotr acpi changing..aptitude remove nvidia-current xserver-xorg-video-nouveau
And install prop. driver from nvidia off. site


All times are GMT -5. The time now is 06:42 AM.