LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 08-08-2012, 10:53 PM   #1
matrix13
Member
 
Registered: Nov 2006
Location: Kerala, India
Distribution: Arch Linux
Posts: 134

Rep: Reputation: 25
Jockey doesn't detect Nvidia proprietary driver Kubuntu 12.04


I installed kubuntu 12.04 on my laptop Dell XPS15 and I noticed that my battery is draining out too fast. I decided to install Nvidia proprietary driver for my Nvidia GeForce GT 525M card. I installed the following packages through konsole (I was following a page I found through google)..
Code:
apt-get install nvidia-current
apt-get install nvidia-current-updates
After rebooting I did,
Code:
jockey-text --list
and I received the error message.
Quote:
ERROR:root:Could not find any typelib for AppIndicator3
Jockey didn't find my Nvidia card. And all my desktop effects and konsole transparency disappeared.
nvidia-settings asked me to create a xorg.conf file and I did
Code:
nvidia-xconfig
After reboot my display resolution is 800x640.
I am stuck here. Uninstalling the Nvidia drivers did not give me a better display.

Any help will be greatly appreciated.

Last edited by matrix13; 08-09-2012 at 07:26 AM. Reason: typo error
 
Old 08-09-2012, 12:51 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,247

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Install "nvidia-settings"
The spelling may not be correct but it's GUI tool.
Just checked the spelling is correct atleast for Debian.

Last edited by EDDY1; 08-09-2012 at 12:55 AM.
 
Old 08-09-2012, 03:43 AM   #3
matrix13
Member
 
Registered: Nov 2006
Location: Kerala, India
Distribution: Arch Linux
Posts: 134

Original Poster
Rep: Reputation: 25
Thank you EDDY1. I did try nvidia-settings. It gave me the following message.
Quote:
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.
I did as it asked me to do. I created the xorg.conf file using nvidia-xconfig. When I restarted the machine, the display resolution became 640x800. My xorg.conf file said that the monitor is 'unknown'.

Then I have uninstalled all the nvidia proprietary drivers and installed nouveau. Restart did not change the resolution. I deleted xorg.conf file and after reboot everything started working fine (desktop effects, screen resolution etc.).

But still my battery drains very very fast.

Can you please guide me in how to install Nvidia proprietary drivers in my machine?
 
Old 08-09-2012, 03:50 AM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,247

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Quote:
I did as it asked me to do. I created the xorg.conf file using nvidia-xconfig. When I restarted the machine, the display resolution became 640x800. My xorg.conf file said that the monitor is 'unknown'.
I think you confused retart x server with rebooting.
Read section #3
http://www.howtoforge.com/enabling-c...a-geforce-8200
The stop restart command depends on which desktop environment you have, this 1 is gnome or gdm

Last edited by EDDY1; 08-09-2012 at 03:51 AM.
 
Old 08-10-2012, 10:41 AM   #5
matrix13
Member
 
Registered: Nov 2006
Location: Kerala, India
Distribution: Arch Linux
Posts: 134

Original Poster
Rep: Reputation: 25
I am using KDE and I tried to restart KDM. That also did not solve the problem. Nvidia-settings still says I am not using the Nvidia driver. Also I found in google that a lot of people are unable to configure the Nvidia card especially when it has Nvidia Optimus in it. Mine is a similar case. So I installed bumblebee. Now it seems the battery is draining a little slow. I feel it is better than the previous configuration. I will go with this until I get a solution to the original problem.
Thank you for your help EDDY1.
 
Old 08-10-2012, 08:28 PM   #6
Vikt3r
LQ Newbie
 
Registered: Aug 2012
Posts: 3

Rep: Reputation: Disabled
Jocke made all right because your laptop use nvidia optimus technology.
Install bumblebee
Code:
su
apt-get add-repository ppa:bumblebee/stable
apt-get update
apt-get install bumblebee
reboot
after for starting games and other with nvidia video card
Code:
optirun NameOfTheApplicationOrGame
if your resolution is not a max
Code:
su
apt-get install mesa mesa-utils
reboot
su
cvt X(X of the screen) (space) Y(Y of the screen) 60 = cvt 1280 768 60

{# cvt 1366 768 60
1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync}

after copy 2nd string and write:
xrandr --newmode <2nd string> = xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
next step is writing
xrandr --addmode default "name of the mode my modes' name is "1368x768_60.00"" = xrandr --addmode default "1368x768_60.00"
xrandr --output default --mode "name of the mode my modes' name is "1368x768_60.00"" = xrandr --output default --mode "1368x768_60.00"
Sorry for mistakes, i'm Russian
 
Old 08-13-2012, 08:28 AM   #7
matrix13
Member
 
Registered: Nov 2006
Location: Kerala, India
Distribution: Arch Linux
Posts: 134

Original Poster
Rep: Reputation: 25
Thank you Vikt3r, and welcome to LQ.
I have installed bumblebee. But, it seems like it is not able to access the Nvidia card when I run an application using optirun. I get these error messages.
Quote:
$optirun glxspheres
[ 234.567355] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 234.567453] [ERROR]Aborting because fallback start is disabled.
Any idea?
 
Old 08-14-2012, 05:34 AM   #8
Vikt3r
LQ Newbie
 
Registered: Aug 2012
Posts: 3

Rep: Reputation: Disabled
Quote:
Originally Posted by matrix13 View Post
Thank you Vikt3r, and welcome to LQ.
I have installed bumblebee. But, it seems like it is not able to access the Nvidia card when I run an application using optirun. I get these error messages.

Any idea?
remove nvidia-current and other nvidia packages, after install proprietary driver from nvidia.ru and reinstall bumblebee.(If you have nvidia packages or install it.)

Write me your kernel version. I think your kernel compiled without acpi changing support.
I had dell n5110 and Intel HD GF 3000 + nvidia geforce 525m and Debian Wheezy, all work all right! Kernel 3.2.4-686-i386-pae and ubuntu 10.04 with kernel 3.4.2-rc2-686-i386-generic-pae

khm... kubuntu 12.04 must suppotr acpi changing..aptitude remove nvidia-current xserver-xorg-video-nouveau
And install prop. driver from nvidia off. site

Last edited by Vikt3r; 08-14-2012 at 05:47 AM.
 
  


Reply

Tags
nvidia drivers


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Proprietary NVIDIA Driver Troubleshooting winter_ken Debian 3 05-03-2012 05:48 AM
nvidia proprietary driver, nvidia-settings and how to configure panning bluebox Linux - Hardware 1 03-11-2011 04:21 PM
Nvidia, Arch Driver vs proprietary... Alexvader Arch 4 08-13-2010 09:39 AM
Has anyone tried the proprietary driver with an Nvidia gt310m? damgar Linux - Hardware 1 04-18-2010 04:05 AM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 07:51 AM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration