LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Intel Pro Wireless 2915, slow connection, slackware 10.2, kernel 2.6.14.4 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/intel-pro-wireless-2915-slow-connection-slackware-10-2-kernel-2-6-14-4-a-450945/)

salviadud 06-02-2006 11:47 AM

Intel Pro Wireless 2915, slow connection, slackware 10.2, kernel 2.6.14.4
 
I got a Dell Inspiron 710m. My wireless connection DOES work. But, I am pretty mad at the results. For example. If I use the computer on windows and connect to my Samba file server I can read that my connection with the server is at about 600 Kbps max. It usually drops to 200 Kbps after a while. Still, no slowdowns, I use that for streaming video on my LAN.

Now, in Linux, I use mplayer and a samba mount. Or better yet, I can mount it via NFS. BUT, my damn wireless connection seems to be limited. My max speed is about 100 Kbps, I can't get it to over that. Is it my router? (I got a 2wire Homeportal 1800HW). Maybe It's my Intel Pro Wireless firmware that loads with hotplug? My drivers maybe malfunctioning? Iwconfig settings? My Kernel is outdated?

If anyone has had this same problem I would surely like to know.

salviadud 06-02-2006 04:31 PM

just upgraded to udev-0.93
linux kernel 2.6.16.19
no difference...... what could it be?

salviadud 06-03-2006 02:39 PM

Well now, it seems the linuxquestions.org community has left me to die!!!!

welll... i found out my prob anyways. so for, any of you who have problems with this, read along.

if your output of iwconfig gives an output of 11Mbps on the bit rate, you can probably chunk it up a bit.
Code:

iwconfig wlan0 rate 54
booom! headshot.

thats how i fixed it... i love answering my own questions.


All times are GMT -5. The time now is 11:30 PM.