LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Intel PRO/Wireless 2200BG (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/intel-pro-wireless-2200bg-205813/)

henriette 07-16-2004 08:46 AM

Intel PRO/Wireless 2200BG
 
Hi.
Has anyone here any experience getting a Intel pro/wireless 2200BG to work under (Mandrake 10) linux?
Apparently it's only suppose to work with a 2.6.4+ kernel (see link below) and since I'm running a 2.6.3-something kernel I probably need to do something about this - help please.

-Henriette



http://ipw2200.sourceforge.net/

henriette 07-18-2004 07:57 AM

Re:
 
Anyone????

hornbeck 07-18-2004 06:35 PM

That card is not supported yet. The drivers you speak of are only a barebones driver to tell if you have the card, but nothing functional. If you read the site it will explain that they are in the very early design stage. I to have this card and even with the linuxant drivers you have to have at least a 8k stack for your kernel or they will not work. I have just resorted to using a pcmcia card.
John

aoshi 01-21-2006 07:05 AM

Similar problem
 
I have installed Gentoo on the MAXDATA 600I Laptop. It has the infamous Intel PRO/Wireless 2200BG card (the laptop is based on Centrino technology). My kernel is 2.6.14. My ipw2200 version is 1.0.0

When I am doing "modprobe ipw2200", there are no error messages, but the card is still not seen by the system (for example ifconfig -a gives no result for this card, neither does iwconfig). I have noticed some error in /var/log/messages, which I do not understand:

Jan 21 13:37:33 rhinoceros kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
Jan 21 13:37:33 rhinoceros kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation
Jan 21 13:37:33 rhinoceros kernel: ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 18 (level, low) -> IRQ 19
Jan 21 13:37:33 rhinoceros kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
Jan 21 13:37:43 rhinoceros kernel: ACPI: PCI interrupt for device 0000:01:04.0 disabled
Jan 21 13:37:43 rhinoceros kernel: ipw2200: probe of 0000:01:04.0 failed with error -5

And in the syslog:
Jan 21 13:37:33 rhinoceros kernel: ieee80211_crypt: registered algorithm 'NULL'
Jan 21 13:37:33 rhinoceros kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
Jan 21 13:37:33 rhinoceros kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation
Jan 21 13:37:33 rhinoceros kernel: ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 18 (level, low) -> IRQ 19
Jan 21 13:37:33 rhinoceros kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
Jan 21 13:37:43 rhinoceros kernel: ipw2200: ipw-2.2-boot.fw load failed: Reason -2
Jan 21 13:37:43 rhinoceros kernel: ipw2200: Unable to load firmware: 0xFFFFFFFE
Jan 21 13:37:43 rhinoceros kernel: ipw2200: failed to register network device
Jan 21 13:37:43 rhinoceros kernel: ACPI: PCI interrupt for device 0000:01:04.0 disabled


LSPCI gives the following results for this card
rhinoceros ~ # lspci -vvv -s 01:04
01:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
Subsystem: Intel Corporation Unknown device 2702
Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin A routed to IRQ 19
Region 0: Memory at fe8fd000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=1 PME-

rhinoceros ~ # lspci -s 01:04 -n
01:04.0 0280: 8086:4220 (rev 05)


The vendor ID/device ID seem to be correct for the driver - when doing "modinfo ipw2200" I get, among others, this line:
alias: pci:v00008086d00004220sv*sd*bc*sc*i*


I am going to do two more things, but I don't really believe they can help:
1. Downloading latest version of ipw2200 from source forge (1.0.10; I am currently using 1.0.0)
2. Looking into the sources (but I don't have any experience with drivers sources)

aoshi 01-22-2006 12:54 PM

Solved by installing new version
 
I downloaded and installed newer version of ipw2200 (1.0.8), together with the firmware. I just used Gentoo's emerge. This solved the problem.
Before this, I was using the ipw2200 module which I compiled as part of the kernel sources. This didn't work. Maybe I was missing the firmware files.

iwishikne 05-20-2007 02:50 PM

ipw2200 fixed
 
I have the same wireless driver and you have to turn the wireless connection on. This is how I got mine to work in sabayon.

HOWTO: Enable wireless with ipw2200

Emerge ipw2200-firmware
Version 3.0 works with sabayon

note: you will need to know which ethX (0,1,2) your wireless is set to. Mine was set to eth0

modprobe ipw2200

To use WEP-encryption load the module:
modprobe ieee80211_crypt_wep


Additionally add ipw2200 to /etc/modules.autoload.d/kernel-2.x (where x stands for your kernel's minor version) to automatically load the modules when booting example:
File: /etc/modules.autoload.d/kernel-2.6
ipw2200

The ipw2200 is supported however it requires a bit extra to get it working. Before the wireless adapter will function you need to issue the following command:

iwconfig ethX txpower on

where X is the number of your device. Once this command is issued you should see "radio on" in the details for your wireless adapter if you issue an iwconfig command.
if you want to have it done whenever you start Linux, you can create a small script that will do it for you: create a file with you favourite text editor where you'll put those lines es. nano -w radioon:

!/bin/bash
iwconfig ethX txpower on

where X is the number of the device once done copy that file in /usr/bin/ and as root do: chmod 755 radioon and then add it to the boot with rc-update add radioon

reboot and use knetworkmanager to enter your wep key

You can also manually put your network key and ip address in by doing this as root:

ifconfig ethX internal ip address ex. 192.168.1.?
iwconfig ethX essid (name of your network) key (network key)
route add default gw (your gateway)

The last part can be found in the gentoo handbook

Mine works great. If someone knows an easier way please post it.


All times are GMT -5. The time now is 09:58 PM.