LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-21-2008, 02:51 PM   #1
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Rep: Reputation: 30
Intel 82801G volume control issue


I've seen mention of this somewhere else but I don't know what the fix is (although it sounds like one does exist from what I surmise).

I recently installed Debian (testing) on my laptop - a HP Pavilion dv8000. Everything works fine except one thing - the audio. It works but the volume can only be controlled with the PCM audio slider (not the normal volume slider). It's annoying to have to open the audio controls every time I want to mute or change volume - the buttons on my laptop work, but they change the master volume (which as I said doesn't change the actual volume for some reason).

Is there some setting or something where I can tell the system that these two sliders need to be switched or something?

here's that particular line of the "lspci" output if anyone cares:
Code:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
 
Old 01-22-2008, 02:54 AM   #2
MattJUK
Member
 
Registered: Dec 2006
Location: UK
Distribution: Ubuntu 8.10
Posts: 80

Rep: Reputation: 15
I had the same problem with Ubuntu 7.10 and I solved this by going to :

System > Preferences > Sound

At the bottom of the "Devices" tab, make sure the 'Default Mixer Tracks' is set to HDA Intel and then make sure that PCM is selected/highlighted in the box below.
 
Old 01-22-2008, 06:58 PM   #3
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Original Poster
Rep: Reputation: 30
D'oh! Thanks, that worked! I thought it would be something with the driver or something. . . can't believe I overlooked that.

For anyone else with the same issue, you also need to right-click on the Volume Control icon in the corner and click "Preferences" and make sure these same options are selected.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't use my microphone with Intel 82801G (ICH7 Family) ruppertus Linux - Hardware 1 02-14-2008 03:24 PM
No sound from Intel 82801g with 2008 sdrambo Mandriva 9 12-16-2007 01:28 PM
Configuring master volume control for Intel ICH5 Alsa liquidfu22 Linux - Hardware 0 03-09-2007 12:56 PM
fc6 intel 82801g sound card problems phaedrusarphan Linux - Hardware 1 01-28-2007 06:40 PM
Master Volume Control Issue dingledoink Ubuntu 0 09-23-2005 01:34 PM


All times are GMT -5. The time now is 10:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration