LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 02-14-2007, 02:15 PM   #1
zWaR
Member
 
Registered: Dec 2003
Distribution: Slackware, Alpine Linux, Ubuntu, Debian
Posts: 219

Rep: Reputation: 35
Intel 3945 Wireless card


Hello,

i'm trying to install Intel 3945 Wireles card on my laptop (hp pavilion dv6162ea). I'm running slackware 11.0 with generic 2.6.18 kernel. I've been following the instructions in INSTALL file, which comes with Intel's ipw3945 driver. Everything went smooth (i just had to force ipw3945 to install, since it complained about ieee80211 duplicate), but as i run iwconfig it claims no wireless extensions. I tried to go trough FAQ steps on Wireless Tools for Linux, under the title debugging Wireless Extensions, but according to it everything should work. lspci displays the card, modules ieee80211 and ipw3945 are listed in lsmod output, cat /proc/net/wireless gives output, but still iwconfig claims no wireless extensions. What should i do?

The wireless card has a switch on the laptop, to turn it on or off. If the wlan card is switched on, the status light lights orange until OS does not load (e.g. it stays orange until windows do not load and it then chages its color to green), but on linux it is allways orange - i don't know if this is important, but it might be a clue.

Any help would be great!
 
Old 02-14-2007, 04:31 PM   #2
zWaR
Member
 
Registered: Dec 2003
Distribution: Slackware, Alpine Linux, Ubuntu, Debian
Posts: 219

Original Poster
Rep: Reputation: 35
I've installed new kernel 2.6.20 and somehow managed to get iwconfig to work. Now there's a second trouble comming on. I configured my essid and WEP key and have also managed to connect inside the local network, but i still can not connect outside of it, on the internet. Other machines on the local net are using the same router (allthough they are wire connected) and the internet connection works like a charm. I was testing the wlan connection on windows, where outside connection also worked. My router is asus WL-500g Premium.
 
Old 02-14-2007, 05:05 PM   #3
zWaR
Member
 
Registered: Dec 2003
Distribution: Slackware, Alpine Linux, Ubuntu, Debian
Posts: 219

Original Poster
Rep: Reputation: 35
Yee i solved it! I disabled eth0 (ethernet device) configuerd eth1 (wlan card) with ifconfig again and now it works! I just have to automate the procedure, so the wlan settings will be configured on startup.
 
Old 02-15-2007, 09:19 AM   #4
zWaR
Member
 
Registered: Dec 2003
Distribution: Slackware, Alpine Linux, Ubuntu, Debian
Posts: 219

Original Poster
Rep: Reputation: 35
I just want to be more specific on managing the wireless card installation. In kernel 2.6.20, ieee80211 is build into kernel, it can not be disabled (Y by default), so there is no need to install ieee80211 module (as suggested in ipw3945 INSTALL file), although the ieee80211 installation can also be done. All you have to do is install ipw3945 driver (if it claims you have to force it, because it has found ieee80211 duplicate, just force it) and then copy the daemon file (ipw3945d) into /sbin folder. Running ipw3945d will load ipw3945 module and because ieee80211 support is build into kernel, there is no need to load ieee80211 module again, hence the error if you try to run ./load from the ipw driver directory (as suggested in INSTALLATION file). Now, you should be able to see a description of your wlan card, if you enter iwconfig command (if you don't, i don't know what to do - i compiled new kernel and it worked).

Next thing is to configure the wlan, it is enough to set essid and WEP key (if you use one):
Code:
iwconfig eth1 essid YourActualEssid
iwconfig eth1 key xxxxxxxx (where xxxxxxx is  you actual hex key or s:yyyyyy, where yyyyy is your ascii key)
Once you did that, just configure eth1 (if that's recognised as your wlan card) with ifconfig:
Code:
ifconfig eth1 {$IPADDRESS} broadcast {$BCASTIP} netmask {$NETMASKIP}
route add default gw {$GWADDRESS}
(Replace variables in curly brackets with actual ip addresses!)

ifconfig command implicitly enables eth1 device, so there is no need using ifconfig eth1 up (but it can be useful when testing).

If you have more then one eth device on your laptop (what usually is the case), be sure to bring unused devices down, since that can be a cause for problems. You can do this using the command ifconfig eth0 down (replace eth0 with the identifier of your device).

To automate the process, it is enough to configure ipw3945d to start on system startup (on slackware placing ipw3945d into /etc/rc.d/rc.local). To configure wlan card via iwconfig and ifconfig, you can write your own bash script, it's really straight forward or you can use my script, which i will post when i come back to my linux machine

I hope this post will someday help someone to configure his/her intel 3945 wireless card!
 
Old 02-20-2007, 07:26 PM   #5
zWaR
Member
 
Registered: Dec 2003
Distribution: Slackware, Alpine Linux, Ubuntu, Debian
Posts: 219

Original Poster
Rep: Reputation: 35
Here's the promissed code for wlan enabling script.

Code:
#!/bin/bash
#The script starts wlan connection

#config
WEP=<insert your wep key here [hex-key | s:ascii-key]>
ESSID=<insert your essid here>
ETH=<the name of lan devide e.g. eth1>

iwconfig $ETH essid $ESSID
iwconfig $ETH key $WEP

if [ $? -eq 0 ]; then
	echo "iwconfig loaded successfuly"
else
	echo "iwconfig error"
fi
 
Old 05-08-2007, 04:51 PM   #6
eigernorth
LQ Newbie
 
Registered: May 2007
Distribution: Slackware
Posts: 7

Rep: Reputation: Disabled
ipw3945 no dynamic IP address

Hi folks,

with my Slack 11, I got the ipw3945 setup almost complete: iwconfig and ifconfig see the adapter as 'eth1'. So far so good. However, I cannot obtain a dynamic IP address. Any ideas? Please see rc.wireless.conf.

00:192:B0:3C:59) ### Work
INFO="Intel PRO/Wireless 3945ABG Network Connection (rev 02)"
ESSID="ISD-MAX-WL"
# ESSID="ISD-ALL-WL"
# NWID=""
MODE="Managed"
# AUTO_CREATE="1"
# FREQ=""
#CHANNEL 0 means any
CHANNEL="0"
# SENS=""
RATE="auto"
KEY="xxx"
# RTS=""
# FRAG=""
# IWCONFIG=""
# IWSPY=""
IWPRIV=""
;;

... it works find under the other OS.

Thanks
 
Old 05-22-2007, 12:03 PM   #7
0ptimus
LQ Newbie
 
Registered: May 2007
Posts: 1

Rep: Reputation: 0
eigernorth, you've probably already tried this, but for those who don't know it:

Did you try
Code:
# dhclient eth1
where "eth1" is replaced with your wireless interface name?
 
  


Reply

Tags
intel, ipw3945, wifi, wireless, wlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intel wireless 3945 Lantius Ubuntu 13 04-09-2009 03:12 AM
Intel Pro/Wireless 3945 mwarbeck Suse/Novell 19 03-28-2007 09:38 PM
Help.. Problem with enabling Intel 3945 wireless card on Dell D520 crystal_liu117 Linux - Wireless Networking 1 02-07-2007 07:55 AM
Need Help - Intel 3945 Wireless vishallagdev Linux - Wireless Networking 1 07-06-2006 03:34 AM
Intel 3945 Wireless Help - FC5 jonwatson Linux - Wireless Networking 1 05-18-2006 08:02 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration