LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 04-16-2006, 12:46 PM   #1
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Rep: Reputation: 18
I want to mount ntfs partitions after booting Kubuntu


I have noticed that live versions of Knoppix, and Damn Small Linux both allow me to see my ntfs partitions.

When running either a live or installed version of Kubuntu, I am not able to browse to my ntfs partitions. What must I do to "mount" the ntfs partitions while running Kubuntu? Anyone know how to do this on a Dell, Latitude?

Thanks
 
Old 04-16-2006, 12:56 PM   #2
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
#mount -t ntfs /dev/<whatever partition its> /mnt/<destination mount point>

e.g #mount -t ntfs /dev/hda2 /mnt/win_ntfs

regards
 
Old 04-17-2006, 01:12 PM   #3
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by ruudra
#mount -t ntfs /dev/<whatever partition its> /mnt/<destination mount point>

e.g #mount -t ntfs /dev/hda2 /mnt/win_ntfs

regards
Awesome! This sounds so simple and direct. I am sure that it can help. I just don't know were to put this and when. I know that I can make on the fly adjustments at a prompt command line environment somewhere, but where does this go? Can it be made a permanent part of the start up so that I donít have to do this every time I want to see my drives? Would I want to?

Perhaps I should download a tutorial for baby newbies. How hard would it be to give step by step instructions for how to use this information? LikeÖ.

click on this. drag to that. type this, hit enter. close this, click that, restart that, save as, then close etc.

Thanks so much. I will work on figuring out where this bit of code would go in the meant time.
 
Old 04-18-2006, 04:24 AM   #4
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
I found what seems to be a good page for this. at
https://wiki.kubuntu.com/Automatical...dowsPartitions

I have not tried it yet, but I am sure it's worth looking at.
 
Old 04-18-2006, 06:31 AM   #5
tynesidegooner
LQ Newbie
 
Registered: Apr 2006
Posts: 1

Rep: Reputation: 0
Post

Quote:
Originally Posted by phazon
Awesome! This sounds so simple and direct. I am sure that it can help. I just don't know were to put this and when. I know that I can make on the fly adjustments at a prompt command line environment somewhere, but where does this go? Can it be made a permanent part of the start up so that I donít have to do this every time I want to see my drives? Would I want to?

Perhaps I should download a tutorial for baby newbies. How hard would it be to give step by step instructions for how to use this information? LikeÖ.

click on this. drag to that. type this, hit enter. close this, click that, restart that, save as, then close etc.

Thanks so much. I will work on figuring out where this bit of code would go in the meant time.

Phazon, I can't tell you how to change a LiveCD so that it automounts your partions. if you want to have your ntfs drives visible and mounted all the time using an installed Kubuntu then you need to edit your /etc/fstab file. I'm not on my ubuntu machine at the moment but from memory;

Assuming that /dev/hda1 is the location of Windows partition (NTFS) then you need to create a create a Local mount folder: /media/windows
using a terminal type:
sudo mkdir /media/windows

Then edit /etc/fstab so that the partition will be mounted on boot, again in the terminal:

sudo cp /etc/fstab /etc/fstab_backup
sudo gedit /etc/fstab

Append the following line at the end of file (use Tab to create the spaces - follow the form of lines already present in the file)
/dev/hda1 /media/windows ntfs umask=0222 0 0

or

/dev/hda1 /media/windows ntfs nls=utf8,umask=0222 0 0

I use the line without nls=utf8 - so no idea what it does??? maybe someone else can shed light on that.

Save the edited file.

Then in a terminal type: sudo mount -a
this should mount all partitions listed in /etc/fstab and your drive will be there everytime you boot up.


This only works for Kubuntu installed on a Hard drive - not the liveCD versions.
Also you should check out the UBUNTU forums (ubuntuforums.org) lots of info there.

Paul
 
Old 04-18-2006, 11:43 AM   #6
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
hi,
this will help you.
http://www.gnulinuxclub.org/index.ph...d=38&Itemid=31

regards
 
Old 04-21-2006, 05:17 AM   #7
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
Cool..

Well, I followed the directions at

https://wiki.kubuntu.com/Automatical...dowsPartitions

and wound up adding

/dev/hda1 /media/windows ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows ntfs user,fmask=0111,dmask=0000 0 0

to

etc/fstab

And they come up great!

Pretty wild!

Thanks for the come back

I wonder how I can get the desk-top links to them to look like the hard drive icons the way they look in the folders.

Last edited by phazon; 04-21-2006 at 05:22 AM.
 
Old 04-21-2006, 05:36 AM   #8
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Quote:
I wonder how I can get the desk-top links to them to look like the hard drive icons the way they look in the folders.
Do you mean a shortcut to the device itself? Right Click on the dektop, select Create New --> Link to Device --> Hard Disc Device. Click the Device tab, and enter the device you want to link to (eg /dev/hda5). This should give you a hard disc icon on your desktop.

If this isn't what you want, post back, and I can probably help
--Ian
 
Old 04-21-2006, 11:55 AM   #9
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
oh cool, I'll try it
 
Old 04-21-2006, 06:50 PM   #10
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
I had this idea, and it seems to have worked out. First of all, I found it interesting that after I had to re-install kubuntu (because I corrupted the xorg.conf file trying to get the machine to see my PS/2 mouse) I found that when I typed the following lines

/dev/hda1 /media/windows ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows ntfs user,fmask=0111,dmask=0000 0 0

into

etc/fstab

that when I closed it, my hard drives appeared in the desktop media folder. As if simply typing it and closing the editor was a command in it self. Odd.

Any way, so I found that if I used the Konsole to browse to the files in media, that only 1 of the 2 hard drives files were there. this meant that I could not give the

chmod 777 file

command to the files on the HDD I could not get to. Oddly enough, I could still see the files on each drive using the web browser or editor, I just cold not save to them without giving permission in the Konsole setting.


hmmm

so I tried this

First, while in the root directory, I did

mkdir /media/windows1

then

mkdir /media/windows2

then I modified

etc/fstab

by adding this

/dev/hda1 /media/windows1 ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows2 ntfs user,fmask=0111,dmask=0000 0 0

at first, when I closed it out, I again saw the images of the 2 extra hdd's magically appear in the media folder, but I could not see the files in them this time until I re-booted.

After re-booting, I was not only able to see the files using what ever browser or editor, but I was also able to browse to them using the Konsole. this is so cool

I feel like a power user!

I would definitely feel like one if I could figure out how Knoppix, and Damn Small Linux are able to make my PS/2 mouse work and do that for Kubuntu.

Cheers

Last edited by phazon; 04-21-2006 at 06:52 PM.
 
Old 04-23-2006, 03:47 PM   #11
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
Quote:
I would definitely feel like one if I could figure out how Knoppix, and Damn Small Linux are able to make my PS/2 mouse work and do that for Kubuntu.

Ok, this is how you can figure it out. Boot up with Damn Small Linux. Using whatever it provides for a text editor, and open /etc/X11/xorg.conf. Save it to someplace on those partitions that it mounts for you, then close out of Damn Small Linux.

Boot into your Kbuntu system, and do these two:

sudo gedit /etc/X11/xorg.conf

sudo gedit /wherever_you_put_the_xorg.conf_from_DSL

Now you have them open together. You might want to save a copy of your xorg.conf before you start:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.confWORKS

Modify the real one (the one at /etc/X11/xorg.conf) and make the mouse things look the same. Remember any line that starts with # is a comment and is not read by the system. Anything after a # that occurs in the middle of a line is also not read.

Save it, close everything, and restart x with the Control-Alt-Backspace key combo. I bet it comes back with your mouse working differently.

If the worst happens and x will not start after you fool with it, the system will drop back to a shell log-in. Just log in with your name and password, and do:

mv /etc/X11/xorg.confWORKS /etc/X11/xorg.conf

And restart x with the Control-Alt-Backspace key combo, or restart the computer with:

sudo shutdown -r now

and she will reboot, and you can try again.

Best of luck to you.

C
 
Old 04-23-2006, 06:21 PM   #12
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 131

Original Poster
Rep: Reputation: 18
Well

Thing is, if you down-load a copy of DSL, you'll see that it does not have an

etc/X11

directory. And Knoppix won't let me save things to hda3 (which is where my Kubuntu is in residence) because I can't get it to give me the permissions. If I do a

chmod 777

for anything while in Knoppix, I get some goofy message unlike I get using Kubuntu. Even though when I do a

ls -l

and get a

-rwxrwxrwx

for any file I have done a

chmod 777

for, it still won't let me save anything.

So...I am stumped for the moment.

besides this, it is not only the

Section "whatever"
option "this"
option "that"
protocol "dev/mouse, blah, blah"
EndSection

part I need to change. I have tried that about 6 different ways,... really.

What I need is a copy of the character device file called "mouse" in the dev directory of Knoppix. But it won't let me save it to any other hda while running Knoppix, and it does not exist on the Knoppix cd because it is all de-compressed at the time of booting said cd.....

dilemma
 
Old 05-02-2007, 06:07 PM   #13
martbd
LQ Newbie
 
Registered: May 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by phazon
I had this idea, and it seems to have worked out. First of all, I found it interesting that after I had to re-install kubuntu (because I corrupted the xorg.conf file trying to get the machine to see my PS/2 mouse) I found that when I typed the following lines

/dev/hda1 /media/windows ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows ntfs user,fmask=0111,dmask=0000 0 0

into

etc/fstab

that when I closed it, my hard drives appeared in the desktop media folder. As if simply typing it and closing the editor was a command in it self. Odd.

Any way, so I found that if I used the Konsole to browse to the files in media, that only 1 of the 2 hard drives files were there. this meant that I could not give the

chmod 777 file

command to the files on the HDD I could not get to. Oddly enough, I could still see the files on each drive using the web browser or editor, I just cold not save to them without giving permission in the Konsole setting.


hmmm

so I tried this

First, while in the root directory, I did

mkdir /media/windows1

then

mkdir /media/windows2

then I modified

etc/fstab

by adding this

/dev/hda1 /media/windows1 ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows2 ntfs user,fmask=0111,dmask=0000 0 0

at first, when I closed it out, I again saw the images of the 2 extra hdd's magically appear in the media folder, but I could not see the files in them this time until I re-booted.

After re-booting, I was not only able to see the files using what ever browser or editor, but I was also able to browse to them using the Konsole. this is so cool

I feel like a power user!

I would definitely feel like one if I could figure out how Knoppix, and Damn Small Linux are able to make my PS/2 mouse work and do that for Kubuntu.

Cheers
to mount NTFS add the following line to fstab

/dev/hda1 /media/windows ntfs-3g defaults,locale=en_US.utf8 0 0
 
Old 06-14-2007, 01:14 AM   #14
uxe1
LQ Newbie
 
Registered: Jun 2007
Posts: 4

Rep: Reputation: 0
permission denied?

i was having the same problem i folowed the instructions on https://help.ubuntu.com/community/Au...ountPartitions
but im being told i dont have permission to veiw or alter it. i thought i told it to alow all users to read and write, am i just missing some thing??? any help would be most apreaciated

thanx
 
  


Reply

Tags
mount, ntfs, partitions


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Write access to windows partitions in kubuntu 5.10 badbunny Ubuntu 4 02-07-2006 01:14 PM
cant mount NTFS when booting from floppy-SLACKWARE mermerus Linux - Newbie 2 08-04-2005 11:57 AM
how t mount my ntfs partitions ??? BReal Fedora 5 04-19-2005 02:42 PM
mount points, /home partitions, /etc/fstab's and booting bigjohn Linux - Newbie 4 11-16-2004 10:14 AM
mount NTFS partitions heinrich Linux - Software 3 08-11-2003 03:27 PM


All times are GMT -5. The time now is 03:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration