LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-14-2006, 12:02 PM   #1
bluesmanu
Member
 
Registered: May 2005
Location: Geneve
Distribution: Fedora 12
Posts: 48

Rep: Reputation: 15
how to wake up from S3 acpi sleep state?


Hey!

When typing
echo 3 > /proc/acpi/sleep
or
acpitool -s
or
echo mem > /sys/power/state

my laptop goes to sleep as expected.

However, i don't know how to wake it up. When pressing the power button, everything goes up again but just to power off.

How can i just wake it up and not turn it off?
ANd how can i wake it up from the keyboard?

Manu
 
Old 01-14-2006, 12:06 PM   #2
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Right before you go to sleep, try disabling the ACPI daemon:
# /etc/rc.d/init.d/acpid stop

Sometimes there are BIOS options to tell the system which devices can wake up the system from sleep. However, you may find out that the power button might be the only way.
 
Old 01-14-2006, 02:43 PM   #3
bluesmanu
Member
 
Registered: May 2005
Location: Geneve
Distribution: Fedora 12
Posts: 48

Original Poster
Rep: Reputation: 15
thanks but it didn't work...
 
Old 01-14-2006, 05:31 PM   #4
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Actually I forgot to add that you can also try removing the button module. This is what I do and it works correctly.

/etc/rc.d/init.d/acpid stop
/sbin/modprobe -r button
echo 3 > /proc/acpi/sleep
/sbin/modprobe button
/etc/rc.d/init.d/acpid start
 
Old 01-15-2006, 03:22 PM   #5
Earthwings
LQ Newbie
 
Registered: Aug 2005
Location: Karlsruhe, Germany
Distribution: Gentoo, Kubuntu
Posts: 20

Rep: Reputation: 0
You'd better disable the acpid action which shuts down your system when pressing the power button. It might be defined in /etc/acpi/default.sh or in one of the files in /etc/acpi/actions/.

Do you have a Fn key (or similar)? Here pressing this for ~ 1 second brings my laptop back up after sleep.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ACPI sleep states slinky2004 Linux - General 3 10-30-2005 12:40 AM
Screen does not wake up after going to sleep at promp PSIPHON Linux - General 1 08-09-2005 08:30 PM
ACPI Sleep ? rpz Linux - Hardware 17 08-08-2005 02:44 AM
ACPI Sleep aaa Linux - General 9 10-01-2003 11:54 AM
monitor in supsend/sleep mode... can't "wake" it up schbond Linux - Hardware 2 09-15-2003 12:03 AM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration