LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   How to suspend to ram ? I have problems. (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/how-to-suspend-to-ram-i-have-problems-479403/)

gkiagia 09-01-2006 07:47 AM

How to suspend to ram ? I have problems.
 
I have an acer aspire 9113 laptop and I am trying to get suspend to ram (S3 acpi state) working. I tried two programs. First, powersave/kpowersave which is the default on suse. Powersave initially detected my system as unable to suspend to ram (although both the linux kernel and the windows device management report S3 as an available state). I had to force it by editing its configuration and when I tried it, I just locked my kde session. The output in /var/log/messages was that:
Code:

Sep  1 13:50:09 gklaptop PM: Preparing system for mem sleep
Sep  1 13:50:11 gklaptop Freezing cpus ...
Sep  1 13:50:11 gklaptop CPU 1 is now offline
Sep  1 13:50:11 gklaptop SMP alternatives: switching to UP code
Sep  1 13:50:11 gklaptop CPU1 is down
Sep  1 13:50:11 gklaptop Stopping tasks: ======================================================================|
Sep  1 13:50:11 gklaptop suspend_device(): usb_generic_suspend+0x0/0xf6() returns -16
Sep  1 13:50:11 gklaptop Could not suspend device 1-4: error -16
Sep  1 13:50:11 gklaptop Some devices failed to suspend
Sep  1 13:50:11 gklaptop Restarting tasks... done
Sep  1 13:50:11 gklaptop Thawing cpus ...
Sep  1 13:50:11 gklaptop SMP alternatives: switching to SMP code
Sep  1 13:50:11 gklaptop Booting processor 1/1 eip 3000
Sep  1 13:50:11 gklaptop Initializing CPU#1
Sep  1 13:50:11 gklaptop Calibrating delay using timer specific routine.. 3657.60 BogoMIPS (lpj=1828804)
Sep  1 13:50:11 gklaptop CPU: After generic identify, caps: bfe9fbff 00100000 00000000 00000000 0000c1a9 00000000 00000000
Sep  1 13:50:11 gklaptop CPU: After vendor identify, caps: bfe9fbff 00100000 00000000 00000000 0000c1a9 00000000 00000000
Sep  1 13:50:11 gklaptop monitor/mwait feature present.
Sep  1 13:50:11 gklaptop CPU: L1 I cache: 32K, L1 D cache: 32K
Sep  1 13:50:11 gklaptop CPU: L2 cache: 2048K
Sep  1 13:50:11 gklaptop CPU: Physical Processor ID: 0
Sep  1 13:50:11 gklaptop CPU: Processor Core ID: 1
Sep  1 13:50:11 gklaptop CPU: After all inits, caps: bfe9fbff 00100000 00000000 00000140 0000c1a9 00000000 00000000
Sep  1 13:50:11 gklaptop Intel machine check architecture supported.
Sep  1 13:50:11 gklaptop Intel machine check reporting enabled on CPU#1.
Sep  1 13:50:11 gklaptop CPU1: Intel Genuine Intel(R) CPU          T2400  @ 1.83GHz stepping 08
Sep  1 13:50:11 gklaptop APIC error on CPU1: 00(40)
Sep  1 13:50:11 gklaptop CPU1 is up

It seems unable to shut down usb, and then it also produces an apic error. Powersave has the same behaviour in both my suse and gentoo installations. I tried to boot gentoo with the noapic kernel parameter but that causes a system freeze after the coldplug service is started.

Then, I tried klaptop on gentoo. KLaptop is not actually the best app for this job and I prefer powersave, but using suspend to ram with it works! The system goes successfully to S3 acpi state. When I resume, though, few seconds after I get back to kde, the screen switches to vt1 and the system is powered off (without entering runlevel 0).

Does anybody have a clue how I can use suspend to ram without turning off my laptop on resume? And does anybody know why powersave does not make it?

cathectic 09-02-2006 10:42 AM

You could try adding "noapic" to the append line at startup for Grub - disabling APIC is recommended for getting resume to work on a lot of systems, and it does appear to be causing you some trouble here.

gkiagia 09-04-2006 01:37 PM

Quote:

Originally Posted by cathectic
You could try adding "noapic" to the append line at startup for Grub - disabling APIC is recommended for getting resume to work on a lot of systems, and it does appear to be causing you some trouble here.

Well, I'll try it in suse too, but as I said, in gentoo the noapic command causes the system to freeze after the coldplug service is started.

gkiagia 09-09-2006 03:45 AM

Well, I think I found the solution. I unload "ehci_hcd" and "uhci_hcd" as well as "ac" and "battery" modules before suspending. I also compiled in the kernel usb suspend support (for suspending individual devices, needed for my internal camera, which is connected to the ehci usb controller) and switched to suspend2-sources in gentoo.
In addition, I use the hibernate-ram script.

Now the problem is that when I resume I get no sound. The hibernate script automatically restarts the alsasound service but that doesn't do anything.


All times are GMT -5. The time now is 06:29 PM.