LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-09-2003, 10:43 PM   #1
Macguyvok
Member
 
Registered: Sep 2003
Location: NewYork - Fredonia - USA
Distribution: MDK 10; SuSE 9.0; Gentoo
Posts: 79

Rep: Reputation: 15
How to make ACPI work for HP/Compaq


Oh, well, here's an FYI for Compaq, and HP laptops running Mandrake 9.1:

To get ACPI working:

1) Install ACPI, and ACPID through the packages configuration.
2) Reboot
3) edit /etc/lilo.conf, and under your linux boot options, you will see the "append" line. In there will be "acpi=off" Change that to "acpi=on"

Also, I've found that some laptops require you to put in disk one, and starts it with "apm=off acpi-on" plus whatever other boot options you run, like "noauto". This is how I did it... and it's worked on 2 compaq (2100, 2800) and 1 HP(5300) machines I've tried it on. Let me know how it works!

Edit: FYI, you need to uninstall or turn off APM inorder to get ACPI working.

Last edited by Macguyvok; 09-10-2003 at 04:24 PM.
 
Old 09-10-2003, 08:48 AM   #2
rainchill
LQ Newbie
 
Registered: Apr 2003
Posts: 15

Rep: Reputation: 0
So I am assuming you got PCMCIA working? I have a 4315 and I can't for the life of me get MDK 9.2 rc2 or lower to detect or install PCMCIA without locking up.
 
Old 09-10-2003, 09:47 AM   #3
cuzzle
Member
 
Registered: Sep 2003
Location: Richland, WA
Distribution: Suse 9.2
Posts: 42

Rep: Reputation: 15
I don't have a compaq or hp but i did have problems installing on my laptop the way i finally got it is to select to install the acpi package when first installing and inabling it in the lilo config and finally turning APM OFF! Then it worked fine from boot up! I think that at the end of the install there is a place where you can configure what services you want to run. Just remove APM and enable ACPI.
 
Old 09-10-2003, 04:22 PM   #4
Macguyvok
Member
 
Registered: Sep 2003
Location: NewYork - Fredonia - USA
Distribution: MDK 10; SuSE 9.0; Gentoo
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by rainchill
So I am assuming you got PCMCIA working? I have a 4315 and I can't for the life of me get MDK 9.2 rc2 or lower to detect or install PCMCIA without locking up.
Yeah, PCMCIA worked fine. IF you have issues with it, I'd try running "linux noauto" and installign ti afterwards... I has issues with my firewire, where it would lock up until I did the noauto. After the 1st reboot it installed an configured my firewire fine.. so I'm assuming it could wokr the same for you.


OH, and I should prolly mention that APM should be off inorder to get ACPI working :-p
 
Old 09-10-2003, 07:45 PM   #5
Kramer
Member
 
Registered: Aug 2003
Location: Somewhere south of sanity...
Distribution: Mandrake 9.1
Posts: 550

Rep: Reputation: 30
When I change mine to ACPI=on, it freezes the computer at boot, right after the LILO screen. Any suggestions?
 
Old 09-10-2003, 08:28 PM   #6
rainchill
LQ Newbie
 
Registered: Apr 2003
Posts: 15

Rep: Reputation: 0
I tried the "linux noauto" and that prevents it from locking when loading the setup. When I get to the end I unselect "apmd" from the configuration screen, but there is nowhere is select an acpo package except on the lilo configurator. But this does what the guy before me said, where it just locks up after I tell Lilo to boot Linux.

So I tried telling LILO to boot Linux-nofb (whatever that means) It listed everything it was doing then froze on something starting with DSDT.... But a few lines before that said something about "ACPI 00803003......" What is going on here? Any help would be great.
 
Old 09-14-2003, 10:27 AM   #7
Macguyvok
Member
 
Registered: Sep 2003
Location: NewYork - Fredonia - USA
Distribution: MDK 10; SuSE 9.0; Gentoo
Posts: 79

Original Poster
Rep: Reputation: 15
Well, my thought is that you need to install ACPI before enabling acpi=on. If you don't it's gunna freeze on bootup.
 
Old 09-15-2003, 02:19 PM   #8
Kramer
Member
 
Registered: Aug 2003
Location: Somewhere south of sanity...
Distribution: Mandrake 9.1
Posts: 550

Rep: Reputation: 30
Quote:
Originally posted by Macguyvok
Well, my thought is that you need to install ACPI before enabling acpi=on. If you don't it's gunna freeze on bootup.
I have installed ACPI and ACPID, but it says it cant find /proc/acpi/events, and there is no acpi directory in /proc. I tried to go into su under the shell prompt and create one, and then move the events file there (i found the events file) but it wont let me create the directory. Any other ideas?
 
Old 09-15-2003, 04:19 PM   #9
Macguyvok
Member
 
Registered: Sep 2003
Location: NewYork - Fredonia - USA
Distribution: MDK 10; SuSE 9.0; Gentoo
Posts: 79

Original Poster
Rep: Reputation: 15
Well, the /proc directory isn't really there. It's a virtual list of all the processes running. My firend had a similiare issue, and all I can say is that either u're bios, or the current ACPI won't work with u're laptop. I'd be tempted to try Mandrake 9.2 RC@, as that seems to have a much improved ACPI, that supports hibernate on my laptop, and seems to allow some other system to run ACPI that couldn't before.
 
Old 09-15-2003, 04:51 PM   #10
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Rep: Reputation: 15
The only thing I had to do to get acpi working on my Compaq 2170 running SuSE 8.2 was to enable the daemon for runlevel 5 through YAST.
Zane
 
Old 09-15-2003, 06:46 PM   #11
Kramer
Member
 
Registered: Aug 2003
Location: Somewhere south of sanity...
Distribution: Mandrake 9.1
Posts: 550

Rep: Reputation: 30
Quote:
Originally posted by Macguyvok
Well, the /proc directory isn't really there. It's a virtual list of all the processes running. My firend had a similiare issue, and all I can say is that either u're bios, or the current ACPI won't work with u're laptop. I'd be tempted to try Mandrake 9.2 RC@, as that seems to have a much improved ACPI, that supports hibernate on my laptop, and seems to allow some other system to run ACPI that couldn't before.
Ok, im definitely looking forward to the 9.2 final. I have no ACPI options in my BIOS, which means it probably isnt supported, but that makes me ask, if its not supported, then why does it work perfectly in Winhoe$? How buggy is the 9.2RC2?
 
Old 09-15-2003, 10:20 PM   #12
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
macguyvok, is the acpi working on your desktop system as well? If so, what is the motherboard? (for that matter what are the entire system specs?)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compaq presario2500 novell suse 9 graphics & acpi mteren Linux - Laptop and Netbook 0 01-31-2005 09:34 AM
Tough question: Compaq 1205EA: get ACPI to work on Mandrake ditch* Linux - Hardware 1 09-24-2004 06:13 AM
Compiling in ACPI support on Compaq 2135CA (system crashes while compiling) Dag Linux - Laptop and Netbook 20 07-30-2004 07:56 PM
compaq 2800 fedora core 2 acpi lcd brightness problems blueghost75 Linux - Laptop and Netbook 0 06-28-2004 07:08 PM
ACPI and Compaq presario oscuro_solitone Linux - Laptop and Netbook 3 04-27-2004 08:14 AM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration