LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   How to Install Mobile Intel 945GM Express Chipset driver on Redhat Enterprise Linux (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/how-to-install-mobile-intel-945gm-express-chipset-driver-on-redhat-enterprise-linux-471899/)

mohan_becse 08-08-2006 05:05 AM

How to Install Mobile Intel 945GM Express Chipset driver on Redhat Enterprise Linux
 
I bought a new Dell Inspiron E1505 laptop.

My video card is:

Mobile Intel 945GM Express Chipset

I have installed Windows XP --- and is successful.
made dual boot and I have installed Redhat Enterprise -- and is successful aswell


The problem is:

The video driver taken by the linux is VESA Generic Driver. its maximum resolution is 800*600 only.


I found linux driver in Intel website. the download driver file is:
Intel-3.4.3006-20051209.i386.tar.gz


But I dont know how to install driver from the above ..tar.gz file.

Can some one help me to install the driver and to increase the resolution to the highest one.

Denes 08-08-2006 03:54 PM

I have a similar chipset - Intel 915 running on CentOS4.3. Similar to RH Enterprise 4 Update 3. In my Systems Settings/Display under the hardware tab I have my video card set to Intel 915 (there is an option there for Intel 945). For the monitor I have Generic CRT - 1024x768 (you may want to try Generic LCD since it is a laptop). Try playing with the monitor setting and then changing the settings tab Resolution to 1024x768. You may have to update to a newer version of RHEL to get support for the newer chipsets.

freecr 08-08-2006 10:20 PM

see xc/BUILD

mohan_becse 08-09-2006 01:56 AM

In my Systems Settings/Display under the hardware tab, there is no intel 945. It lists only upto intel 915. I tried with all other possibilities earlier..but if i increase the resolution higher than 800*600, then OS hangs while booting.


Thanks for your reply. I already tried the solution but i received error while builiding.

1. I changed the directory to xc (please note I didnot make any config changes under xc/config/cf nor to xorgsite.def.

2. Ran make World > World.log 2>&1

But the log file has errors, I am not able to diagnose it as I am not an expert in these areas. Can you please help me. I am providing the details below.



[root@testnet xc]# uname -a
Linux testnet.idc.oracle.com 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:54:53 EST 2006 i686 i686 i386 GNU/Linux



The last portion of the World.log
---------------------------------


tr.h
+ rm -f XEVIstr.h
+ ln -s ../../../../include/extensions/XEVIstr.h .
make[3]: Leaving directory `/home/oracle/xc/include/extensions'
including in include/fonts...
make[3]: Entering directory `/home/oracle/xc/include/fonts'
+ mkdir -p ../../exports/include/X11/fonts
+ cd ../../exports/include/X11/fonts
+ for i in FS.h FSproto.h fsmasks.h
+ rm -f FS.h
+ ln -s ../../../../include/fonts/FS.h .
+ for i in FS.h FSproto.h fsmasks.h
+ rm -f FSproto.h
+ ln -s ../../../../include/fonts/FSproto.h .
+ for i in FS.h FSproto.h fsmasks.h
+ rm -f fsmasks.h
+ ln -s ../../../../include/fonts/fsmasks.h .
make[3]: Leaving directory `/home/oracle/xc/include/fonts'
including in include/GL...
make[3]: Entering directory `/home/oracle/xc/include/GL'
make[3]: *** No rule to make target `/X11R6/SourceForge/Mesa6.2/Mesa/include/GL/
gl.h', needed by `gl.h'. Stop.
make[3]: Leaving directory `/home/oracle/xc/include/GL'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/home/oracle/xc/include'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/home/oracle/xc'
make: *** [World] Error 2
~

Denes 08-09-2006 10:34 AM

Did you install the kernel headers? You can't compile alot of things unless these are installed and RHEL doesn't install them by default.

Did you try the non SMP kernel at the higher resolution? I have two systems that hang on SMP kernels (they are only single processor so it doesn't really affect me).


All times are GMT -5. The time now is 11:32 AM.