LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-05-2009, 12:00 PM   #1
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Rep: Reputation: 0
How to get a sis 671 card in a proline laptop to work ubuntu studio amd64


Hi,

I have posted this question in the newbie forum (I feel less than newbie when such a seemingly simple issue can not be resolved!), though without response, so hopefully this is the right place.

I have a laptop with a sis 671 graphics card installed (what idiot specked a laptop with a sis card for linux I will never know!), I cannot get a higher res than 800x600.

xorg.conf only has the following (relevant section only):

Section "device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

I Tried adding Driver "sis"
BusID "PCI:1:0:0"
And various variations to "Device", I have also in one attempt added res and depth strings to "Screen", adding subsection "display"s. This always results in a fatal X error, no device found, or no screens found.

I need to deliver the laptop this weekend and I am still struggling with res!

Update: I am about to gift wrap the laptop as is, screen problem and all, I am out of time and must now try to get this sorted for a complete newbie, who will be 500Kms away from me!

Please help me here!

Thanks
Peet

Last edited by Peet_Nel; 03-05-2009 at 12:02 PM. Reason: Trying to sort tags, they are obviously not comma deliminated!
 
Old 03-05-2009, 12:13 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
cat /var/log/Xorg.0.log | grep -i driver
is most likely going to indicate that your system is already using the sis driver

http://www.sis.com/support/support_faqs_16.htm
Quote:
The linux OS has default driver for SiS products
if it's not using the sis driver make sure it's installed..
apt-cache policy xserver-xorg-video-sis
if it's not installed, install it.
sudo apt-get install xserver-xorg-video-sis
then restart X


your /var/log/Xorg.0.log file may also show you other useful information.
 
Old 03-05-2009, 12:52 PM   #3
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi Farslayer, thanks for the quick reply, I unwrapped the laptop and checked your suggestion, I seem to have a sis module, but not in use. Here is the result of the commands:

Quote:
Originally Posted by farslayer View Post
cat /var/log/Xorg.0.log | grep -i driver

root@AMMONITE:/home/renette# cat /var/log/Xorg.0.log | grep -i driver
X.Org Video Driver: 2.0
X.Org XInput driver : 2.0
ABI class: X.Org Video Driver, version 2.0
(==) Matched vesa for the autoconfigured driver
(==) Assigned the driver to the xf86ConfigLayout
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 2.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) VESA: driver for VESA chipsets: vesa
ABI class: X.Org Video Driver, version 2.0
ABI class: X.Org Video Driver, version 2.0
(II) Synaptics touchpad driver version 0.14.6 (1406)

To me it looks like it is using vesa, how can I change it?, I downloaded the redhat driver from sis support, I tryed copying it into the driver directory, then x could not start (unable to load module sis...), there is though a sis file of some sort, I have been unable to figure out how to set it to use it though!

is most likely going to indicate that your system is already using the sis driver

http://www.sis.com/support/support_faqs_16.htm


if it's not using the sis driver make sure it's installed..
apt-cache policy xserver-xorg-video-sis

root@AMMONITE:/home/renette# apt-cache policy xserver-org-video-sis
W: Unable to locate package xserver-org-video-sis

So I thought not installed - YES?

if it's not installed, install it.
sudo apt-get install xserver-xorg-video-sis

root@AMMONITE:/home/renette# apt-get install xserver-xorg-video-sis
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-sis is already the newest version.
xserver-xorg-video-sis set to manually installed.
The following packages were automatically installed and are no longer required:
ispell ibritish wamerican openoffice.org-l10n-en-gb
openoffice.org-l10n-en-za openoffice.org-help-en-gb
openoffice.org-help-en-us openoffice.org-hyphenation-en-us gimp-help-common
gimp-help-en wbritish openoffice.org-thesaurus-en-au iamerican
openoffice.org-thesaurus-en-us
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


So There is something, not being used but installed in an un-recognised way??


your /var/log/Xorg.0.log file may also show you other useful information.
How can I get the log in a format that I can copy to clipboard? in MC it looks like it recognizes a sis 671 card, later in the section it detects a vesa chip, which it seems to configure, if it would help I can post that, but not sure how?

Thanks for the help so far, you are giving me hope here!

Regards
Peet
 
Old 03-05-2009, 01:11 PM   #4
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
OK, I thought I will be clever here, ran apt-get remove xserver-org-video-sis, then install, but I still get W: Unable to locate package xserver-org-video-sis.

So maybe that was not so clever after all.

Peet
 
Old 03-05-2009, 02:01 PM   #5
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
If I removed all xserver-org-video- modules, except sis, would it force X to go sis, or would it cause a fatal error?
 
Old 03-05-2009, 03:53 PM   #6
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
From the log it looks like it is using the vesa driver..
Code:
Matched vesa for the autoconfigured driver
If you do
sudo apt-get install xserver-xorg-video-sis
and it actually installs something, then the driver was not installed to begin with. If it doesn't install anything the the package was already there. I'm going to bet it wasn't installed by default (it wasn't installed by default on my Debian system)

Why don't you start with installing that driver and then restart your X-server..
CTRL+ALT+BACKSPACE - should force X to restart.

then check the log again to see if the sis driver is being used. I believe xorg autodetection will see the sis chip and the more appropriate driver and make the necessary modifications automatically.


I wouldn't remove all the other drivers, it's good to have them around, or at least leave the VESA driver installed, it's always a good fallback..

Last edited by farslayer; 03-05-2009 at 03:55 PM.
 
Old 03-05-2009, 10:59 PM   #7
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
[QUOTE=farslayer;3466202]From the log it looks like it is using the vesa driver..
Code:
Matched vesa for the autoconfigured driver
If you do
sudo apt-get install xserver-xorg-video-sis

root@AMMONITE:/home/renette# apt-get install xserver-xorg-video-sis
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-sis is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have installed it as one of my earlier attempts, Though even after a remove then install, I still get

root@AMMONITE:/home/renette# apt-cache policy xserver-org-video-sis
W: Unable to locate package xserver-org-video-sis


How can I set sis as the active driver?

Regards
Peet
 
Old 03-06-2009, 11:08 PM   #8
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Quote:
Originally Posted by Peet_Nel View Post

I have installed it as one of my earlier attempts, Though even after a remove then install, I still get

root@AMMONITE:/home/renette# apt-cache policy xserver-org-video-sis
W: Unable to locate package xserver-org-video-sis
xserver-xorg-video-sis

you missed the x in your command above.

OK so it's installed, so now run

sudo dpkg-reconfigure xserver-xorg and see if it will allow you to select sis as the driver.
 
Old 03-08-2009, 01:25 AM   #9
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi,

Running dpkg-reconfigure xserver-xorg asks several questions about the keyboard, does not even mention the graphics, seems not to detect it, or it figures it is fine?

I have run reconfigure with direct access to the hardware and using the framebuffer (1st question reconfigure asks - in case I am mis quoting!).

How else can I get it to use the right driver?

Thanks
Peet
 
Old 03-08-2009, 05:22 PM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Manually edit the xorg.conf file and add in the line for the driver in the device section.

Code:
Section "Device"
	Identifier	"nVidia Corporation NV40 [GeForce 6800]"
	Driver		"nvidia"
EndSection
of course your driver will be "sis", and don't change the 'Identifier' line, unless you like seeing the error "No Screens Found"
 
Old 03-09-2009, 12:03 PM   #11
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Thank you - now I know why my previous attempts resulted in "no screens found"!

I will try this, possibly remotely (telephone guidance, or if I can get the right commands, remote desktop (vncviewer), There is a reconfigure command which brought it back to where it was before, so I can probably give that over the phone, if the worst should happen!

Will report back!

Regards
Peet
 
Old 03-09-2009, 02:22 PM   #12
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Yeah the Identifier Line is used elsewhere in the configuration.. It's a pointer really, and doesn't affect how the card works, but the system uses it to say Use video card "Y" but if you change "Y" to "Z" then the system can not find the section of the config to use.. so it returns "no screens found"

Alternately you can edit the identifier, look through the config and find where else it is referenced, change that as well, and get everything working.. but seems like a lot of effort for no real gain.
 
Old 03-12-2009, 12:43 PM   #13
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
I should be in Knysna this weekend - then I will insert the driver line and report back!

Thanks for that, it makes fiddling easier to know what not to change. I agree with not changing the identifier! (As it does not change anything).

Regards
Peet
 
Old 03-14-2009, 02:56 AM   #14
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
I am now in Knysna, have added the driver line, "no screens found", I noticed the log said it is assigning driver with no busID to primary device, so I added BusID below the Driver line, "no devices found", "no screens found"

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
Driver "sis"
BusID "PCI:01:00:0"
EndSection

The only part I edited. I will try removing the usefbdev, I might have put that in - not sure what it does.

Further advise would be hugely welcomed!

Thanks
Regards
Peet
 
Old 03-15-2009, 07:22 AM   #15
Peet_Nel
LQ Newbie
 
Registered: Jan 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Taking the usefbdev out (actually it was left out after recovering) made no difference, so I am back to square 1!
 
  


Reply

Tags
amd64, ubuntustudio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get a sis 671 card to work ubuntu studio amd64 Peet_Nel Linux - Newbie 1 03-04-2009 09:39 AM
Cannot get the cube to work in Ubuntu Studio 8.04 DaF101 Linux - General 10 12-10-2008 02:23 AM
Installed Ubuntu studio now sound doesn't work David Breedlove Linux - Newbie 6 12-05-2007 04:40 PM
SiS 7012 sound card on a laptop with Redhat 9.0 won't work! oncemorewith Linux - Laptop and Netbook 10 02-28-2004 08:03 PM
can't get x to work with my sis video card tksmitty Debian 2 12-20-2003 09:05 PM


All times are GMT -5. The time now is 01:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration