LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 12-20-2008, 06:27 PM   #1
olin
LQ Newbie
 
Registered: Sep 2007
Distribution: Debian Lenny
Posts: 26

Rep: Reputation: 15
How to disable synaptics touchpad vertical scrolling


I am using Debian Lenny on T61 (refer to my signature). I found vertical scrolling of the touch pad is annoying since T61 has a small touch area. I checked gnome options and tried to use tpconfig but didn't make it. Here is the tpconfig -i output:

Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).
Sensor type: unknown (0).
Geometry: rectangular/landscape/up.
Packets: absolute, 80 packets per second.
Corner taps disabled; no tap gestures.
Edge motion: none.
Z threshold: 6 of 7.
2 button mode; corner tap is right button click.

From tpconfig man helps, I even didn't find one option for vertical scrolling.

Any one has a idea? Thank you very much!
 
Old 12-20-2008, 06:29 PM   #2
olin
LQ Newbie
 
Registered: Sep 2007
Distribution: Debian Lenny
Posts: 26

Original Poster
Rep: Reputation: 15
And here is my xorg.conf touch pad section:

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

BTW, what does "HorizScrollDelta" mean? Is there something like "VerticalScrollDelta" can be used to disable vertical scrolling? Thank you!
 
Old 12-20-2008, 06:43 PM   #3
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
BTW, what does "HorizScrollDelta" mean?
Please see man synaptics for the full story.
 
Old 12-21-2008, 05:33 PM   #4
olin
LQ Newbie
 
Registered: Sep 2007
Distribution: Debian Lenny
Posts: 26

Original Poster
Rep: Reputation: 15
Thank you!

There is a bool type VertEdgeScroll option in man synaptics. It works!

Last edited by olin; 12-29-2008 at 09:43 AM.
 
Old 12-21-2008, 06:05 PM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
EndSection
now you will not have horizontal you want that.
Option "ZAxisMapping" "4 5 6 7"
option 4 5 are up and down 6 7 left and right give it a try let me know.
Option "ZAxisMapping" " 6 7"

Last edited by Drakeo; 12-21-2008 at 06:11 PM.
 
Old 01-12-2009, 02:11 AM   #6
domo141
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
Fedora 10, no tap click, no pad scroll:

Hi

I did this yesterday to disable clicking and scrolling on toucpad:

(machine: BIM Thinkpad T43, OS: Fedora 10 i386)

# cat > /etc/hal/fdi/policy/synaptics_notabnorscroll.fdi <<EOF
<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- copy this to /etc/has/fdi/policy/ -->
<deviceinfo version="0.2">
<device>
<match key="input.x11_driver" string="synaptics">
<merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
<merge key="input.x11_options.HorizScrollDelta" type="string">0</merge>
<merge key="input.x11_options.MaxTapTime" type="string">0</merge>
<merge key="input.x11_options.RightEdge" type="string">6000</merge>
<merge key="input.x11_options.BottomEdge" type="string">5000</merge>
<merge key="input.x11_options.VertEdgeScroll" type="string">false</merge>
<merge key="input.x11_options.HorizEdgeScroll" type="string">false</merge>
</match>
</device>
</deviceinfo>
EOF


# /etc/init.d/haldaemon restart

# <ctrl-alt-backspace>

(last key combination restarted X server)

After re-login touchpad worked as desired.

I am going to do similar thing with one Ubuntu 8.10 (dell laptop) in near future;
I do not expect much difference getting it to work...

Btw: is there way to insert verbatim text in this forum? The indentation
was lost in the data above (luckily I was not pasting python code

Last edited by domo141; 01-12-2009 at 02:12 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptics touchpad not recognised by synaptics driver (12.1) bogzab Slackware 13 03-22-2009 10:23 PM
How to disable Synaptics Touchpad on Toshiba Satellite? skysmurf Linux - Laptop and Netbook 18 10-05-2008 05:45 PM
How can I disable Synaptics touchpad tapping? dafydil Linux - Hardware 8 09-22-2007 01:02 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
synaptics touchpad edge vertical scrolling fbarsoba Linux - Laptop and Netbook 0 03-25-2006 08:15 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration