LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-20-2008, 07:04 PM   #16
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0

Quote:
Originally Posted by resetreset View Post
Interesting.... I'd like to know how to remove the support for your pad if you had a PS/2 mouse....
I'm not sure whether you'd really like to know or you're just being a smartass, but here goes anyway:

As far as I can tell the kernel doesn't know about touchpads. It just sees pointing devices, no matter whether they're pads or "normal" mice.

So if your touchpad and your "normal" mouse are of the same type, then I guess you'll have to either:
  • disable the pad in the BIOS if this is possible;
  • open the case and physically disconnect the pad if you dare/can;
  • cover the pad somehow;
  • always start X (provided you have X in the first place) and use the xorg.conf "trick" described by tredegar.

And perhaps there are even more options (for example, maybe gpm can somehow be configured to only listen to the "normal" mouse and ignore the touchpad) but I haven't looked at those yet because the kernel config method works for me.

Alphons
 
Old 10-05-2008, 03:45 PM   #17
gsilvestro
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
Prolbem not not really sorted!

I have the same (not really) prolem: disable the touchpad
for a different reason: I think I have an hardware prolem
and I would like to isolate it.

The target is the same: exclude the touchpad!
In first instance the /etc/X11/xorg.conf
has this lines:

Code:
Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection
So no apparent psaux stuff. Indeed my USB mouse is
what I use right now. (No other input stuff in
that file [beside keyoard and the like..].)


Also BIOS is of no help.


Shall I trust

Quote:
In fact, even if I remove the "Mice" section alltogether, a USB mouse will still work - provided that USB support is still compiled in, of course.

In my case I have an hardware prolem:
It looks like if the touchpad is keeping moving on the
right all the time. Depending on temperature and stage.
I guess it is a pretty personal prolem, but excluding
the touchpad at kernel/modules level might help me
to isolate the prolem and also to keep using the machine.

cheers
S
 
Old 10-05-2008, 03:53 PM   #18
gsilvestro
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
Sorry...

I forgot to mention a detail.
It is much more easier if I can load and unload modules.
Recompiling the kernel might be an option but
it will bring me too far away from an easy hardware
debug. I'll better change the hardware!

Soon
S
 
Old 10-05-2008, 04:45 PM   #19
gsilvestro
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by skysmurf View Post
I'm not sure whether you'd really like to know or you're just being a smartass, but here goes anyway:

As far as I can tell the kernel doesn't know about touchpads. It just sees pointing devices, no matter whether they're pads or "normal" mice.

So if your touchpad and your "normal" mouse are of the same type, then I guess you'll have to either:
  • disable the pad in the BIOS if this is possible;
  • open the case and physically disconnect the pad if you dare/can;
  • cover the pad somehow;
  • always start X (provided you have X in the first place) and use the xorg.conf "trick" described by tredegar.

And perhaps there are even more options (for example, maybe gpm can somehow be configured to only listen to the "normal" mouse and ignore the touchpad) but I haven't looked at those yet because the kernel config method works for me.

Alphons
I do allow myself (not expert) to agree and disagree
in the same time. The kernel is the OS and soon or later
it will have to know about the devices it handles.
One side is due to security and an other side is due to
the hardware it runs on.

I guess that on X servers/clients the kernel is not
going to play a role as soon as the hardware is not
on its own machine.

Indeed the access to a simple mouse device is handled
by the kernel. At least as an hardware device.

You will not even see a mouse if the kernel doesn't
allow it. Here are the modules: Make available to
the kernel as a device: via modules (drivers). Also
my shiny one.

Yep, indeed:

Now the 4 points you made are simply off.

1 - this might be a solution: if you can. (nobody can)
2 - Do not open the case. Unless like me you have
an harware prolem do not ever open the case for
software prolems!
3&4 - seek a solution.

Unless you have a buggy problem there is always
a standard normal easy solution.

4 - No. You do not need to start X.

best
S
 
  


Reply

Tags
disable, laptop, slackware, synaptic, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable Synaptics touchpad tapping? dafydil Linux - Hardware 8 09-22-2007 12:02 PM
Touchpad misbehaviour on toshiba satellite trebek Linux - Laptop and Netbook 6 12-10-2006 12:56 AM
Touchpad on Toshiba Satellite trebek Linux - Laptop and Netbook 4 05-29-2005 04:25 PM
toshiba satellite A10 touchpad halitayarci Linux - Laptop and Netbook 5 11-02-2004 02:16 PM
Toshiba Satellite 1135 Touchpad problems xymox Slackware 2 05-17-2003 11:37 AM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration