LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-12-2008, 08:36 AM   #1
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Rep: Reputation: 0
Question How to disable Synaptics Touchpad on Toshiba Satellite?


Hiya people,

I have a Toshiba Satellite P200 1A4 laptop with a Synaptics touchpad.
The distro in question is Slackware 12.1 with the generic-SMP kernel, in case it matters.

However, I don't like touchpads at all and prefer a normal mouse. So I'd like to know how I can disable it. I don't mean to disable it on the console or disable it in X, I wish to disable it alltogether.

Any help will be appreciated,

Alphons

Last edited by skysmurf; 07-12-2008 at 08:37 AM. Reason: Spelling typo fixed
 
Old 07-12-2008, 10:33 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
If there is nothing in the BIOS to do this, you have 2 options: open up the case and find the touch pad connectors and disconnect them or, alternatively, tape a piece of card over the touch pad so you can't use it (and I have seen people do this!)
 
Old 07-12-2008, 10:59 AM   #3
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Try this in your /etc/X11/xorg.conf
Code:
Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "MaxTapTime" "0"
EndSection
Then restart X with <CTRL><ALT><BACKSPACE>
That should disable the tapping (probably the most annoying thing)
Perhaps if you set Option "SendCoreEvents" "false"
It will not do anything at all?
 
Old 07-12-2008, 11:08 AM   #4
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0
Unhappy

I'll go check the BIOS, thanks.

So there isn't anything I can do with the kernel, e.g. unloading some module or something?

Alphons
 
Old 07-12-2008, 11:23 AM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
What is the point of us taking the time to answer your questions, if you pay no attention to the replies?

I just set my /etc/X11/xorg.conf like this (as I suggested above) and the touchpad is completely disabled when X is restarted.:
Code:
Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "false"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "MaxTapTime" "0"
EndSection
Now I'd better undo that change.
 
Old 07-12-2008, 12:23 PM   #6
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0
Cool

Quote:
Originally Posted by tredegar View Post
I just set my /etc/X11/xorg.conf like this (as I suggested above) and the touchpad is completely disabled when X is restarted.
Who says I'm running X?
Who says I even have X installed in the first place?

I appreciate your suggestion, but I specifically mentioned that I prefer a solution that doesn't depend on either X being there or the console being used.

Thanks anyway,

Alphons (Linux can actually run without X...)
 
Old 07-12-2008, 01:10 PM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
It is possible that there's a setting in your kernel, but disabling it may disable your mouse support altogether. No reason you can't do some experimenting though - assuming you have the available time to compile and recompile your kernel.......
 
Old 07-12-2008, 01:27 PM   #8
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by XavierP View Post
It is possible that there's a setting in your kernel, but disabling it may disable your mouse support altogether. No reason you can't do some experimenting though - assuming you have the available time to compile and recompile your kernel.......
If I can't disable the touchpad in the BIOS I'll give it a whack. Should I report back if I find something?

Alphons
 
Old 07-12-2008, 02:18 PM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Yes please - it may help someone who is either trying to do the same or who wants to enable it and can't find it in the kernel.
 
Old 07-15-2008, 04:20 PM   #10
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
Who says I'm running X?
Who says I even have X installed in the first place? [snip]
I prefer a solution that doesn't depend on either X being there or the console being used..[snip]
(Linux can actually run without X...)
Sorry: I mis-read your question. So my replies will not have helped you.
So, if you are not running X, or a console then what is it that the touchpad is doing that is so annoying you?
 
Old 07-15-2008, 05:50 PM   #11
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Actually, that's a good point. If you are in the CLI and do not need a mouse, you should uninstall gpm - that gives you mouse access in a CLI.
 
Old 07-16-2008, 05:01 AM   #12
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by XavierP View Post
If you are in the CLI and do not need a mouse, you should uninstall gpm
Actually, I do (occasionally) need a mouse. I just don't like touchpads, so I use a "normal" wired USB mouse.

Anyway, I think I may have found something while tinkering with the kernel config. As soon as I've verified that it really works, I'll report back with the results.

Thanks to both of you,

Alphons
 
Old 07-16-2008, 03:55 PM   #13
skysmurf
LQ Newbie
 
Registered: Nov 2007
Location: Holland
Distribution: Slackware 12.1
Posts: 15

Original Poster
Rep: Reputation: 0
How to disable Synaptics Touchpad on Toshiba Satellite? - SOLVED

The reason for wanting to disable the touchpad is that I keep accidentally touching it while typing - very annoying, particularly when I'm in vim's insert mode. I also simply don't like the way those thingies feel/handle.

Anyway, the solution turned out to be very simple: because the touchpad is identified as a PS/2 device (as an examination of dmesg revealed) I can simply remove PS/2 mouse support from the kernel (Device drivers -> Input device support -> Mice). In fact, even if I remove the "Mice" section alltogether, a USB mouse will still work - provided that USB support is still compiled in, of course.

Thanks again for the suggestions, I'm a little happier now

Alphons

Last edited by skysmurf; 07-16-2008 at 04:00 PM. Reason: Forgot something
 
Old 07-16-2008, 03:58 PM   #14
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Problem sorted then.
 
Old 07-19-2008, 06:17 AM   #15
resetreset
Senior Member
 
Registered: Mar 2008
Location: India
Distribution: Dynebolic, Ubuntu 10.10
Posts: 1,320

Rep: Reputation: 51
Interesting.... I'd like to know how to remove the support for your pad if you had a PS/2 mouse....
 
  


Reply

Tags
disable, laptop, slackware, synaptic, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable Synaptics touchpad tapping? dafydil Linux - Hardware 8 09-22-2007 12:02 PM
Touchpad misbehaviour on toshiba satellite trebek Linux - Laptop and Netbook 6 12-10-2006 12:56 AM
Touchpad on Toshiba Satellite trebek Linux - Laptop and Netbook 4 05-29-2005 04:25 PM
toshiba satellite A10 touchpad halitayarci Linux - Laptop and Netbook 5 11-02-2004 02:16 PM
Toshiba Satellite 1135 Touchpad problems xymox Slackware 2 05-17-2003 11:37 AM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration