LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 08-26-2012, 09:26 PM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 3,992

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
How to disable NVIDIA on laptop with combined Intel/Nvidia


I have installed Debian Wheezy on an Asus N73S latop. I am sure the Nvidia or Nouveau kernel module is not loaded. The Intel i915 module is loaded.

Still the laptop gets too hot and battery life is too sort. The fan is running at lowest speed but my hand still gets cooked when I put it 5 cm from the air outlet.

I want to disable/depower/nuke the Nvidia chip completely. There are a zillion articles varying in age and succes rate.

Does someone have the state-of-the-art on the disabling the NVidia? I prefer to power it down completely.

Additional information on how to enable it again (either through module loading, bumblebee like program, editing xorg, or even rebooting is welcome.

Thanks

jlinkels
 
Old 08-27-2012, 02:20 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,667

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
I don't know if this laptop has a BIOS setting allowing to switch off or deactivate the nVidia GPU but that's the first thing I would check.
 
Old 08-27-2012, 04:47 PM   #3
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
There's a thing built into most kernels called vgaswitcheroo. For this to be enabled, you must have both the nouveau and intel drivers active and you must set both nouveau and intel modesetting to 1 (on) in the kernel command line.

Code:
i915.modeset=1 nouveau.modeset=1
Then you can see what's up by doing this:

Code:
cat /syskernel/debug/vgaswitcheroo/switch
To turn off the unused GPU (in this case Nvidia)

Code:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
should be done. You can put this in your rc.local to do it on bootup for you.

Also, /sys/kernel/debug/ should be mounted as debugfs in your fstab.

Code:
none 	/sys/kernel/debug 	debugfs 	defaults 	0 	0
Alex Brinister
 
1 members found this post helpful.
Old 08-28-2012, 08:29 PM   #4
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 3,992

Original Poster
Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Switching off seems to work correctly. Before issuing the echo OFF command I saw this:
Code:
0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0
and after issuing that command:
Code:
0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0
However, the disappointment is that it doesn't make any difference. Before and after the current is 2861000 according to /sys/class/power_supply/BAT0/current_now . I interpret that as 2.86 A, which is a lot at a battery voltage of 11V.

When I wait until the backlight switches off, the current becomes 2.2 A.

The CPU is running at 800 MHz, so power scaling seems to work as well.

I think I either drew a premature conclusion on the NVIDIA power consumption, or switching off was not succesful. But 0:\DIS: :Off:0000:01:00.0 confirms that it is switched off, isn't it?

jlinkels

Last edited by jlinkels; 08-28-2012 at 08:30 PM.
 
Old 08-28-2012, 10:27 PM   #5
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
Yes. It appears that the Nvidia card was already turned off. So it must be something else that is sucking your battery. Usually, on laptops, it's the screen and the wireless card. Those are very power hungry.

Alex Brinister
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable PaX for Nvidia Drivers dman777 Linux - Software 4 01-15-2011 02:30 AM
How to disable onboard intel graphic card on Toshiba M640 (Hybrid Intel/Nvidia) Marcelo Ruiz Linux - Laptop and Netbook 6 08-14-2010 09:59 AM
Laptop with nvidia GPU but there is no nvidia badge on it !! wanas Linux - Laptop and Netbook 2 08-01-2010 09:13 PM
Disable nVidia video adapter on Dell laptop? firebird Linux - Hardware 2 09-14-2009 07:52 PM
Nvidia disable higher resolution lazylogic Debian 2 07-15-2007 06:45 AM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration