LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   How to disable NVIDIA on laptop with combined Intel/Nvidia (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/how-to-disable-nvidia-on-laptop-with-combined-intel-nvidia-4175424128/)

jlinkels 08-26-2012 09:26 PM

How to disable NVIDIA on laptop with combined Intel/Nvidia
 
I have installed Debian Wheezy on an Asus N73S latop. I am sure the Nvidia or Nouveau kernel module is not loaded. The Intel i915 module is loaded.

Still the laptop gets too hot and battery life is too sort. The fan is running at lowest speed but my hand still gets cooked when I put it 5 cm from the air outlet.

I want to disable/depower/nuke the Nvidia chip completely. There are a zillion articles varying in age and succes rate.

Does someone have the state-of-the-art on the disabling the NVidia? I prefer to power it down completely.

Additional information on how to enable it again (either through module loading, bumblebee like program, editing xorg, or even rebooting is welcome.

Thanks

jlinkels

Didier Spaier 08-27-2012 02:20 PM

I don't know if this laptop has a BIOS setting allowing to switch off or deactivate the nVidia GPU but that's the first thing I would check.

abrinister 08-27-2012 04:47 PM

There's a thing built into most kernels called vgaswitcheroo. For this to be enabled, you must have both the nouveau and intel drivers active and you must set both nouveau and intel modesetting to 1 (on) in the kernel command line.

Code:

i915.modeset=1 nouveau.modeset=1
Then you can see what's up by doing this:

Code:

cat /syskernel/debug/vgaswitcheroo/switch
To turn off the unused GPU (in this case Nvidia)

Code:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
should be done. You can put this in your rc.local to do it on bootup for you.

Also, /sys/kernel/debug/ should be mounted as debugfs in your fstab.

Code:

none        /sys/kernel/debug        debugfs        defaults        0        0
Alex Brinister

jlinkels 08-28-2012 08:29 PM

Switching off seems to work correctly. Before issuing the echo OFF command I saw this:
Code:

0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

and after issuing that command:
Code:

0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

However, the disappointment is that it doesn't make any difference. Before and after the current is 2861000 according to /sys/class/power_supply/BAT0/current_now . I interpret that as 2.86 A, which is a lot at a battery voltage of 11V.

When I wait until the backlight switches off, the current becomes 2.2 A.

The CPU is running at 800 MHz, so power scaling seems to work as well.

I think I either drew a premature conclusion on the NVIDIA power consumption, or switching off was not succesful. But 0:\DIS: :Off:0000:01:00.0 confirms that it is switched off, isn't it?

jlinkels

abrinister 08-28-2012 10:27 PM

Yes. It appears that the Nvidia card was already turned off. So it must be something else that is sucking your battery. Usually, on laptops, it's the screen and the wireless card. Those are very power hungry.

Alex Brinister


All times are GMT -5. The time now is 11:22 AM.