LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-26-2005, 08:21 PM   #1
Ay-Karamba!
Member
 
Registered: Aug 2005
Location: Sydney
Distribution: Ubuntu, FC4
Posts: 43

Rep: Reputation: 15
help!, can't get intel soundcard working on my laptop


Hi,
I have Toshiba portege A100 laptop and running FC4 on it and I have problem with my soundcard. I've tried everything I could such as maxed out the volume, max everything in alsa-mixer but still nothing I can hear. When I do desktop -> system setting -> soundcard detection, It detects my soundcard correctly. But still when I do 'play test song' I can't hear anything and the application crashes. It detect my hardware as Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller, and the driver handling my soundcard is snd-intel8x0. Here's my /sbin/lsmod output,Can someone help please!!

Code:
Module                  Size  Used by
i915                   19009  1 
drm                    70101  2 i915
parport_pc             28933  0 
lp                     13001  0 
parport                40585  2 parport_pc,lp
autofs4                29253  2 
rfcomm                 42333  0 
l2cap                  30661  5 rfcomm
bluetooth              56133  4 rfcomm,l2cap
sunrpc                167813  1 
pcmcia                 29025  8 
ipt_REJECT              5569  1 
ipt_state               1857  7 
ip_conntrack           41497  1 ipt_state
iptable_filter          2881  1 
ip_tables              19393  3 ipt_REJECT,ipt_state,iptable_filter
video                  15941  0 
toshiba_acpi            5845  0 
button                  6609  0 
battery                 9413  0 
ac                      4805  0 
md5                     4033  1 
ipv6                  267841  8 
ohci1394               41353  0 
ieee1394              304441  1 ohci1394
yenta_socket           21449  2 
rsrc_nonstatic         12737  1 yenta_socket
pcmcia_core            50909  3 pcmcia,yenta_socket,rsrc_nonstatic
uhci_hcd               35153  0 
ehci_hcd               41037  0 
hw_random               5973  0 
i2c_i801                8781  0 
i2c_core               21569  1 i2c_i801
snd_intel8x0m          19589  0 
snd_intel8x0           34689  7 
snd_ac97_codec         75961  2 snd_intel8x0m,snd_intel8x0
snd_seq_dummy           3653  0 
snd_seq_oss            37057  0 
snd_seq_midi_event      9153  1 snd_seq_oss
snd_seq                62289  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          8781  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            51185  0 
snd_mixer_oss          17857  2 snd_pcm_oss
snd_pcm               100169  7 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              33605  3 snd_seq,snd_pcm
snd                    57157  20 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10913  2 snd
snd_page_alloc          9669  3 snd_intel8x0m,snd_intel8x0,snd_pcm
ipw2100                81716  0 
ieee80211              20484  1 ipw2100
ieee80211_crypt         6788  1 ieee80211
e100                   49473  0 
mii                     5441  1 e100
joydev                  9601  0 
dm_snapshot            17413  0 
dm_zero                 2113  0 
dm_mirror              26157  0 
ext3                  132681  2 
jbd                    86233  1 ext3
dm_mod                 58101  6 dm_snapshot,dm_zero,dm_mirror
 
Old 08-26-2005, 08:46 PM   #2
robert2513
Member
 
Registered: Oct 2004
Posts: 35

Rep: Reputation: 15
Hello there.

I had a similar problem when I installed FC4 on my Inspiron 9100. Heres what I did to get my sound working.

Open up a terminal window and type in
Code:
alsamixer
Press the left arrow key until you get to an entry called "External." Highlight it and press the m key. Then hit the ESC key to save the changes. For some reason, the sound is muted by default.

Hope this helps.
Robert2513
 
Old 08-27-2005, 08:31 PM   #3
Ay-Karamba!
Member
 
Registered: Aug 2005
Location: Sydney
Distribution: Ubuntu, FC4
Posts: 43

Original Poster
Rep: Reputation: 15
God, it worked.. thanks a lot man.. I've been figuring it for weeks and I found out it's only that simple.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel onboard soundcard not working anothernixconvert Mandriva 2 11-29-2005 08:20 PM
Intel soundcard not working on slack 10.1 IntelSlacker Slackware 3 03-28-2005 08:23 AM
TV Out on Toshiba laptop - intel 855 not working belga Linux - Laptop and Netbook 1 02-06-2005 02:07 AM
Soundcard detected on Sony S260 laptop but not working kkempter Linux - Hardware 1 12-24-2004 01:49 PM
Intel ICH5 Soundcard help CryptDragoon Slackware 3 01-28-2004 01:38 PM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration