LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Have problem with suspend (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/have-problem-with-suspend-783632/)

mmpsy 01-17-2010 03:38 PM

Have problem with suspend
 
Hi, I have an hp dv3-2230ea and I suffer the same problems with Ubuntu 9.10 and Gnome, except it won't wake up from either suspend or hibernate. Could it be that the swap partition is too small for my RAM ? How would I find out and / or fix ?

It's most inconvenient - is there a way of switching off both suspend and hibernate completely - just have the thing carry on as usual when the lid is closed ? Gnome doesn't seem to give me this option.

:-! M.

vansch76 01-19-2010 03:17 PM

Hi MM

just change the "suspend" to "do nothing" instead.
this will disable suspend and hibernation.

Vanessa

Ion Silverbolt 01-19-2010 04:22 PM

So is the computer powered up, but the screen is not turning on? Or is the computer itself staying in suspend?

My screen stays dark after exiting suspend because of a specific module I have. There's an easy script you can create and run to get around this issue though.

Create a new file and put it somewhere in your home folder. (screen.sh for example)

Open the file with a text editor and post this in it:
Code:

xrandr --output LVDS1 --auto
Now all you have to do is assign a keyboard shortcut to run this file. If your screen fails to wake up, this may help with that issue. For example, I have CTRL+S assigned to wake the screen if it stays black. This is what I have the CTRL+S shortcut run:

sh /home/silverbolt/backups/screen.sh

I'm using xfce, so I don't know right offhand where you assign keyboard shortcuts in gnome. But I'm sure it's somewhere that isn't too hard to find.

michaelk 01-20-2010 09:53 PM

Your posts have been moved to their own thread since your problem is really unrelated to the original poster.

mmpsy 01-22-2010 05:34 PM

Many thanks, Vanessa and Ion.

Re. Vanessa's advice, there seems to be no such option in my Gnome powermanagement menu, but setting to just 'black screen' seems to prevent the crash - so it's a useful interim solution.

I'll try Ion's advice as soon as I find out how to assign the shortcut key combo, and see if this improves the 'suspend' situation.

The computer doesn't *stay* upin suspend or in hibernate, if one of these options are chosen. It appears to 'try' to wake up, as follows:
- In suspend, the various lights come on but the screen remains black whatever keystrokes I try (therefore I have some hope re. Ion's advice)
- To try to awake from hibernate I have only got a response by using the power-on button. It then shows the GRUB screen, but when it goes into Ubuntu it shows the screen with the logo and then the message "Please wait while the computer wakes up" - then it hangs with this message on the screen (I have waited for ages just in case).

Thanks again for the advice!
:-) Michael.


All times are GMT -5. The time now is 07:57 AM.