LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   GUI not working on HP Laptop (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/gui-not-working-on-hp-laptop-4175445209/)

ankitsahai 01-11-2013 10:45 PM

GUI not working on HP Laptop
 
Hi,

I have installed RHEL5.4 on HP laptop without any problem.
But when I am booting with it, I end up with GUI not working though CLI is woking perfectly. Getting error saying Touch Pad mouse not configured correctly.

Please let me know what more details are required

Waiting for a response.

TobiSGD 01-11-2013 10:48 PM

Would be nice to have information about the hardware you are using.

DavidMcCann 01-12-2013 12:35 PM

We need to know what sort of touchpad it is. If it's a Synaptic, this thread might help:
http://forums.fedoraforum.org/showthread.php?t=246126

But if you bought RHEL, then ask them! That's the service you paid for. If you didn't buy it, then you've got a demo and you'll never get any bug fixes or anything else — get a free Linux.

ankitsahai 01-13-2013 12:58 AM

More details about the issue

Laptop Model is : HP ProBook 4431s

I am getting the below error when booting from Linux:

"Unable to Query Synaptics Hardware"

Failed to start X server. It seems that the pointer device (your mouse) is not set up correctly.

Log File "/var/log/Xorg.0.log" has following ERROR lines:

EE: Synaptics no synaptics touchpad detected & no repeater device
EE: Synaptics Unable to query/initialize Syanptics hardware
EE: PreInit failed for input device "syanptics"
II: Unload Module "synaptics"

cascade9 01-13-2013 03:37 AM

Using a 2009-09-02 (5.4) version of Red Hat on a 2011/2012 model laptop? I'm not suprised you've got GUI isseus, the kernel, xorg, etc. would have major issues with hardware it knows nothing about.

Try upgrading to a newer version like 5.8+/6.2+. Or try contacting Red Hat and see what they say (and if you arent paying for Red Hat, install CentOS)

ankitsahai 01-13-2013 07:21 AM

I have installed RHEL6 as well but faced the same issue.

cascade9 01-13-2013 08:06 AM

RHEL 6.0 is a 2010 version......

DavidMcCann 01-13-2013 10:06 AM

You haven't said whether you've actually bought Red Hat. It's quite capable of supporting modern hardware, but only if you update it and you can't update a demo. As I said before, if you've paid, complain to Red Hat. If you haven't, then don't use it.

John VV 01-13-2013 04:20 PM

if you do have a paid for license ( REQUIRED)
contact your sails rep from red hat

and download and register RHEL 6.3

BUT

red hat is a server class OS and was never designed for a laptop !!!

Now most of the time it will mostly work mostly well on a laptop

but not on every laptop


also
if you did not buy the required license
you can not install anything to fix it

CentOS 6.3 has added extra software for desktop and laptop use software that is not on the rhel dvd
( but downloadable from RHN with a registered install )


All times are GMT -5. The time now is 04:39 PM.