LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   grub legacy on netbook Samsung N130 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/grub-legacy-on-netbook-samsung-n130-897612/)

Luise 08-16-2011 09:30 AM

grub legacy on netbook Samsung N130
 
I do not know whether this is the right forum - since I do not know whether my problem is in any way netbook-connected.

When I installed Debian lenny and chose grub legacy for my boot loader, I had it installed in the mbr.

At that time I had one other linux OS on my computer. Grub recognized it, wrote it into the /boot/grub/menu.lst and everything was fine.

Afterwards I backed up my system completely to another partition and wanted (and still want) to be able to boot up to it and work on it. (Of course I edited the fstab).

After that I edited the menu.lst, i. e. I manually added the bu-system to it, copying the text of the other OS and changing the /dev to boot up to.

Nothing I have tried so far has worked. The bu-system, i.e. the third OS just will not show up in the boot menu at start.

In the meantime I had changed the boot manager in the mbr by grub cp, working from a different system. It did list the bu system in the boot menu and I did manage to boot up to the system with it - but I did not really like it. So I tried lilo - which also did not work.

So I decided to try again to use grub legacy, which was still existent in lenny (my work system) and found the how-to quoted below on how to "recover grub)

Quote:

http://wiki.debian.org/GrubRecover

Reinstall GRUB bootloader (grub manual)

If you have grub-legacy 2 and your root partition is /dev/sda3 then you can re-install grub in the MBR of your hard drive by typing the following commands :

sudo grub
grub>root (hd0,2)
grub>setup (hd0)
grub>quit
exit

Note that in grub-legacy (hd0,2) is the third partition.

Then choose "Reboot the system", everything should be fine.
Again it did not work.

This issue has been running for months now and I have asked on the German and English-language debian forums. No-one could help me.

So for a last attempt I am asking here :banghead:

Below is the (I think) relevant part of the code of my /boot/grub/menu.lst

#
Code:

## ## End Default Options ##
#
 
#
title          Debian GNU/Linux, kernel 2.6.26-2-686
#
root            (hd0,4)
#
kernel          /boot/vmlinuz-2.6.26-2-686 root=/dev/sda5 ro
#
initrd          /boot/initrd.img-2.6.26-2-686
#
 
#
title          Debian GNU/Linux, kernel 2.6.26-2-686 (single-user mode)
#
root            (hd0,4)
#
kernel          /boot/vmlinuz-2.6.26-2-686 root=/dev/sda5 ro single
#
initrd          /boot/initrd.img-2.6.26-2-686
#
 
#
### END DEBIAN AUTOMAGIC KERNELS LIST
#
 
#
# This is a divider, added to separate the menu items below from the Debian
#
# ones.
#
title          Other operating systems:
#
root
#
 
#
 
#
# This entry automatically added by the Debian installer for an existing
#
# linux installation on /dev/sda1.
#
title Ubuntu, Linux 2.6.31-14-generic (on /dev/sda1)
#
root (hd0,0)
#
kernel /boot/vmlinuz-2.6.31-14-generic root=UUID=4ee6dbcd-6fd6-411c-b3c0-106d4971db46 ro
#
initrd /boot/initrd.img-2.6.31-14-generic
#
savedefault
#
boot
#
 
#
 
#
# This entry automatically added by the Debian installer for an existing
#
# linux installation on /dev/sda1.
#
title          Ubuntu, Linux 2.6.31-14-generic (recovery mode) (on /dev/sda1)
#
root            (hd0,0)
#
kernel          /boot/vmlinuz-2.6.31-14-generic root=UUID=4ee6dbcd-6fd6-411c-b3c0-106d4971db46 ro single
#
initrd          /boot/initrd.img-2.6.31-14-generic
#
savedefault
#
boot
#
 
#
# This entry manually added for the bu on /dev/sda4
#
title<-><------>Debian GNU/Linux, kernel 2.6.26-2-686 (on /dev/sda4)
#
root<--><------>(hd0,3)
#
kernel<><------>/boot/vmlinuz-2.6.26-2-686 root=/dev/sda4 ro.
#
initrd<><------>/boot/initrd.img-2.6.26-2-686
#
savedefault
#
boot
#
 
#
title<-><------>Debian GNU/Linux, kernel 2.6.26-2-686 (single-user mode)
#
root<--><------>(hd0,3)
#
kernel<><------>/boot/vmlinuz-2.6.26-2-686 root=/dev/sda4 ro single
#
initrd<><------>/boot/initrd.img-2.6.26-2-686
#

Aside from the practical issue, I am also just interested in the reason why this does not work.

Is anyone here expert on grub legacy and can enlighten me?

yancek 08-16-2011 12:54 PM

You are booting from Debian on sda3, trying to boot ?? a Debian backup system?? on sda5??
It's not really clear to me.
What is your other Linux system and are you able to boot it? Is it just the backup you are unable to boot? What method did you use to create it? dd command, clonezilla, something else??

Do you have the kernel and initrd files listed in the menu.lst in the /boot directory on sda5?


All times are GMT -5. The time now is 06:09 PM.