-   Linux - Laptop and Netbook (
-   -   Getting multimedia keys working in FC9 KDE 4.1 (

dwmorton 09-17-2008 10:28 PM

Getting multimedia keys working in FC9 KDE 4.1
I have using Linux for a while, but am a novice on dcop, dbus and khotkeys.

I have a Dell XPS 1530 running FC9 x86_64 with KDE 4.1 installed. The multimedia keys work just fine under Gnome. However, they don't work at all under KDE.

I used the following command (borrowed from an Ubuntu bug report) to map out the multimedia keys:

xev | grep -A2 --line-buffered '^KeyRelease' | sed -n '/keycode /s/^.*keycode \([0-9]*\).* (.*, \(.*\)).*$/\1 \2/p'

output generated by pushing the multimedia buttons in order from left to right:
144 XF86AudioPrev
164 XF86AudioStop
162 XF86AudioPlay
153 XF86AudioNext
160 XF86AudioMute
174 XF86AudioLowerVolume
176 XF86AudioRaiseVolume

I assume this means X11 knows about these buttons, which makes sense since Gnome works out of the box.

If I go directly into kmix and define a shortcut for, say, muting kmix using the multimedia mute button, a pop up window says this is already defined in khotkeys and asks me if I want to change it. When I look at khotkeysrc under my home directlry (~/.kde/share/config/khotkeysrc), there is no mention of any X86Audio shortcut definitions. This is also true for imported khotkeys config files listed in the [main] section of the khotkeysrc file.

I have also discovered that dcop no longer seems to talk to kmix under KDE 4.1. Under systemsettings -> advanced -> inputActions, dbus now appears wherever dcop used to appear in the menu pics. Typing 'dcop kmix' returns 'No such application: kmix'.

2 questions:

1. Where on earth is khotkeys getting the definitions for these multimedia keys?

2. Any suggestions on how to get kmix to respond to my multimedia keys?


Doug Morton

andrems 09-18-2008 04:09 PM

I had silimar problems and kept trying until I read this. Khotkeys and the input actions are broken in KDE 4.

If you were thinking of using something like xbinkeys to associate a key to a command, use DBus instead


$ qdbus org.kde.kmix /Mixer0
Will show you all the functions for Mixer0, you can use this pretty much like dcop


$ qdbus org.kde.kmix /Mixer0 org.kde.KMix.masterDeviceIndex
Lists the deviceidx available and

$ qdbus org.kde.kmix /Mixer0 org.kde.KMix.toggleMute PCM:0
toggles the mute for PCM.

dwmorton 09-18-2008 10:01 PM

Thanks! I learned about and worked through the qdbus commands and they work great from the command line.

I ran squarely into the khotkeys bug again when I entered these qdbus commands into the "input actions" menu of "system settings". After programming each multimedia key, I found that pushing the "Try" button worked great, however, the media keys still didn't do anything. I did not realize the "systems settings" menu used khotkeys, which as you pointed out, is broken in KDE 4.1.

I went on to set up things in "keyboard shortcuts" which is under the "keyboard & mouse" menu. As I programmed each key, it complained that the keys are already programmed into khotkeys, but since khotkeys is broken, it doesn't really matter. Also, using this submenu, I could not program buttons for a media player, but it did get kmix responding to the volume and mute multimedia keys.

Specific settings I made for my Dell M1530:
Assign "Volume UP" to: Increase Volume - PCM, HDA Intel
Assign "Volume Down" to: Decrease Volume - PCM, HDA Intel
Assign "Volume Mute" to: Toggle Mute - Front, HDA Intel

I tried assigning "Volume Mute" to "Toggle Mute - PCM, HDA Intel", but that didn't do anything.

All times are GMT -5. The time now is 06:00 AM.