LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-03-2011, 06:17 AM   #1
Royzz
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Rep: Reputation: 0
Smile Function key strokes are not registering in xev


Hi,
I am using a Toshiba Satellite Pro L510 running on a 2.6.38-11 Ubuntu 11.04.

My Function key strokes are not registering in Xev. None of the Functions mapped to Function keys are working as well. I tried this, but the program didn't compile.

This is the error that I get after commenting line 294 in init.c:

Code:
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-11-generic'
  CC [M]  /home/bodhi/Downloads/omnibook-2.20070211/ac.o
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:45:44: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ac_driver’
/home/bodhi/Downloads/omnibook-2.20070211/ac.c: In function ‘__check_ac’:
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:57:1: error: ‘ac_driver’ undeclared (first use in this function)
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:57:1: note: each undeclared identifier is reported only once for each function it appears in
/home/bodhi/Downloads/omnibook-2.20070211/ac.c: At top level:
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:57:1: error: ‘ac_driver’ undeclared here (not in a function)
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:57:1: warning: type defaults to ‘int’ in type name
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:21:12: warning: ‘omnibook_ac_read’ defined but not used
/home/bodhi/Downloads/omnibook-2.20070211/ac.c:36:28: warning: ‘ac_table’ defined but not used
make[2]: *** [/home/bodhi/Downloads/omnibook-2.20070211/ac.o] Error 1
make[1]: *** [_module_/home/bodhi/Downloads/omnibook-2.20070211] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-11-generic'
make: *** [omnibook.ko] Error 2
Any ideas how to get my Function key working? Currently, I am using the Super key as an alternate to the Fn. key.
Thanks in advance,
Royzz.
 
Old 09-03-2011, 12:54 PM   #2
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
The Fn key does not register with xev on my laptop either.
Ctrl, Shift, CapsLock, Super and Alt all do.

Which leaves me to believe that Fn is special in some way - it may be processed by the keyboard hardware rather than X, to make up for the lack of keyboard space on a laptop.

Perhaps that explains why the Fn key is often coloured blue?
 
Old 09-04-2011, 03:09 AM   #3
Royzz
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Talking

Usually it is colored in "blue" or "yellow" or some other color to distinguish it from the general Fn.Key presses.

You see, Fn.keys(F1-F12) in laptops are also paired with some other functions (sleep, hibernate, mute, brightness etc.), which can only be accessed by pressing the Fn. Key. You will realize that even those functions are color-coded in some different color, and the Fn. key is also the same color to intuitively make users understand that those functions can only be accessed while pressing the Fn. key.

But the problem still remains inconclusive: why can't X register the Fn. key stroke?
 
Old 09-04-2011, 05:27 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Make sure have the toshiba laptop (extras) kernel module inserted. The Fn keys often work using ACPI, so maybe that's why they don't show up in xev.
 
Old 09-04-2011, 04:51 PM   #5
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Quote:
You see, Fn.keys(F1-F12) in laptops are also paired with some other functions (sleep, hibernate, mute, brightness etc.), which can only be accessed by pressing the Fn. Key. You will realize that even those functions are color-coded in some different color, and the Fn.
Yes, yes, I know about that.

The point I am trying to make is that the Fn key is sent to the hardware of the laptop keyboard (that is too space-limited to have enough real, keys to do its proper job) and then the correct key code ("Up-Volume", or "Wireless Off/On") is sent to X. This is right and proper.

The fact that you have pressed the Fn key is not sent to X is because X does not care that you have a crippled (not enough physical keys available) keyboard. Your keyboard just sends the correct code ("Toggle wireless Off/On") when you send your keyboard the right key Fn presses.

If you do not understand this advice, reply here, and I'll do my best to follow it up.
 
Old 09-04-2011, 09:52 PM   #6
Royzz
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
@H_TeXMeX_H, thanks for your advice!
It actually works, though not perfectly. Only the brightness functions work, the mute, sleep,etc. options are still non-responsive.

Thanks tredegar!
Yep, that makes perfect sense actually. I see that it's happening. My xev registers a XF86AudioMute on pressing Fn.+Esc. However, the AudioMute event never occurs when I normally press it in X. Any ideas why?
 
Old 09-05-2011, 06:19 AM   #7
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Check your System - Preferences - Keyboard shortcuts.
Under the Sound heading, mine lists things like:
Code:
Action         Key
Volume Mute    XF86AudioMute
Volume Down    XF86AudioLowerVolume
Perhaps yours just needs configuring if the keyboard is sending the right events (which it seems to be).
 
Old 09-05-2011, 09:35 AM   #8
Royzz
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
I just created a new account for my system, and everything works.
Hence, I deleted my old account, created a new one, copied all stuff. And now everything works.
 
  


Reply

Tags
function, toshiba, xev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to programatically feed top with key strokes babaqga Linux - Software 4 09-02-2010 02:54 AM
Midnight Commander requires twice the key-strokes jsmith6 Slackware 13 05-19-2006 03:47 PM
problem recognising key strokes himateja Programming 3 05-27-2005 05:54 AM
Identifying and Mapping/Binding key strokes mikeyt_333 Linux - General 3 10-02-2003 10:42 PM
Repeating key strokes toxic53 Linux - General 1 12-11-2002 09:06 PM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration