LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Framebuffer problem -- IBM T43, ATI Radeon X300 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/framebuffer-problem-ibm-t43-ati-radeon-x300-883872/)

exquisite_corpse 06-01-2011 02:26 AM

Framebuffer problem -- IBM T43, ATI Radeon X300
 
Hello all. I just install slack 13.37 on my IBM Thinkpad. I'm having this issue with the framebuffer: I configure lilo to use 800x600x32 (I use the console a lot, and I like slightly larger text)... then when I install lilo and reboot, the boot process starts, and for a few moments the resolution is 800x600x32, and the right before going multiuser it switches to 1060x768x?? (not sure exactly, but the console text is VERY small)

Can anyone here help me try to fix this?

Oh and one more thing, I wanted to test and see what happens if the radeon module is not loaded at boot time, but the module doesn't seem to be in /etc/rc.d/rc.modules. I'm confused.

business_kid 06-01-2011 05:04 AM

Give up. KMS is here. Use the Terminus fonts instead, and forget framebuffer. Let it do it's thing. I have this line in rc.local

/usr/bin/setfont ter-28kn

And I have nice big console fonts(on 2 radeon cards).
As for the radeon module and Slackware, after a certain point the option to use KMS went in by default. Go with it, it's easier than trying to beat it.

adamk75 06-01-2011 05:27 AM

The radeon module is probably being loaded by udev. Which is a good thing... KMS has to be fully loaded before X starts or you won't get direct rendering.

Pass 'video=800x600' to the kernel and KMS should use that resolution.

Adam

exquisite_corpse 06-01-2011 11:20 AM

Quote:

Originally Posted by adamk75 (Post 4372857)
The radeon module is probably being loaded by udev. Which is a good thing... KMS has to be fully loaded before X starts or you won't get direct rendering.

Pass 'video=800x600' to the kernel and KMS should use that resolution.

Adam

Hey thanks for the reply adam. If you don't mind, could you explain to me how to pass video=800x600 to the kernel. I'm kind of new at this stuff. Thanks!

adamk75 06-01-2011 11:29 AM

Edit /etc/lilo.conf and add video=800x600 to the append line. It should read something like:

Code:

append=" vt.default_utf8=0 video=800x600"
Then, of course, run lilo :-)

Adam

exquisite_corpse 06-01-2011 05:39 PM

Quote:

Originally Posted by adamk75 (Post 4373197)
Edit /etc/lilo.conf and add video=800x600 to the append line. It should read something like:

Code:

append=" vt.default_utf8=0 video=800x600"
Then, of course, run lilo :-)

Adam

works great! thanks adam


All times are GMT -5. The time now is 01:07 PM.