LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 05-05-2012, 07:57 PM   #1
siickboii
Member
 
Registered: May 2012
Posts: 62

Rep: Reputation: Disabled
fedora 16 grub1.99 and windows7


My question/problem has been asked many times but I can't seem to get problem fixed following the comments that's been left. I have both windows and fedora running on my laptop. When grub loads, it's fedora that boots by default and I desire windows to boot by default.
This is what I have tried; In fedora I open terminal and at user prompt I type su and then get a password prompt. I type password and get this prompt; [root@siicboii siicboii]#
At this point I have typed several commands that have been left in comments such as /boot/grub/menu.lst and also /boot/grub/grub.conf and /boot/grub/grub.cfg and /boot/grub2/grub.conf
I always get; bash command not found.......

Can anyone help me with this?
 
Old 05-05-2012, 08:08 PM   #2
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,523

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
If you are using Grub 1.99 on Fedora you need to go to the /etc/default/grub file and open it in a text editor as root user. Change the line below:

Quote:
GRUB_DEFAULT=0
The above should be the first line in the file. You would need to change the number zero (0) as shown above to whatever your windows entry is in the grub.cfg file so open the grub.cfg file: cat /boot/grub/grub.cfg and just count the menuentry titles until you get to the windows and put that number in the /etc/default/grub file. Grub entries count from zero, so if windows is the third menuentry, you put 2. Run update-grub as root after you make the change.
 
1 members found this post helpful.
Old 05-05-2012, 08:36 PM   #3
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
/ect/default/grub file.....says no such file
/ect/default/grub.conf.....says no such file

:-(
 
Old 05-05-2012, 08:51 PM   #4
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
Are you certain you are using GRUB 1.99 and not GRUB-legacy (0.97). Fedora does not install GRUB 1.99 by default, it installs GRUB-legacy. Did you install GRUB 1.99 from the Fedora repos?

What does this command returns:

Code:
su -c "which grub-install grub2-install"
 
1 members found this post helpful.
Old 05-05-2012, 08:58 PM   #5
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
When I boot up this is what it says
GNU GRUB version 1.99

It's what came with the fedora16 iso I downloaded from their site....
 
Old 05-05-2012, 09:06 PM   #6
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by towheedm View Post
Are you certain you are using GRUB 1.99 and not GRUB-legacy (0.97). Fedora does not install GRUB 1.99 by default, it installs GRUB-legacy. Did you install GRUB 1.99 from the Fedora repos?

What does this command returns:

Code:
su -c "which grub-install grub2-install"
I'm on my iPhone at work so please excuse any typos..... I ran that code on my laptop and it said this----> which: no grub-install in (/user/local/bin:/user/bin:/bin:/user/local/sbin:/user/sbi/sbin/grub2-install
 
Old 05-05-2012, 09:14 PM   #7
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
Sorry, I MUST learn to read. Fedora 16 does install GRUB 1.99 by default.

This also means that there MUST be a /etc/default/grub file.

Please post the results of:
Code:
ls -l /etc/default
 
1 members found this post helpful.
Old 05-05-2012, 09:29 PM   #8
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
I can go through the GUI and there is a file named grub at ect/default/ grub but it won't let me edit cause it says I don't have promission. But I log in su on terminal and can't find it
 
Old 05-05-2012, 09:42 PM   #9
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by towheedm View Post
Sorry, I MUST learn to read. Fedora 16 does install GRUB 1.99 by default.

This also means that there MUST be a /etc/default/grub file.

Please post the results of:
Code:
ls -l /etc/default
total 12
-rw-r--r--. 1 root root 236 May 5 12:58 grub
-rw-r--r--. 1 root root 1756 Oct 26 2011 nss
-rw-------. 1 root root 119 July 25 2011 useradd
 
Old 05-05-2012, 09:49 PM   #10
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
On Fedora, to run a GUI app as root requires you to install the 'beesu' package:
Code:
 su -c "yum install beesu"
Then:
Code:
beesu gedit /etc/default/grub
Or, if you're familiar with nano, simply:
Code:
su -c "nano /etc/default/grub"
Now, there are several ways of setting the Windows 7 menuentry item as the default. Check the position of the Windows 7 entry within the GRUB menu with the first entry starting at 0. So if Windows 7, is on the 4th line, it's entry 3.

Now change this line in /etc/default/grub to the entry number for Windows 7:
Code:
GRUB_DEFAULT=<the entry number for Win7>
The disadvantage of this, is that if you add other entries (even a simple kernel upgrade can cause this) before it, you must change it again.

A more fool-proof way is the set GRUB_DEFAULT to the title of the Windows 7, ie: if the entry is 'Microsoft Windows 7 (on /dev/sdb1)', set:
Code:
GRUB_DEFAULT="Microsoft Windows 7 (on /dev/sdb1)"
You may also want to set the default time that GRUB waits before booting the default entry:
Code:
GRUB_TIMEOUT=<no. of secs to wait>
Remember to update GRUB's boot configuration script after any changes to /etc/default/grub:
Code:
su -c "grub2-mkconfig -o /boot/grub2/grub.cfg"

Last edited by towheedm; 05-05-2012 at 09:51 PM.
 
1 members found this post helpful.
Old 05-05-2012, 10:14 PM   #11
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
towheedm I assume I need Internet access to load beesu package? Im at work and only have net access on my phone.
 
Old 05-05-2012, 10:30 PM   #12
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
Then use nano from the terminal:
Code:
su -c "nano /etc/default/grub"
It's a very simple text editor. <CTRL-O> to save your changes and <CTRL-X> to exit when done.
 
1 members found this post helpful.
Old 05-05-2012, 10:40 PM   #13
siickboii
Member
 
Registered: May 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by towheedm View Post
Then use nano from the terminal:
Code:
su -c "nano /etc/default/grub"
It's a very simple text editor. <CTRL-O> to save your changes and <CTRL-X> to exit when done.
tried the nano and it returns. command. not found
maybe banging my head against the wall would help? tehehe
 
Old 05-05-2012, 10:45 PM   #14
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
Code:
su -c "which nano"
returns what?

Just checked and apparently nano is not installed by default in F16.

Last edited by towheedm; 05-05-2012 at 10:48 PM.
 
1 members found this post helpful.
Old 05-05-2012, 10:55 PM   #15
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,523

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
Try gedit as a possible text editor. Look under the Applications tab and find the name of the editor then open a terminal and as root (explained in a previous post) open the editor to that file.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
quad boot windows7, os/x snow leopard, fedora/ubuntu and backtrack 5 gnome aliabbass Linux - General 4 02-10-2012 06:44 AM
difference between GRUB1 and grub2 nsrihari Linux - Newbie 3 02-05-2012 01:26 AM
[SOLVED] installed fedora 10 on windows7 64bit but doesent booot after installation ndhanashekar Linux - Newbie 2 07-28-2011 10:59 PM
Lilo vs grub1 vs grub2 honeybadger Linux - General 8 12-03-2010 11:42 AM
grub4dos is grub2 or grub1? zoombee Linux - General 10 07-29-2010 05:25 AM


All times are GMT -5. The time now is 08:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration