LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 03-18-2010, 11:33 AM   #1
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Rep: Reputation: 0
Fedora 12 and Intel WiFi 5100 not working


I upgraded to Fedora 12 and lost the connection to the INTEL WireLess WiFi Link 5100 card. Also, when I plug in an Ethernet cable and fire up Firefox and try to add a second tab to the display the Ethernet connection disconnects.

The following is information on my computer -

/sbin/lspci -vnn

0e:00.0 Network controller [0280]: Intel Corporation Wireless WiFi Link 5100 [8086:4232]
Subsystem: Intel Corporation Device [8086:1201]
Flags: bus master, fast devsel, latency 0, IRQ 31
Memory at f2100000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [e0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-22-fa-ff-ff-2f-d9-8e
Kernel driver in use: iwlagn
Kernel modules: iwlagn

14:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
Subsystem: COMPAL Electronics Inc Device [14c0:0031]
Flags: bus master, fast devsel, latency 0, IRQ 30
I/O ports at 4000 [size=256]
Memory at f2010000 (64-bit, prefetchable) [size=4K]
Memory at f2000000 (64-bit, prefetchable) [size=64K]
[virtual] Expansion ROM at f2020000 [disabled] [size=64K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/2 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=2 Masked-
Capabilities: [d0] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
Kernel driver in use: r8169
Kernel modules: r8169

Regards
 
Old 03-19-2010, 05:13 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
The firefox error is weird. But don't use eth0 & wlan0 together unless you are sure no network switching is set in the bios. Often, using the nic will turn off wifi and vice versa. Even tweaking it on startup is sometimes enough to lose you wifi.
 
Old 03-20-2010, 10:23 AM   #3
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks. I'll keep working on stuff and hopefully post a nifty update/reply soon.
 
Old 03-21-2010, 04:59 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
The basic process for an open network by hand is
ifconfig wlan0 up
iwlist wlan0 scan and copy themac address of your intended AP
iwconfig essid<your_essid> ap <mac address>

At his point you should see "associated" in the first few lines of the iwconfig wlan0 o/p

Then go for dhcp.
Let us know where you come unstuck.
 
Old 03-21-2010, 05:42 AM   #5
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Also, it may be useful to note that many wireless Intel cards use proprietary drivers to run.

I am not sure if it's quite the problem you are having or not, or if this applies to your card, but it's useful to know since Fedora follows strict license policies.
 
Old 03-27-2010, 10:14 AM   #6
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
update on stuff

Hey,

The iwlist wlan0 scan returns -

wlan0 Scan completed :
Cell 01 - Address: 00:13:46:AA:76:74
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-33 dBm
Encryption keyn
ESSID:"DI-624_WIRELESS"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s
Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000003ab7246036
Extra: Last beacon: 385ms ago
IE: Unknown: 000F44492D3632345F574952454C455353
IE: Unknown: 010882848B960C183048
IE: Unknown: 030106
IE: Unknown: DD0600032F010001
IE: Unknown: 2A0100
IE: Unknown: 32041224606C
IE: Unknown: DD0900037F010100170000
IE: Unknown: DD0C00037F0201010A0002A34000
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00

The iwconfig return is -
iwconfig essid<"DI-624_WIRELESS"> ap<00:13:46:AA:76:74>
bash: syntax error near unexpected token `newline'

I'm not sure what that means.

Then an iwconfig wlan0 returns
wlan0 IEEE 802.11abgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry long limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

On a side note, using the Gnome menu shows the following -
system ; preferences ; startup applications ; network manager

command 'nm-applet --sm-disable

My mistake reporting the ethernet connection not working - it does work. It's firefox that shuts down if I try to open more than one tab. Opera seems to work OK.

Regards
 
Old 03-28-2010, 05:53 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
iwconfig essid<"DI-624_WIRELESS"> ap<00:13:46:AA:76:74>">

Sorry for confusion; my bad.
remove all the < & > from the line, and add in wlan0

iwconfig wlan0 essid "DI-624_WIRELESS" ap 00:13:46:AA:76:74

IO don't know if the "" are necessary around the essid.
 
Old 05-09-2010, 11:51 AM   #8
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
Hey,
The following is the latest attempt to activate things -

root@Georges David]# ifconfig wlan0 up
[root@Georges David]# iwconfig wlan0 essid "DI-624_WIRELESS" ap 00:13:46:AA:76:74
[root@Georges David]# iwconfig wlan0 essid DI-624_WIRELESS ap 00:13:46:AA:76:74
[root@Georges David]#

The wireless netwrok icon shows 'device not ready'.

Regards
 
Old 05-10-2010, 04:38 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
Shut whatever network manager that is running. There's nothing ore confusing than two things trying to set up the same card. Let's try it the long way by hand

ifconfig wlan0 up
ifconfig (should show details of wlan0)
iwconfig (should show details of wlan0)
iwlist wlan0 scan |less (should see your base and perhaps other channels. copy your ap mac address)
If you have wpa_encryption, do check that your psk has been run through wpa_passphrase - man wpa_passphrase & man wpa_supplicant.conf. If you need that a line try
wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext
then
iwconfig wlan0 essid DI-624_WIRELESS ap 00:13:46:AA:76:74

Now you're not getting online, so you won't get that far. Tell us what command gives the error.
 
Old 05-11-2010, 08:02 PM   #10
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
Hi,

wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext

wpa_supplicant: error while loading shared libraries: libssl.so.8: cannot open shared object file: No such file or directory


I've had trouble updating software, and I tried using yum and am getting a similar error message

yum check -update

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

libssl.so.8: cannot open shared object file: No such file or directory

In the lib subdirectory there is no libssl.so.8 file so I tried

yum install libssl.so.8

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

libssl.so.8: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.2 (r262:71600, Aug 21 2009, 12:22:21)
[GCC 4.4.1 20090818 (Red Hat 4.4.1-6)]

I'm not sure how to get the libssl.so.8 file downloaded and installed.

Regards
 
Old 05-12-2010, 05:07 AM   #11
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
libssl is probably part of the openssh package. If yum won't run, get your install cd and try to install openssh from your install cd using rpm -ivh openssh-whatever.rpm

I also have a libssl in the 32 bit libs (this is a 64 bit box) and you may need a 32 bit version if you are in a similar spot. That one came in a general aaa-elflibs32. You might have something similar
 
Old 05-13-2010, 11:56 AM   #12
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
Hey

I went to the kindly folks at
http://rpm.pbone.net/index.php3/stat...ch/libssl.so.8

and downloaded the file
Fedora/i386/os/Packages/openssl-0.9.8k-1.fc11.i686.rpm

The file is now located on a thumb drive -
Erickson/libssl/openssl-0.9.8k-1.fc11.i686.rpm

I would like to try to install the file to the subdirectory "lib"

Could you provide a script to install?

Regards
 
Old 05-13-2010, 12:14 PM   #13
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
It's an rpm. Install it with the Package Manager...
 
Old 09-10-2010, 07:48 PM   #14
overthere
LQ Newbie
 
Registered: Jul 2009
Location: Texas & France & Russia
Distribution: Fedora 12
Posts: 12

Original Poster
Rep: Reputation: 0
It seems that the problem was with the settings for the D-Link wireless router and had nothing to do with Fedora 12 or the wireless card. Thanks for your patience and time.
 
  


Reply

Tags
intel, wifiwireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel WiFi Link 5100 - Is 802.11n (Draft-N) possible? Yankee_Fan Linux - Laptop and Netbook 3 08-22-2010 12:06 PM
My Intel(R) Wifi Link 5100 AGN - not detected ohmeng Linux - Newbie 8 05-21-2010 03:59 AM
Intel 5100 wifi driver debian lenny 2handband Linux - Hardware 11 01-12-2010 11:08 PM
Ubuntu 9.04 can't connect to wifi with Intel Wireless WiFi Link 5100 Shinbatsu Linux - Networking 3 08-30-2009 01:55 AM
intel wifi link 5100 cannot work on linux pu1030 Linux - Networking 4 04-29-2009 11:25 AM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration