LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Fedora 11 install on Vista Dual Boot fails to load back Vista (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/fedora-11-install-on-vista-dual-boot-fails-to-load-back-vista-757249/)

abi0909 09-23-2009 09:28 AM

Fedora 11 install on Vista Dual Boot fails to load back Vista
 
Hey,
I was pretty confident when I did this. But at the end was perplexed and ended up googling and now into forums as my last resort. :(

I had Windows Vista installed on my Dell XPS 1330 laptop and installed Fedora 11 through USB-Net install method. Install went fine, grub loaded fine but then, when I chose Others to boot Windows I got -
NO BOOTMGR FOUND - PRESS CTRL+ALT+DEL TO REBOOT !

Googling for this suggested me to try the Windows Install CD to REPAIR MY WINDOWS INSTALL. But the problem was, when I chose the option to Reapair the OS, it listed no windows install.

But I am able to access my windows directories through Fedora. But not able to boot through window (obvious because I do not have the BOOTMGR).

Any help on this is appreciated. I can provide more inouts as and when asked.

Thanks,
Abi

Sader881 09-23-2009 09:39 AM

Which partition did you make primary? Windows is very jealous so if you try to make it a secondary partition, you can fry it.

abi0909 09-23-2009 09:46 AM

I am sure, I did not make Windows to become secondary. It was left to be primary and I installed Fedora on the freespace unallocated space I shrunk from the original drive which had windows installed on it.

mobinskariya 09-23-2009 09:49 AM

give us the output of(as root)
Code:

fdisk -l
and contents of /boot/grub/grub.conf

abi0909 09-23-2009 09:57 AM

Oops !! I do not have my laptop with me right now. :( If you could suggest me what needs to be checked, I can check for them once I go back home. :(

mobinskariya 09-23-2009 10:03 AM

in your menu.lst you can find an entry for windows..it should probably look like
Code:

title                Windows Vista (loader)
rootnoverify        (hd0,1)
savedefault
makeactive
chainloader        +1

the above piece of code means that my windows is located in /dev/sda2 and it will chainload the windows bootloader to start the windows.. so you should check the value X in (hd0,X)

edit:menu.lst means grub.conf

abi0909 09-23-2009 10:10 AM

Perfect, so from what I understand, I should first do a fdisk -l and find which partition has the windows partition.

Then put in the corresponding partition in the hd0,X where X replaces the partition number. Will try this tonight and let you know.

mobinskariya 09-23-2009 10:13 AM

if windows is installed in /dev/sdan (n an integer).. then you should use (hd0,n-1) not (hd0,n)..hope u got it..

abi0909 09-23-2009 10:16 AM

Now I got it, its even more clear .... :)

Thanks a lot dude .. will try and let you know ... If this works I will be saving 4 horus from reinstalling my laptop and another 2 hours for the crap to install updates and all :(

Fingers Crossed !!!

mobinskariya 09-23-2009 10:19 AM

good luck.. :)

abi0909 09-23-2009 10:27 AM

As a general question, before installing I had Ubuntu 9.04. I could use the Windows Boot Manager instead of GRUB to boot into Ubuntu. So even uninstalling it was not all a problem too.

But looks like, there is not option to stop GRUB from overwirting the Windows Boot Manager when I install Fedora. I mean, we need to have this flexibility to choose our boot loader betwrrn - GRUB and Windows Boot Manager.

Because, I was aware of this problem and was very cautious when I did the install but still ran into this problem. :(

yancek 09-23-2009 11:00 AM

Quote:

But looks like, there is not option to stop GRUB from overwirting the Windows Boot Manager when I install Fedora.
I would be very surprised if that is the case. I haven't installed Fedora for several years so this may be true? Usually, when installing a Linux distribution the bootloader is the last thing installed and if you are using a GUI to install, there should be an Advanced tab that allows you to choose where to install Grub.

Windows does not give you this option.

abi0909 09-23-2009 11:20 AM

There is an option to choose the partition to load the GRUB, and I did choose the partition whre I had installed Fedora, KEEPING IN MIND I SHOULD NOT REMOVE WINDOWS BOOT MANAGER... But boom, I got shot.

Infact I tRied my install twice, first time, I said DO NOT INSTALL ANY BOOT LOADER, because I guessed then windows Boot Manager would have the Control. Then I ended up not being to reboot either Vista or Fedora .....

From what it looks like, once you install Fedora 11 (atleast), your WINDOWS BOOT MANAGER IS WIPPED OFF !!! :(

btncix 09-23-2009 11:42 AM

Quote:

But looks like, there is not option to stop GRUB from overwirting the Windows Boot Manager when I install Fedora. I mean, we need to have this flexibility to choose our boot loader betwrrn - GRUB and Windows Boot Manager.
You are given that option.


Fedora (and several other distributions) tell you where grub will be placed. By default, the Fedora installer selects grub to be placed in the MBR of your first hard drive. You can instead change it to be the MBR of another hard drive or the first few blocks of a partition.



edit:
I guess I had this thread opened too long. Your post didn't appear until after I sent mine. My bad.

abi0909 09-23-2009 12:09 PM

What ever, I could not see the option to load the GRUB in a place apart from the Windows Boot Manager. Or better said, GRUB Overwrote WBM even though I chose to install GRUB on the first segment of the partition where I installed Fedora.

When I could do this with Ubuntu, I even tried in Fedora. But did not work.


All times are GMT -5. The time now is 02:14 AM.