LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-30-2005, 12:38 PM   #1
VincentB
Member
 
Registered: Jun 2003
Location: Brussels, Belgium
Distribution: Ubuntu 6.10
Posts: 139

Rep: Reputation: 15
FC3 modem on Dell 510m


All,

I am trying to use the modem installed on my DELL 510m laptop running Fedora Core 3.0. When I run lspci -v , I got the following result ...

Code:
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01) (prog-if 00 [Generic])
        Subsystem: Broadcom Corporation: Unknown device 4d64
        Flags: bus master, medium devsel, latency 0, IRQ 5
        I/O ports at d400 [size=256]
        I/O ports at d080 [size=128]
        Capabilities: [50] Power Management version 2
The problem is that when I try to create a PPPo connection to use my modem, it seems it is not able to detect this modem (that I can easily use with XP).
Is there a specific driver I have to download (when I read Broadcom somewhere, this automatically pops up to my mind) and where / which driver do I have to install?

Thanks in advance for your help,

Vincent
 
Old 04-03-2005, 01:14 AM   #2
t3gah
Member
 
Registered: Dec 2004
Distribution: SuSE, RedHat, ubuntu, Debian
Posts: 734

Rep: Reputation: 30
Re: FC3 modem on Dell 510m

Quote:
Originally posted by VincentB
All,

I am trying to use the modem installed on my DELL 510m laptop running Fedora Core 3.0. When I run lspci -v , I got the following result ...

Code:
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01) (prog-if 00 [Generic])
        Subsystem: Broadcom Corporation: Unknown device 4d64
        Flags: bus master, medium devsel, latency 0, IRQ 5
        I/O ports at d400 [size=256]
        I/O ports at d080 [size=128]
        Capabilities: [50] Power Management version 2
The problem is that when I try to create a PPPo connection to use my modem, it seems it is not able to detect this modem (that I can easily use with XP).
Is there a specific driver I have to download (when I read Broadcom somewhere, this automatically pops up to my mind) and where / which driver do I have to install?

Thanks in advance for your help,

Vincent
I found this HOWTO on a page outside of LQ.org and I won't transpose because it's copyrighted: http://www.kcore.org/?menumain=4&menusub=1

They go on to state that your modem is a Lucent WinModem which is what I have and I've had no problems getting it to work with all sorts of Linux distro's and FreeBSD.

Your driver is a slmodem driver according to that howto. http://www.smlink.com/main/down/slmodem-2.9.10.tar.gz

If the howto at the link doesn't do it you can try the Intel site for the driver or http://www.linmodems.org/ or http://www.agere.com/ or http://www.smlink.com/

Did you try Dell.com's Forum's or their Support Site for the Linux driver? (Enter your service tag for your support page)

There is also http://downloadfinder.intel.com/scri...port_Intel.asp

Last edited by t3gah; 04-03-2005 at 01:19 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dell inspiron 510m vs fc3 yenonn Linux - Laptop and Netbook 1 05-16-2005 01:09 AM
Configuring X on my dell inspiron 510m nickleus Linux - Laptop and Netbook 6 02-10-2005 04:02 AM
Ndiswrapper on Dell 510m VincentB Linux - Wireless Networking 7 01-09-2005 05:53 AM
Dell 510M 2.6 kernels won't boot dezza Linux - Laptop and Netbook 1 11-14-2004 10:04 AM
1400 * 1050 on DELL 510m VincentB Linux - Hardware 1 07-25-2004 12:55 PM


All times are GMT -5. The time now is 12:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration