LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 08-14-2010, 05:46 PM   #1
Doruletz
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
Enable wireless in linux mint 9 isadora for e-machines m5312 laptop


e-Machines M5312 Laptop
Mobile AMD Athlon™ XP-M 2400+ Processor
Operates at 1.8 GHz - 266 MHz Front Side Bus - Level 2 cache 512K
1GB (1024MB) RAM DDR PC2100 SO-DIMM (2 sticks x 512MB) with 64 MB used for onboard video/display
ATI® RADEON IGP 320M - 64 MB DDR shared video memory
PC2001 Compliant AC '97 Audio Built-in Stereo Speakers
HTS541080G9AT00 Hitachi 80GB HDD
10/100Mbps Ethernet
802.11g 54Mbps Wireless

I installed Linux Mint 9 Isadora on my e-Machines M5312 Laptop and I cannot activate the wireless. I have to use a wired LAN (via an Ethernet cable) to have internet access.
In Windows XP I was able to use the hotkeys combination (Fn+F2) to turn the wireless (Radio) On and Off - it was the only way to do that.
Please help me with step by step instructions on how to do this in mint 9 or for that matter in any linux distro.

Thanks.
 
Old 08-14-2010, 05:59 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
This procedure varies a little bit depending on what wireless device you have, and by distro. Most importantly first, we need to know exactly what wireless device you have in your machine. My roommate just recently installed Mint-9 on her Acer e-Machine also, and when it started up, it told her that "there are 3rd party drivers available for this machine" and she had to choose the Broadcom STA driver for her wireless. Upon choosing to install that driver (which was included on the Mint disc) the wireless started working on its own - I was impressed, it was very easy.

So anyhow, about your wireless device; please show us the output from the following command:
Code:
lspci -vnn
That will produce a long list of paragraphs, one paragraph for each PCI device in your machine. Your wireless should look slightly like below:
Code:
05:06.0 Ethernet controller [0200]: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 [1317:0985] (rev 11)
        Subsystem: Motorola Device [1057:7310]
        Flags: bus master, medium devsel, latency 64, IRQ 19
        I/O ports at e800 [size=256]
        Memory at febffc00 (32-bit, non-prefetchable) [size=1K]
        Expansion ROM at febc0000 [disabled] [size=128K]
        Capabilities: [c0] Power Management version 2
        Kernel driver in use: tulip
        Kernel modules: tulip
..except it will say something about 802.11 wireless or whatever. The example above is from my wired ethernet card.

Once we know what the device is, someone will be able to advise how to go about getting the driver for it, and installing it. You have one very good benefit right now - working wired ethernet, in case you have to download something. With any luck, your device will not be some really weird, rare crazy wireless.
 
Old 08-15-2010, 12:53 AM   #3
Doruletz
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Enable wireless in linux mint 9 isadora for e-machines m5312 laptop

e-Machines M5312 Laptop
Mobile AMD Athlon™ XP-M 2400+ Processor
Operates at 1.8 GHz - 266 MHz Front Side Bus - Level 2 cache 512K
1GB (1024MB) RAM DDR PC2100 SO-DIMM (2 sticks x 512MB) with 64 MB used for onboard video/display
ATI® RADEON IGP 320M - 64 MB DDR shared video memory
PC2001 Compliant AC '97 Audio Built-in Stereo Speakers
HTS541080G9AT00 Hitachi 80GB HDD
10/100Mbps Ethernet
Askey WLL3010 - 802.11g 54Mbps Wireless

I took the cover off and the wireless LAN is an Askey WLL3010
 
Old 08-15-2010, 01:02 AM   #4
Doruletz
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
GrapefruiTgirl, I don't think you completely undestood my problem.
The driver for wireless was installed by Linux, it's just that the laptop was built with an on/off feature for the Wireless that was controlled in Windows XP by the Fn+F2 hotkey, the only way to activate/deactivate wireless. While
other laptops have an actual switch that turns wireless on and off or it is always on, this emachines model only does it by pressing hotkey Fn+F2. The hardware is properly installed in Linux, with the proper driver, it's just the fact that it is turned off by default and the hotkey will not turn it on in Linux. Is there a way to make the Fn+F2 hotkey work in Linux or find another way to turn the wireless card on???
 
Old 08-15-2010, 07:52 AM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
You're correct - I did not fully understand the problem. My apology.

I seem to remember seeing here and there (on LQ) a number whack of threads about this Fn+F2 hotkey, but at the moment I do not know if one or more of those threads have the solution to the key-combination issue.

For the record though, for future reference: Askey WLL3010 - 802.11g 54Mbps Wireless is not useful; that's just a name on the outside of the device. From googling a moment, I believe that this is actually a Broadcom wireless chip. It's the chipset manufacturer who made the insides of the Askey thing which is important, not the name printed on the outside of it. So if anyone needs to know in the future, please provide them with the `lspci -vnn` output suggested earlier.

If I come across a thread where the Fn-F2 key-code is working, I'll post a link. Hopefully someone else may have a solution though!

Best of luck,
Sasha
 
Old 08-15-2010, 08:11 AM   #6
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
P.S. - you may like to read this thread (it's one of many returned from a search from LQ's search page):

http://www.linuxquestions.org/questi...sabled-824281/

It gives a method to turn the wireless on/off, although not by using the Fn keycode.
 
Old 08-16-2010, 04:12 AM   #7
Doruletz
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
GrapefruiTgirl thanks for your prompt input, I looked at the post you pasted here, seems like it could work...
Did not have a chance to actually try it yet, as my laptop is wipped off completely (I'm in the middle of a clean wipe and reinstall), but I will try it and let you know as soon as I can get it up and running again.
Thanks.
 
Old 08-20-2010, 11:08 PM   #8
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 55
From that thread:

Code:
sudo -s
echo -ne "sudo iwconfig wlan0 txpower on" >> /etc/rc.local
Now, all you have to do is reboot and you'll be able to use the wireless whenever you want!

Last edited by Kenny_Strawn; 08-20-2010 at 11:10 PM.
 
Old 09-11-2010, 02:48 AM   #9
Doruletz
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Thumbs up ****** problem solved ******

****** PROBLEM SOLVED ******

It was all a matter of BIOS settings.

Besides the Windows XP hotkeys combination (Fn+F2) to turn the wireless (Radio) On and Off which I mentioned earlier there is also a BIOS setting that will turn the wireless On, Off or Auto --> hotkeys combination (Fn+F2).

I just had to set the BIOS to wireless On and it works fine now.

Hope this last post will help others facing the same problem. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Perfect Desktop - Linux Mint 9 (Isadora) LXer Syndicated Linux News 4 03-16-2011 06:33 AM
Enable wireless in linux mint 9 isadora for e-machines m5312 laptop Doruletz Linux - Newbie 1 08-15-2010 01:42 PM
Enable wireless in linux mint 9 isadora for e-machines m5312 laptop Doruletz Linux Mint 1 08-14-2010 06:16 PM
Linux Mint 9 Isadora X Window crash how to debug? michielv Linux Mint 0 08-04-2010 03:38 PM
LXer: Linux Mint 9 (Isadora) Review LXer Syndicated Linux News 0 05-20-2010 01:00 AM


All times are GMT -5. The time now is 06:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration