LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 02-17-2009, 07:05 AM   #1
pmate
LQ Newbie
 
Registered: Feb 2009
Distribution: Gnu/Linux Debian
Posts: 4

Rep: Reputation: 0
eeepc + rtcwake = alarm clock


Hi all,
i wish to turn my eeepc 701 (Gnu/Linux Debian Lenny) into an alarm clock.
So i thought that this worked:
Code:
# rtcwake -s 20 && pm-suspend
but nothing happened...

So i tried whith wakealarm too but got the same result:
eeepc goes on suspend-mode (obviously) but doesn't wake up. It needs that (manually) the power button is pressed to wake up from suspension.

Anyone got some experience on it?

Thanks

Last edited by pmate; 02-17-2009 at 08:43 AM.
 
Old 02-18-2009, 03:10 AM   #2
ebmi
LQ Newbie
 
Registered: Oct 2006
Posts: 18

Rep: Reputation: 0
I'm running Debian 5.0, and I was able to put my laptop (dell xps m1330) to sleep for thirty seconds with

Code:
# rtcwake -m mem -s 30
The rtcwake command issues the sleep instruction itself. There is no need to run pm-suspend.

That's a pretty cool command. Thanks for showing it to me.
 
Old 02-18-2009, 04:59 AM   #3
pmate
LQ Newbie
 
Registered: Feb 2009
Distribution: Gnu/Linux Debian
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for your answer,
you're totally right: there's non need to run pm-suspend.
But the problem remains: it goes in suspension and resume not after x seconds but only if i press power button. This happens only in X, in console instead, it doesn't wake up at all. I have to power off...

p.s. happy to have been useful... ;-)
 
Old 02-18-2009, 07:06 PM   #4
ebmi
LQ Newbie
 
Registered: Oct 2006
Posts: 18

Rep: Reputation: 0
That's a stinker. What kernel are you running? Is it hand rolled or did you apt-get it?
 
Old 02-19-2009, 03:30 AM   #5
pmate
LQ Newbie
 
Registered: Feb 2009
Distribution: Gnu/Linux Debian
Posts: 4

Original Poster
Rep: Reputation: 0
no it isn't hand rolled, it is the default kernel of debian for eeepc.
Can it be that the problem is in some of the eeepc-acpi-scripts?
Or it can depend on bios?
 
Old 02-19-2009, 03:49 AM   #6
ebmi
LQ Newbie
 
Registered: Oct 2006
Posts: 18

Rep: Reputation: 0
Well, to answer your questions, yes and yes. It sounds like your linux isn't listening to acpi events. That could be a scripts or a bios issue. I don't have any experience with an eeepc so I don't think I can offer anything more. Good luck!
 
Old 02-19-2009, 05:08 PM   #7
geesh
Member
 
Registered: Feb 2004
Posts: 47

Rep: Reputation: 15
I just tried this on an HP DV5020us laptop and it looks like it is a bios limitation. Same here, no wake up.
Tried it on a couple desktops that have a wake time settable in the bios and it works great from a terminal. Looks like it has to be settable in the bios (but you don't need to set it like that) to be function-able.
 
Old 02-19-2009, 05:15 PM   #8
geesh
Member
 
Registered: Feb 2004
Posts: 47

Rep: Reputation: 15
ok got it working try using the -u option for utc time and not local time , works on every thing i've tried around here so far!

rtcwake -d rtc0 -m mem -s 60 -u -v

Last edited by geesh; 02-19-2009 at 05:16 PM.
 
Old 02-21-2009, 07:31 PM   #9
pmate
LQ Newbie
 
Registered: Feb 2009
Distribution: Gnu/Linux Debian
Posts: 4

Original Poster
Rep: Reputation: 0
no way, even with geesh's suggestions.
At this point i think it's a matter of acpi-scripts.
I will check in these days.
Thanks a lot
 
  


Reply

Tags
debian, eeepc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i need an alarm clock for 2007 bennythepitbull Mandriva 5 06-01-2007 12:39 PM
Simple Alarm Clock dudeman41465 Linux - Software 11 10-07-2006 12:33 AM
Exit status - Alarm clock?!?!?! edhellaby Mandriva 0 10-29-2005 12:40 PM
linux alarm clock? DJOtaku Linux - General 1 02-16-2005 02:41 AM
Linux Alarm Clock?? Scruff Linux - General 3 09-02-2003 10:41 PM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration