LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 12-10-2011, 07:51 PM   #1
Economicus
LQ Newbie
 
Registered: Dec 2011
Posts: 4

Rep: Reputation: Disabled
EDID Checksum error on boot


Hi everyone,

I have just installed Arch Linux and the following error appears during boot:

Code:
Waiting for UDev uevents to be processed                 [BUSY]
[5.957386] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 171
[5.957461] Raw EDID:
[5.957513] 4d d6 fa 06 01 88 ff ff 00 00 00 00 00 00 00 00
(similar lines with alphanumeric values are repeated 7 times)
[5.958339] [drm:radeon_atombios_get_lvds_info] *ERROR* Bad LCD record 217
A quick forum search showed a few similar cases in the past with no real solutions. Does anyone have any idea how this could be resolved (it does not cause any immediate issue as far as I can tell), or at least how I can hide this error from showing each boot?

Thank you in advance.
 
Old 12-11-2011, 05:16 AM   #2
free-user
LQ Newbie
 
Registered: Dec 2011
Posts: 10

Rep: Reputation: Disabled
Hi, I had this issue. It seems its a problem with the Screen, the driver does not read properly the EDID and shows that error. I dumped the EDID into a file and then edited xorg.conf and added to the videocard section:

"CustomEDID" "LVDS:/etc/X11/edid.bin" but it doesn't work. If anyone know how to provide properly the edid would be great.

Anyways I managed to "hide" that error message by adding to the kernel options nomodeset.
 
Old 12-11-2011, 06:45 AM   #3
Economicus
LQ Newbie
 
Registered: Dec 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you for the quick response. Adding nomodeset to the kernel options in grub menu did hide the error. However, the text during boot and in tty1 after is very large. Normally, the text is quite large (about 3x normal size) during the first 7-8 seconds of boot before the screen goes black for 1/2 second and it returns normally. This now does not happen. Any ideas how I can fix this or fix the original error without nomodeset?

Last edited by Economicus; 12-11-2011 at 07:21 AM.
 
Old 12-11-2011, 06:55 AM   #4
free-user
LQ Newbie
 
Registered: Dec 2011
Posts: 10

Rep: Reputation: Disabled
Yes, the nomodeset options tells the kernel to not load the video driver until X are launched so you get a ugly boot.
The key here is to find out how to provide a EDID manually as I tried before, let see if someone knows how to do it.
 
Old 12-11-2011, 08:27 AM   #5
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,252

Rep: Reputation: 252Reputation: 252Reputation: 252
My monitor causes a similar EDID error, in my case:
Code:
Dec 11 05:38:25 Pyrope kernel: [   31.051645] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 74
Dec 11 05:38:25 Pyrope kernel: [   31.051647] Raw EDID:
Dec 11 05:38:25 Pyrope kernel: [   31.051648]  	c0 16 10 1e 01 18 02 14 00 4f 04 20 07 10 14 00
Dec 11 05:38:25 Pyrope kernel: [   31.051650]  	4f 11 01 03 08 2f 1e 78 0a b5 34 a5 56 4a 9a 25
Dec 11 05:38:25 Pyrope kernel: [   31.051652]  	10 50 54 af cf 00 81 80 81 8f 95 00 95 0f 01 01
Dec 11 05:38:25 Pyrope kernel: [   31.051654]  	01 01 01 01 01 01 1c 39 90 30 62 1a 27 40 68 b0
Dec 11 05:38:25 Pyrope kernel: [   31.051656]  	36 00 d9 28 11 00 00 18 00 00 00 fe 00 0a 20 20
Dec 11 05:38:25 Pyrope kernel: [   31.051657]  	20 20 20 20 20 20 20 20 20 20 00 00 00 fc 00 4d
Dec 11 05:38:25 Pyrope kernel: [   31.051659]  	42 57 2d 53 45 52 49 41 4c 0a 20 20 00 00 00 ff
Dec 11 05:38:25 Pyrope kernel: [   31.051661]  	00 0a 20 20 20 20 20 20 20 20 20 20 20 20 00 33
In order to use my monitor's native 1690x1050 resolution, I created a custom /etc/X11/xorg.conf file with the appropriate modeline. However, I still see the error upon booting.
 
Old 12-11-2011, 11:01 AM   #6
free-user
LQ Newbie
 
Registered: Dec 2011
Posts: 10

Rep: Reputation: Disabled
Doing some research it seems that nobody knows how to use a custom EDID with the FGLRX driver (Maybe you even can't). The Custom EDID option it only works with the free drivers and with the nvidia drivers.

I haven't tried with the free drivers if it works though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network boot returns "UDP Checksum Error" iainr Linux - Networking 1 08-06-2009 02:58 PM
error in checksum tannu_ah Linux - Newbie 1 05-02-2009 11:37 AM
Checksum Error- Help! unixchick Linux - Newbie 1 05-08-2006 12:32 PM
checksum error when trying to boot red hat version 9 burned installation iso cd dorn Linux - Laptop and Netbook 3 10-27-2003 12:29 PM


All times are GMT -5. The time now is 09:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration