LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-31-2009, 09:24 PM   #1
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Rep: Reputation: 0
Each time my laptop is put to sleep, the keyboard doesn't work upon awake.


Each time my laptop is put to sleep, the keyboard doesn't work upon awake.
I run Ubuntu 9.10 on a Sony Vaio VGN-CSJ390.

Thanks for your help!

Nik
 
Old 01-02-2010, 07:41 AM   #2
Carsto
Member
 
Registered: Aug 2009
Posts: 97

Rep: Reputation: 17
Known problem with the Aspire as well.

Do some searching and on Linuxforums as well. Look under my posts of about a month ago. I have now re-installed Fedora Core 11 and still have to do three taps on the Kb to get it to wake up properly. It's like your cell phone. There are other posts as well - with other solutions. For the moment I am living with it.

Keep looking. Good Luck!!
 
Old 01-03-2010, 06:46 PM   #3
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Rep: Reputation: 18
Nic

Are you using hibernate or suspend?
Hibernate doesnt always work correctly in Ubuntu.
I had to switch mine to suspend.
You should try that as let us know what happens.
Its under system/perferences/powermanagement

Vanessa
 
Old 01-06-2010, 07:40 PM   #4
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Well, the funny thing is, the keyboard is completly dead after hibernating or suspending. It's not a few keys to press or something, it's simply dead. I use the DVORAK simplified keyboard (instead of QWERTY) if that is any help. Please note that this is a laptop.

Thanks in advance, Nick.
 
Old 01-08-2010, 07:15 PM   #5
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Rep: Reputation: 18
Nick

Have you tried to re-map your keyboard to qwerty and re-test it.
It may be a Dvorak issue.

Vanessa
 
Old 06-14-2010, 05:56 PM   #6
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Unhappy

Yeah, it's not only a Dvorak issue, I've tested it. I'm running Ubuntu 10.04 now, and the problem persists. The problem also exists under Debian 5.04.

Thanks again, and sorry for the 6-month delay...

~Nick
 
Old 12-03-2010, 09:59 PM   #7
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Another 6 months has gone by and the problem persists. The same computer is running on Ubuntu 10.10. Ubuntu was never fresh installed, and I still have some inactive Karmic repositories, but as mentioned above, Debian had the same problem.

Any suggestions?
 
Old 07-31-2011, 08:10 AM   #8
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
I know this is the third time I bump, but it's been like a year and a half...
I'm running debian again now, the problem still persists.
Thanks.
 
Old 09-12-2012, 07:22 PM   #9
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Talking If a solution exists...

Bump.
As of now, I'm running Ubuntu 12.04 with the MATE (GNOME 2) Graphical User Environment.
The problem is so persistent, it has to be some deeply hardware related problem.
 
Old 06-30-2013, 09:49 AM   #10
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Question

Bump.
Come on guys Any solution?
Also, each time I have a USB mouse plugged in, the right button stops working after about 20 minutes.
 
Old 08-18-2013, 02:44 PM   #11
Nicolas.Perrault
LQ Newbie
 
Registered: Dec 2009
Location: Montreal, Canada
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
Angry

I'm the loneliest person on the boards!
Bumping is becoming my game.
Also, may I receive a reply?
 
Old 09-13-2013, 12:19 AM   #12
Resistor1
LQ Newbie
 
Registered: Aug 2013
Posts: 13

Rep: Reputation: Disabled
Quote:
Originally Posted by Nicolas.Perrault View Post
I'm the loneliest person on the boards!
Bumping is becoming my game.
Also, may I receive a reply?
You are not alone. I'm running Linux Mint 15 on a new Dell 15z. First, I wiped Win8 while trying to install LM15, which never saw Win8, due to uEFI. Then, I proceeded to wipe the GPT/MBR a couple of times.

Now, I'm running LM15 from one of 3 USB devices, configuring the browser and a few other settings, on each boot.

I generally suspend at the end of the session, but can do this only one time, due to the ramdrive, I suspect.

The dead keyboard is an intermittent thing and it is a battle to get things configured and running, before it dies. I don't know if restarting Cinnimon makes a difference, after I flip the panel from bottom to top.

It seems to makes a difference, but I'm a trucker and not sure about anythng I'm doing with a computer, these days.
 
Old 09-13-2013, 07:05 AM   #13
911InsideJob
Member
 
Registered: Jul 2013
Distribution: Mint KDE
Posts: 74

Rep: Reputation: Disabled
I have an HP that does this occassionally. Pretty sure it's a driver issue with the quick access buttons but once the hardware locks it'll keep locking up unless I unplug, remove the battery and press power button (to discharge capacitors.) Then it starts sleeping and waking up normally again.
 
Old 09-29-2013, 05:48 PM   #14
Resistor1
LQ Newbie
 
Registered: Aug 2013
Posts: 13

Rep: Reputation: Disabled
Reaching back to, I think, Linux Mint 9... There was a setting - maybe in Compiz or Meta City - to prevent other windows from stealing focus.

When I lose control of the cursor, I still have access to the arrow keys and can navigate to some extent, with the tab and shift-tab keys. The Enter key works, the Super L (Windows) key works and will bring up the menu. Escape works, as does some of the Function keys.

Sometimes, Control-Alt-Backspace will log out and present the log in screen. Control-Alt-Delete does not work, though.

I'm waiting for the next version of Mint, with great hope...

I'm hoping that the next version will overcome the jumpy cursor, as well. I now wear Jersey gloves with the fingers cut off, to provide some cursor stability, when typing. Nothing else seems to make a difference.
.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to awake my laptop ? mq15 Linux - Laptop and Netbook 3 04-27-2009 01:35 AM
LXer: Put your laptop to sleep LXer Syndicated Linux News 0 08-02-2006 01:24 AM
How I put tv-out work? (Laptop with S3 Twister) aapo Linux - Hardware 1 03-02-2005 03:05 PM
awake jobs at specified time merlin23 Linux - Newbie 5 12-02-2004 12:34 PM
longest time awake without sleeping? nixel General 25 05-09-2004 01:42 PM


All times are GMT -5. The time now is 11:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration