LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Dual Head Monitor (Dell Latitude E5420) (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/dual-head-monitor-dell-latitude-e5420-4175448513/)

neuro11 02-03-2013 08:48 PM

Dual Head Monitor (Dell Latitude E5420)
 
Hi,
i am using Centos 5.9 on my laptop and have connected an extra monitor(eizo Flexscan L568) through VGA port. Centos does not auto detect the monitor.I tried System-> Admin-> Display and clicked on Dual Head. It says as follows:
Second Monitor : No monitor selected
Second Video Card : Intel Corp. 2nd gen......integrated graphics controller
Desktop Layout : individual

I clicked on Configure button and there i have selected LCD Monitor and i have also found the same brand available there and have selected it and changed Desktop Layout to spanning type. it asked me to restart however when i restart it showed problem during boot that there were errors in X server configuration or so..... So from command prompt i had to uncheck dual head to be able to log on again in previous single display mode. Here is what i can find inside Xor.conf file now:

Quote:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "S170 (autoconfigured)"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 24.0 - 80.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
In the /etc a xorg.conf.backup also was created which is like this :

Quote:

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "S170 (autoconfigured)"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 24.0 - 80.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "vesa"
VendorName "Videocard Vendor"
BoardName "Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller"
BusID "PCI:0:2:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection
please advice me thank you.


All times are GMT -5. The time now is 06:38 AM.