LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 04-19-2006, 01:02 PM   #1
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Rep: Reputation: 15
Exclamation Disabling Touchpad Clicking


I am running Ubuntu Breezy Badger on a Dell Inspiron 6000 notebook. Everything is working great and I have the synaptics driver installed, but I cannot figure out how to disable or turn down the sensitivity on clicking by tapping the touchpad. Whenever I am moving the mouse with the touchpad it is constantly picking up clicks and clicking when I don't want it to be. I also do not see the MaxTapTime option in xorg.conf, which sounds like what I need. Any suggestions?
 
Old 04-19-2006, 02:11 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
looks like the
Code:
 Option "TouchpadOff" "2"
in your xorg.conf will sort you out. check the "synaptics" manpage for the full list of options i'm currently looking at.
 
Old 04-19-2006, 02:15 PM   #3
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
Do I need to add that to my xorg.conf? I don't see it in my xorg.conf, currently.

edit: I just added that under the synaptics driver in my xorg and restarted x with no luck.

Last edited by eman45008; 04-19-2006 at 02:21 PM.
 
Old 04-19-2006, 03:38 PM   #4
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
At this point, I can't figure anything out, so I don't even care if the tap-clicking is disabled...I just want this to stop. Any other suggestions?
 
Old 04-19-2006, 04:04 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
there are no other suggestions... as i suggested edit your xorg.conf and add the line i gave you.
 
Old 04-19-2006, 04:11 PM   #6
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
I did, and as I said, it's still not working. Here's a copy of my xorg.conf:

Quote:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "TouchpadOff" "2"
EndSection

Section "Device"
Identifier "Intel Corporation Intel Default Card"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Intel Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 04-19-2006, 04:29 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
well then also as above, check the synaptics manpage of other favourable looking options. and of course restart X after editing.
 
Old 04-19-2006, 04:46 PM   #8
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
I've tried just about everything and restarted X and still no luck.
 
Old 04-19-2006, 07:27 PM   #9
ktaylo58
LQ Newbie
 
Registered: Nov 2002
Location: Detroit, MI USA
Distribution: SuSE 8.2
Posts: 27

Rep: Reputation: 15
Add these 2 options to your InputDevice, Synaptics section:

Option "MaxTapTime" "0"
Option "SHMConfig" "on"

You might not need the SHMConfig option but try it with it first.
 
Old 04-19-2006, 08:39 PM   #10
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
Still can't get it to work. Here's my xorg.conf and I used the Ctrl+Alt+Backspace combination to restart X.

Quote:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "MaxTapTime" "0"
Option "SHMConfig" "on"
EndSection

Section "Device"
Identifier "Intel Corporation Intel Default Card"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Intel Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 04-20-2006, 08:17 PM   #11
ktaylo58
LQ Newbie
 
Registered: Nov 2002
Location: Detroit, MI USA
Distribution: SuSE 8.2
Posts: 27

Rep: Reputation: 15
You could comment out the Synaptics Touchpad in the Server Layout section.

This is what I did back when I was running Breezy, and I had to put psmouse.proto=imps on the boot line to get the tap back because I prefer it.
 
Old 04-20-2006, 08:27 PM   #12
ktaylo58
LQ Newbie
 
Registered: Nov 2002
Location: Detroit, MI USA
Distribution: SuSE 8.2
Posts: 27

Rep: Reputation: 15
Play with the synclient command as is suggested on this page:

http://voidmain.is-a-geek.net/redhat..._touchpad.html

synclient -l
lists your settings.

synclient maxTapTime=0
turns it right off for me (which I immediately switch back on because I hate it).
 
Old 04-21-2006, 12:58 AM   #13
eman45008
LQ Newbie
 
Registered: Apr 2006
Posts: 26

Original Poster
Rep: Reputation: 15
In the synclient is shows my MaxTapTime=0, yet tapping on the touchpad still causes it to click. Not sure why it doesn't fix it. -Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling Toshiba M70's touchpad riksweeney Linux - Laptop and Netbook 1 02-23-2006 12:40 PM
disabling synaptics touchpad on hp ze4500 ouzo Suse/Novell 0 03-12-2005 03:02 PM
disabling synaptics touchpad? dkw Linux - Laptop and Netbook 0 08-04-2004 06:27 PM
Disabling Trackpad Clicking in Fedora conjk Linux - Laptop and Netbook 2 07-20-2004 06:45 AM
Disabling the touchpad? zzZoiDzz Linux - Hardware 21 01-30-2004 09:17 PM


All times are GMT -5. The time now is 11:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration