LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 09-16-2006, 08:05 PM   #1
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Rep: Reputation: 15
Disabling tapping on touch pad - Presario


I'm running Kubuntu 6.06 on a Presario 720US. By default, tapping (left-click) is enabled for the touch pad, but there is no way to turn it off out of the box. I installed the ksynaptics GUI and I unchecked the "enable tapping" box in the System Settings subsection labeled "Touch Pad" (which appeared after I installed ksynaptics). However, tapping has not been disabled. Changing things with ksynaptics doesn't seem to do anything. I've even rebooted just to see that would help. No dice.

Using Adept, I can see that I have xserver-xorg-input-synaptics installed (the description says "Synaptics TouchPad driver for X.org Server"). I'm assuming this is the driver that I need.

Anyone have any ideas?
 
Old 09-18-2006, 05:27 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
Never done this but using the command syndaemon may work for you. Don't know much about it but read the man page on it with the command ' man syndaemon '. You need to add the line
Code:
	Option	"SHMConfig"	"on"
to/etc/X11/xorg.conf file to the input device section on the touchpad.

Brian1
 
Old 09-19-2006, 11:57 AM   #3
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks, Brian! I'll look into that and report back.
 
Old 09-19-2006, 07:59 PM   #4
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Original Poster
Rep: Reputation: 15
No dice yet, but I think I'm getting somewhere. I found this page:
http://web.telia.com/~u89404340/touchpad/

and I saw this:
Quote:
How can I configure tap-to-click behavior?

1. If you set MaxTapTime=0 in the X config file then the touchpad will not use tapping at all, i.e. touching/tapping will not be taken as a mouse click.
The problem is that my xorg.cong file does not have the MaxTapTime variable. In fact, it doesn't have any of the synaptics variables listed in the InputDevice section. Here's what I have in my xorg.conf file for input devices:
Quote:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
Option "SHMConfig" "on"
EndSection
And then there are three input device entries for Wacom devices, but I don't think those are relevant.

I also found this site:
http://gentoo-wiki.com/HARDWARE_Syna...Edit_xorg.conf

And apparently the xorg.conf input device section for a synaptics touch pad should look something like this:
Quote:
Section "InputDevice"
Driver "synaptics"
Identifier "TouchPad"
Option "Device" "/dev/input/mouse0"
Option "Protocol" "event"
Option "LeftEdge" "130"
Option "RightEdge" "840"
Option "TopEdge" "130"
Option "BottomEdge" "640"
Option "FingerLow" "7"
Option "FingerHigh" "8"
Option "MaxTapTime" "180"
Option "MaxTapMove" "110"
Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.60"
Option "MaxSpeed" "1.10"
Option "AccelFactor" "0.030"
Option "EdgeMotionMinSpeed" "200"
Option "EdgeMotionMaxSpeed" "200"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "SHMConfig" "on"
Option "Emulate3Buttons" "on"
EndSection
According to Adept, I have the Synaptics Xorg driver installed, but I don't think xorg.conf is setup right to take advantage of the driver. Can somebody help me out with how I can verify if the driver is indeed loading.

Also, when I try to run dyndaemon or synclient, I get the following error:
Quote:
Can't access shared memory area. SHMConfig disabled?
Anyone have any ideas?
 
Old 09-20-2006, 03:51 PM   #5
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
Do you not have a section for the touchpad device?
You show one for the mouse.
You should have one that is using synaptic as a driver. Does that exist.
The option for SHMConfig would not work with the mouse driver. It only works with the synaptic driver.
As far as the long list on settings depends on maybe the requirements of the touchpad. Not all touchpads are the same and may require custom specs to function.

I will show you xorg.conf which has to devices mouse and touchpad. I have one for a NEW synaptic driver like the one you show but does not work for me. I beleive it is because I compile evdev as a module. I just use the Mouse0 and Synaptic ones. You can review the top of it for Server Layout and see how both are presented to the X server.
Code:
Contents of /etc/X11/xorg.conf

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
#	Load  "synaptics"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
	Identifier "New2-Synaptics"
	Driver  	"synaptics"
	Option 	"Device"  	"/dev/input/mice"
	Option	"Protocol"	"auto-dev"
	Option	"LeftEdge"      "1700"
	Option	"RightEdge"     "5300"
	Option	"TopEdge"       "1700"
	Option	"BottomEdge"    "4200"
	Option	"FingerLow"	"25"
	Option	"FingerHigh"	"30"
	Option	"MaxTapTime"	"180"
	Option	"MaxTapMove"	"220"
	Option	"VertScrollDelta" "100"
	Option	"MinSpeed"	"0.09"
	Option	"MaxSpeed"	"0.18"
	Option	"AccelFactor"	"0.0015"
	Option	"SHMConfig"	"on"
# 	Option	"Repeater"	"/dev/ps2mouse"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1280x1024"
	HorizSync    31.5 - 67.0
	VertRefresh  50.0 - 75.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "Videocard vendor"
	BoardName   "ATI Radeon Mobility M9"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
 
Old 09-21-2006, 02:52 PM   #6
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Brian1
Do you not have a section for the touchpad device?
Nope. Just one entry for the keyboard, one for "mouse" and then about 4 or 5 for some kind of wacom devices.

I don't suppose it would be as easy as adding a new input device entry with the relevant synaptics info, would it?

Last edited by culturejam; 09-21-2006 at 02:54 PM.
 
Old 09-21-2006, 04:31 PM   #7
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
Appartenly it is using wacom which is used on some touchpads and mostly tablets. Check this link on wacom info. http://linuxwacom.sourceforge.net/

The touchpad may not be a synaptic type my guess. Never run into this so it is new to me. If I think of some I will post.

You might try this to test if wacom is needed. Make a copy of the xorg.conf first and then edit the xorg.conf and rem out the wacom stuff and then restart the X server or reboot and see if touchpad still functions.

Post contents of your xorg.conf

Brian1

Last edited by Brian1; 09-21-2006 at 04:32 PM.
 
Old 09-21-2006, 07:12 PM   #8
DJNolz83
Member
 
Registered: Aug 2006
Distribution: Ubuntu
Posts: 91

Rep: Reputation: 15
I wanted to do the same thing on my Dell laptop that I got my hands on not that long ago.
I searched around and found that I could add:
Code:
Option "MaxTapMove" "0"
to my xorg.conf file. (I use FC5, and SUSE 10.0) This I added in to my "input device"/"mouse" sectionof the file.
I added that line of code to the applicable file, and whaddya know? after a reboot, i can no longer "clikcy" with my touchpad!(although, my "f" menu seems to dissapear when I go to move my pointer over the top of it!)

If your /etc/X11/xorg.conf file doesnt have this option already in there, just add it in!
 
Old 09-22-2006, 06:21 AM   #9
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
It is also possible that the touchpad is using the ps/2 driver. Try adding a synaptics device to xorg.conf, set the server to use it and then try modifying the synaptic settings. See "man synaptics" for more information.
 
Old 09-25-2006, 07:53 AM   #10
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Original Poster
Rep: Reputation: 15
Okay, so I commented out all of the Wacom entries, and the touchpad still works, so I guess that means that the Wacom entries are bogus.

I also added this line...
Code:
Option "MaxTapMove" "0"
...to the mouse input device entry. No dice. The touchpad still left-clicks with a tap.

I guess I'll have to read up on what option parameters are available for the "configured mouse" entry in xorg.conf.
 
Old 09-30-2006, 10:54 PM   #11
eerok
Member
 
Registered: Nov 2005
Location: Canada
Distribution: Debian
Posts: 167

Rep: Reputation: 32
I turned off the tap on the touchpad on my presario with this (in the synaptics section of xorg.conf, of course):

Code:
    Option    "TouchpadOff"    "2"
This turns off the tap and scroll features. "1" turns off all the touchpad driver features. (There's a man page on this stuff if you need more info ... "man synaptics"))
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling Laptop Touch Pad while External Mouse is available... HiIamBill Linux - Hardware 1 07-24-2006 11:31 AM
disabling tapping in linux alanalover89 Linux - Laptop and Netbook 1 08-10-2005 03:50 AM
Touch pad tapping question pgte3 Linux - General 2 09-28-2004 09:10 AM
Presario 700 Touch Pad Scroll Prob. Soulja1 Linux - Laptop and Netbook 2 10-15-2003 06:47 PM
Touch pad Help fimanne Linux - Laptop and Netbook 3 09-11-2003 09:10 AM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration