LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 11-22-2007, 11:23 PM   #1
5muggl3r
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Rep: Reputation: 0
desktop shortcut for File System


What is it?

I'm trying to configure an old WinBook XL laptop but the touchpad's not working, not even when I plug in an external mouse. Been scanning the net for desktop/system keyboard shortcuts but I can't find one for this specific problem. So if you know it, I'd appreciate it.
 
Old 11-23-2007, 01:35 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Have you looked in the BIOS to see if it's disabled there?

Have you <Linux> Googled it?

Last edited by Bruce Hill; 11-23-2007 at 01:36 AM.
 
Old 11-23-2007, 03:19 AM   #3
5muggl3r
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
You know, I Googled the exact same phrase but somehow missed that link (dag!). Thanks though.

Rebooted, removed PCMCIA card, entered BIOS, tried following:
-> Trackpoint: Enabled = (exit>save>boot>touchpad still not working)

-> Trackpoint: Enabled
PS/2 Device: ExtPS2|TrackP = (exit>save>boot>screen goes dead although OS still running because I can (blindly) login and restart)

-> Trackpoint: Enabled
PS/2 Device: Auto = (exit>save>boot>screen ok again, touchpad not working)

-> Trackpoint: Disabled
PS/2 Device: N/A
TouchPad: Auto = (exit>save>boot>attempt w/external mouse, screen dead, have to blindly login/restart)


Did some more searching, apparently I have more issues related to this:
- during bootup, I get "acpi=force is required to enable ACPI"
- this is probably also causing me not to shutdown properly
- found link at: http://ubuntuforums.org/archive/index.php/t-416645.html
- it states "you can add acpi=force to the end of the kernel line in /boot/grub/menu.lst to force ACPI on."
- since I'm a Linux noob, how exactly do I get to this kernel line? I'm gonna require a step-by-step

Back to dead touchpad issue:
- link you provided states: "You'll need to pass the following to the kernel in your lilo.conf, or the keyboard and mouse won't work (irq conflict with the cardbus): append="pci=irqmask=0xafff"
- again, how exactly does one 'pass' something to a kernel in a 'lilo.conf'?


Any instruction would be appreciated.

-n00b

-----------
WinBook XL laptop
Xubuntu 7.1
300mhz Pentium, 128 MB RAM
 
Old 11-23-2007, 03:50 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Just add that line in /etc/lilo.conf here:
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/sda
append="pci=irqmask=0xafff"
then issue "lilo" and if there are no errors, reboot.

Last edited by Bruce Hill; 11-23-2007 at 03:53 AM.
 
Old 11-23-2007, 10:37 AM   #5
5muggl3r
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
I assume you mean for me to just go into a terminal and type exactly what is written in the box. Problem: Terminal is crashing. I know how to fix it, but I need access to the 'File System' desktop icon.

Also tried logging in with 'Xfce Terminal Session' but that just made screen go dead. I have access to 'Applications' menu if that helps.

When you say "issue lilo", does that mean to start a program called 'lilo'?

Last edited by 5muggl3r; 11-23-2007 at 10:50 AM. Reason: more info
 
Old 11-23-2007, 12:23 PM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Since this option worked for you
Code:
-> Trackpoint: Enabled
PS/2 Device: Auto = (exit>save>boot>screen ok again, touchpad not working)
use it to boot the laptop.

When you get to the login prompt
Code:
login: _
type root and then press Enter.

When it reads
Code:
password:
type your root password, and then press Enter.
(NB: Your root password is masked, so you won't see anything as you type.)

Now you need to edit the file /etc/lilo.conf (from your previous post I assume you have this file). The easiest editor to use at this point is probably pico, so at the prompt type:
Code:
pico /etc/lilo.conf
and press Enter, which will open the file. Move the cursor to the end of the line which reads
Code:
boot = /dev/sda
(your line might read /dev/hda) and then press Enter which will give you a blank line. There you type
Code:
append="pci=irqmask=0xafff"
and then look at the bottom of your screen. With pico I think you enter "Ctrl+X" to save.

After you save the file with your changes, and get back to the prompt, type
Code:
lilo
which will return some output to your screen. If there are errors, post them here. If not, then reboot the laptop and see what happens ...


NOTES: When we say issue "lilo" that means type lilo at the prompt and press Enter. You type the text/string in the quotes, but not the quotes, and press Enter.

If you get back into the system, you need to navigate to this page
Code:
http://tille.garrels.be/training/tldp/index.html
in your web browser and study that before going further.

Last edited by Bruce Hill; 11-23-2007 at 12:26 PM.
 
Old 11-23-2007, 01:31 PM   #7
5muggl3r
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Hmmm,

Tried logging in as root, but it wouldn't work
(read on a wiki that Root account in Ubuntu is locked)
I was able to use Thunar File Manager to get to Xterm and then used sudo for the commands you gave me.

The file camp up empty, which probably means I didn't have the file to begin with (used Ctrl+Y and Ctrl+V to PgUp/PgDn). Right? Is the solution to download or install lilo.conf? Or is that just not going to work? (the matter regarding lilo.conf was due to me reading post: http://www.linuxquestions.org/hcl/sh...hp/product/977 , that person was using VectorLinux but had same laptop and same issue).

Thanks for the Linux howto book; seen a lot of those online, some of those are easier to read than others.
 
Old 11-23-2007, 05:35 PM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I believe Ubuntu uses GrUB and not LiLO. So you need to edit /boot/grub/menu.lst or whatever is the GrUB equivalent of /etc/lilo.conf for LiLO.
 
Old 12-26-2007, 10:01 AM   #9
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
Comments & Compliments
Bruce, your post #6 is a thing of patience, clarity, & beauty.

5muggl3r, you have learned early to add sudo to suggested commands.


All 'buntu users:
Please remember that your chosen distro is a bit odd in its treatment of root privilege. It's in the minority that way & many folks who will offer advice don't know about your need to prefix "sudo" to some of their suggestions.

Remember you can always "sudo su" to become root temporarily.

Please mention that you are using a 'buntu when you ask Q's outside a 'buntu forum -- that may alert at least some of your potential helpers to be mindful of this difference.

If you have activated your root acct., say so.


All non-'buntu users attempting to help 'buntu users:
They don't have regular root access, most especially they don't have a root password -- "sudo" asks for the regular user password.
Phrase your advice accordingly.
 
  


Reply

Tags
dead, mouse, touchpad, trackpad, xl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating a desktop shortcut with a script file ben44b Linux - Newbie 5 01-07-2007 07:24 PM
Desktop Shortcut Magic02 Linux - Newbie 1 07-03-2005 03:48 PM
desktop shortcut? Sean2 Mandriva 3 12-11-2003 08:13 PM
Shortcut to Desktop? Gerardoj Linux - Software 3 09-29-2003 04:29 PM
Desktop Shortcut MasterC Linux - Software 13 09-27-2002 10:36 AM


All times are GMT -5. The time now is 01:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration